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Introduction

Welcome to Macro Express Pro

Macro Express is the premier macro utility on the market. Use Macro Express to
record, edit and play back mouse and keyboard macros. Its powerful tools and
robust features will noticeably boost productivity.

What is a Macro?

A macro is a set of written or recorded commands that can be played back at will
to perform a specific task. These tasks can be as simple as inserting a name and
address into a word processor to something more complex such as launching a
program, copying data from it, activating another program, pasting the data into it
and repeating the steps several times.

Tasks performed by macros are typically repetitive in nature allowing significant
savings in time by executing the macro instead of manually repeating the
commands.

Creating a Macro

There are several methods available to create macros with Macro Express. The
simplest is to capture (record) keystrokes and mouse movements. Another method
is to use the Quick Wizards to build a macro through a series of questions and
prompts. Or build more complex macros with the easy to use Script Editor or
Direct Editor. The tutorial provides examples of creating macros using each of
these methods.

Playing Back a Macro

Macro Express provides a number of methods for executing macros. These include



the use of Hot Keys, Shortkeys, Scheduled Macros, Window Activation, Mouse
Clicks, Popup/Floating Menus and others described below.

1. A Hot Key is a set of keys on the keyboard that are pressed to initiate the
macro. This could include pressing CTRL+ALT+R or CTRL+F12 or any
number of combinations.

2. A Shortkey is a small string of characters. When a matching combination is
typed on the keyboard, it is erased and the assigned macro executes. For
example, type /add to insert an address into another application.

3. A Scheduled Macro executes on a given time schedule.

4. A Window Activated macro runs when a specific window gains focus
(appears) on the computer screen.

5. Start a macro by clicking on a specific area of the screen with the left, right
or middle Mouse button.

6. A Popup Menu or Floating Menu is basically a list of defined macros. Once the
list is displayed, click on the desired macro or press an associated number or
letter to execute the macro.

7. Activate a macro through a Batch File or Command Line.
8. Execute macros by using Windows API calls or Windows Explorer.
9. Run a macro from the Macro Explorer by using the Run Macro Now option.

10. Start a macro when a particular word or phrase is copied to the
Clipboard.

11. Invoke a macro when the information in a specified File or Folder
changes.

12. Activate macros when a Process starts or stops running or when the
TCP/IP stack becomes available or unavailable.

13. Trigger macros from a System Event, such as a Windows message,
screen resolution or color change.

Macro Scopes

Macro scopes may be used to place restrictions on macros. Assign macros to play
back in all Windows programs, in one specific window or program, or in every
program except the one selected. The tutorial section also provides a few examples



of how to do this.



Quick Start Guide

Macro Express Pro is a utility to help you automate repetitive computer tasks. In
the process it will save you time and money.

This guide covers a few basic concepts to help you better understand Macro
Express.

Starting Macro Express

The default installation of Macro Express places a shortcut in the Windows Startup
folder. This action causes Macro Express to load every time Windows starts. To
open the Macro Express window do one of the following:

1. Press the system hot key of Ctrl + Alt + Shift + W

2. Left click on the Macro Express icon in the Windows notification area.

3. If the icon is hidden, left click on the triangle button to show the hidden
icons. Left click on the Macro Express icon.
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Player and Editor
Macro Express is comprised of two main components, the Macro Express Player
and the Macro Express Editor.

Macro Express Player

The Macro Express Player is what executes macros and it must be running in
order for macros to play back. When you run Macro Express, you are really
running the Player.

By default, the Macro Express Player shows up as an icon in the notification
area. From this icon you can invoke the Macro Express Editor or shut down the

Macro Express Player.

You can optionally set the Macro Express Player to be completely hidden so that



no icon shows in the notification area. With this option set, you would need to
use the "System Macros" to invoke the editor or terminate the program.

Macro Express Editor

The Macro Express Editor is the tool used to create and edit macros. The Editor
cannot be run by itself. The Player needs to be running in order to open the
Editor.

Macros

A macro is a script containing commands that automate computer tasks. Each
command performs one step, such as moving the mouse, launching a program or
entering keystrokes.

There are several methods available for creating macros. No programming
language or special skills are required or necessary.

1. Over two dozen Quick Wizards guide you through a series of questions and
build the macro for you.

2. Record keystrokes and mouse movements with the easy to use Capture
process.

3. Utilize the Script Editor or Direct Editor to write more powerful macros.

Macro Activation
Macro Express provides a number of options for executing (running) a macro.

1. Press a hotkey such as Ctrl + R or Alt + F11. Choose from over 840
combinations.

2. Type a shortkey - a short letter combination from 2 to 32 characters.

w

Run the macro on a schedule - hourly, daily, weekly, monthly or practically
any other schedule.

Run automatically when a window opens or closes.

Click on a specific area of a screen or window.

Use popup or floating menus

Run a macro when a specific directory has been modified

Initiate a macro based on the contents of the clipboard

© ® N o g A

Plus others ...



Files

Macros shown in the Macro Express Pro - Explorer window are saved to a .mex
macro file. The Explorer window displays the name of the .mex file in use and its
location.

When the program is first installed, two .mex files are created - macex.mex and
samples.mex.

macex.mex
On initial installation, this file does not contain any macros. It is suggested that
you start with this file to write and save new macros.

samples.mex

The samples.mex file contains a number of sample macros that you may use for
reference. It is recommended that you do not use this file as the default to
create and store macros.

Additional .mex macro files may also be created for use. Open the Macro Express
Pro - Explorer window and click on File and New File to create a new file. Or click
on File and Open File to load in a file that you previously created and
subsequently closed.

Converting from prior versions of Macro Express

Some preferences are not transferred from prior versions of Macro Express. You
will need to configure Macro Express Pro by clicking Options and Preferences in
the Macro Express Editor. Read the help topic “"Upgrading from v3.x"” in the Macro
Express help for more information.

Tutorials
Written Tutorials and Video tutorials walk you through the process of creating and
running macros.

Context Sensitive Help
Macro Express contains extensive help. Access the appropriate help topic by
clicking the Help menu or by pressing F1 in any open Macro Express window.


https://www.macros.com/videotutorials.htm

Program Navigation

Macro Express Pro consists of several components which may be accessed by
clicking on the icons or accessing through the menu commands. Each component is
briefly discussed below.

By default, the program opens to the Macro Express
Pro - Explorer. This displays the list of macros in the
file currently open. When saving macros in the
Explorer editors or other options, the program returns to the
Macro Explorer.

Macro

New File |[Create a new macro (.mex) file.

: Open an existing macro (.mex) file. Or click on the
= Open File [triangle button to view a list of recently used macro
files and select one to open.

Click on the New Macro button to start the process of
New building a macro in the Script Editor or Direct Editor.
b The Script Editor is the default editor. If desired, click

Macro on the Direct Editor icon while in the Script Editor
to switch to the Direct Editor.
[}“ RUCNG Click this button to run the macro that is highlighted
in the Macro Express Pro - Explorer window.
_ Highlight a macro from the list of already created
Edit macros. Click on the Edit Macro button to open the
& |Macro Script Editor and display the macro. Or double click

on the macro in the list to open it in the Script Editor.

Starts the process for recording or capturing a
H" ) |Capture macro. Keystrokes and mouse clicks/movements are
recorded and saved.

S Quick Opens the Quick Wizards dialog. There are 25+
| £ Wi d different wizards to provide step by step instructions
1Zards |for creating various macro types.

Macro Express has its own recycle bin. Any macros
deleted from the Macro Explorer are sent to the

. Recycle Bin. If a macro is deleted by mistake it can
Bin be restored to its original file. Or the macros in the
recycle bin may be removed permanently.

ez |Recycle
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Converting from v3 or v4 to Macro
Express Pro 6

By default, Macro Express Pro 6 installs to a different folder than Macro Express 3
or Macro Express Pro v4.

1. Macro Express Pro allows more than one macro to run simultaneously. When
importing or opening a v3 macro file in Macro Express Pro, you will see the
message displayed below. Answer Yes to place a File Lock command in each of the
macros being converted. This prevents the macro from playing while another
macro is already running.

Notice

For backwards compatibility, Macro Express Pro can add
0 some commands that prevent macros from running

simultaneously.

These commands can be removed or added later by editing

the macro.

Do you want to add these locks?

Yes No

2. Macro Express 3 files converted to the Macro Express Pro file format cannot be
converted back to the older format. Keep backup copies of the version 3 macro
files if you ever intend to revert back to Macro Express 3 use.

When converting the file to the Macro Express Pro format, a backup copy of the file
in Macro Express 3 format is created. The backup is saved to the same location as
the original file.

3. Macros written to automate Macro Express may not convert properly because
the Macro Express Pro window titles have changed from v3. The accelerator keys
have also changed.

4. Macros written in Macro Express Pro v4 will convert seamlessly to Macro Express
Pro 6.



Installing Macro Express

Installing Macro Express

The steps for installing Macro Express Pro are fairly standard.

1. First download the program from www.macros.com/download.htm.

2. Save the downloaded file to a folder on your hard drive.

3. Locate the downloaded file and double click the .exe file to start the
installation process.

4. Follow the on screen instructions to complete the install.

If not familiar with Macro Express, please read through the Quick Start Guide and
Tutorial sections of the Help file.

Licensing Macro Express Pro

If you have purchased the license for Macro Express you will also receive a license
code. From the Macro Explorer click on Help > License Macro Express to activate
the License Information window. Enter your name and code exactly as they appear
on the license instructions you received when you purchased Macro Express. Press
OK to save the license information.

See the Advanced License Information topic for consideration of Administrator and
non-Administrator login rights and Macro Express licensing.



https://www.macros.com/download.htm

Advanced Installation
Quiet Install

A quiet (or silent) install means Macro Express Pro will be installed without the user
having to answer any questions during the installation process. This is helpful for
installing Macro Express Pro from within another setup program or installing from a
server on a network.

The /quiet command line parameter tells the Macro Express Pro installer to do a
quiet Install. This option must include the slash and must be in all lowercase. The
Macro Express Pro Setup program must be run with elevated privileges (as
administrator) when the /quiet parameter is used.

Macro Express Pro will not be automatically launched when the /quiet option is
used during installation.

Installation options

These command line options allow you to adjust how Macro Express Pro is
installed. You can choose things such as where to install the program, whether
Macro Express Pro should be put in the Startup folder so it is automatically
launched when Windows starts, or whether the Quick Start Guide should be
displayed after Macro Express Pro is installed.

Each option consists of a property name and value separated by an = sign.
Property names must be in UPPERCASE, no spaces are allowed on either side of
the = sign, and property values that are literal strings must be enclosed in
quotation marks.

INSTALLPATH=c:\myprograms\Macro Express Pro
Used to override the default installation folder.

STARTUP=N
Tells the Macro Express Pro installer to not create a shortcut in the Windows
Startup folder that launches Macro Express Pro when Windows starts up.

QUICKSTART=N
Do not display the Quick Start Guide when the program is launched for the first
time.

LICENSENAME="Your License Name"
LICENSECODE="AB3E6-45F98-1200Z-34CC2-DF65R"

Use these properties to enter the Macro Express Pro license information. If the
license is not entered here it may be entered when Macro Express Pro runs.



v Note: This license information is for demonstration purposes only. Use the License Information
received upon purchase of Macro Express Pro. Both the License Name and License Code are
required.

CONFIGFILEPATH="c:\InstallFiles\Macro Express Pro.wcfg"
This allows setting the default preferences at install time.

To do this, install Macro Express Pro on a computer and set the preferences to
desired settings. Follow by clicking Tools > Export Program Configuration to create
a file such as Macro Express Pro.wcfg containing the preferences.

NOEDITOR=Y

Installs the Macro Express Pro player but does not install the editors used to create
or modify macros.

RUNQUIET=Y

This property installs Macro Express Pro and sets the most common preferences for
a group of networked computers. These options apply to the user installing the
program and any new users:

« The Splash Screen is disabled

« The Editor is not loaded when the program starts

« The Quick Start Guide is not displayed the first time the program runs
« Backups are disabled

« The First Time setup wizard is disabled

« Macro Halted messages are suppressed

« The samples.mex macro is not copied to the default macro files folder
« The display of periodic messages during 30-day trial is disabled

« Check for updates is set to Manually

Examples

The Macro Express Pro Setup program must be run with elevated privileges (as
administrator) when the /quiet parameter is used.

Example 1

Installs Macro Express Pro in the c:\Programs Files (x86)\Macro Express Pro 6
folder with default preferences. After the installation is complete, the program will
be licensed to John Smith.

MacroExpressPro6Setup.exe /quiet LICENSENAME=" John Smith"
LICENSECODE="AB3E6-45F98-1200Z-34CC2-DF65R"



Example 2

Installs Macro Express Pro in the d:\Programs\Macro Express Pro 6 folder. Macro
Express Pro will not be launched when Windows is started. The Quick Start Guide
will not be displayed when Macro Express Pro is first launched. After the installation
is complete, the program will be licensed to John Smith.

MacroExpressPro6Setup.exe /quiet INSTALLPATH="d:\Programs\Macro Express Pro 6"
LICENSENAME=" John Smith" LICENSECODE="AB3E6-45F98-1200Z-34CC2-DF65R" STARTUP=N
QUICKSTART=N

Example 3

Installs Macro Express Pro in the c:\Programs Files (x86)\Macro Express Pro 6
folder with the most common preferences for a group of networked computers.
After the installation is complete, the program will be licensed to John Smith.

MacroExpressPro6Setup.exe /quiet RUNQUIET=Y LICENSENAME=" John Smith"
LICENSECODE="AB3E6-45F98-12002-34CC2-DF65R"

Example 4

Installs Macro Express Pro in the c:\Program Files (x86)\Macro Express Pro 6 folder
and sets the preferences to those contained in the MacroExpressPro.wcfg file. After
the installation is complete, the program will be licensed to John Smith.

MacroExpressPro6Setup.exe /quiet LICENSENAME=" John Smith"
LICENSECODE="AB3E6-45F98-1200Z-34CC2-DF65R"
CONFIGFILEPATH="E:\MacroExpressProlnstall\MacroExpressPro.wcfg"

v Note: This license information is for demonstration purposes only. Use the License Information
received upon purchase of Macro Express Pro. Both the License Name and License Code are
required.



Advanced License Information

Windows can be configured to allow different users to log onto a single computer.
Some versions of Windows require a user to log in. Normally only one user is
logged in at a time. One or more login names have access to the entire computer
and are said to have administrative access rights. Other login names do not have
administrative access rights. These login names have restrictions about what they
can change on the computer.

If the Name and Code are entered into the License Information dialog when logged
in as an administrator, Macro Express Pro is licensed for all users. If, however, the
License Information is entered when logged in as a non-administrator, Macro
Express Pro is only licensed for that user login.



Uninstalling Macro Express

To remove Macro Express from the computer follow the steps below:

1. Click on File > Terminate Macro Express Editor & Player to close the program.

2. From the taskbar, click the Start menu button to open the Start menu.

3. Open the Windows Control Panel.

4. Based on the version of Windows you are running, select the option from the
control panel used to uninstall applications.

5. Highlight Macro Express Pro in the list of installed programs.

6. Again, depending on your version of Windows click on the option to remove
the program.

7. Follow the on-screen prompts to remove Macro Express from your computer.

**There is not an uninstaller for the portable version. Use Windows/File Explorer to delete the files.




Tutorials

Tutorial - Introduction

The tutorials in this section demonstrate how to create various macro types and
how to use many of the program features.

Creating Macros
There are several ways to create macros with Macro Express.

1. Capture (record) your keystrokes and mouse movements.
These two tutorials show different options for recording a macro.

Capture a Macro using the Capture Icon

Capture a Macro - System Hot Key

2. The Quick Wizard guides you through a series of questions and

builds the macro.
Step through the Quick Wizard tutorial to create a reminder message.

Create Macro with Quick Wizard

3. Write the macro in the Direct Editor

Learn more about the Direct Editor with the HotKey tutorial and how it can be
used to write macros.

Creating a Hot Key Macro

4. Scripting Editor

Use the Scripting Editor to create simple to complex macros. Each command is
displayed on a separate line in the script for easy viewing and modification. These
tutorials demonstrate the use of the Scripting Editor.

Creating a Shortkey Macro

Creating a Scheduled Macro

Using Window Controls

Copy and Paste between Two Applications
ASCII Text File Process




Using Text String Variables

Using Integer Variables

Other Tutorials

This tutorial shows how to build a popup menu. Create a menu of macros to display
on screen and just select the one you want to run.

Create a Popup Menu

Determine where macros will run using the macro scope feature. This tutorial
shows how to have macros only run in specific programs or windows, run in all but
one or several windows, or run in all programs.

Macro Scope

The videos for each of these tutorials may be viewed online at www.macros.com.



https://www.macros.com/videotutorials.htm

Creating a Hot Key Macro

In this exercise we will create a macro assigned to a hot key. When complete,
pressing the hot key will run the macro.

Setting up the Macro and Assigning the Hot Key

1. From the Macro Express Pro - Explorer menu click on Macro > New Macro to

open the Create New Macro window.

2. Hot Key should already be selected as the Activation.

3. Click on the HotKey edit box to place the cursor in this field.

4. Hold down the CTRL key, the SHIFT key and the T key at the same time and
release them.

5. CTRL+SHIFT+T should appear in the edit box. This is the hot key we will
define for the macro.

6. Enter "My Address" in the Nickname field.

7. Click OK to open the Script Editor.

8. Next, click on View > Direct Editor to open the Direct Editor, which we will
use to create the macro.

Other methods to create macros are via the Quick Wizards or capturing (recording)
a macro. These options are reviewed in other sections.
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The Direct Editor looks like the screen shot above.

Creating the Macro

1. In the edit field, type in your address.

2. Click on the Scope Tab and make sure Global is selected. Global is the default
option.

3. Click on the Save and Close button to save the macro and close the Editor.

4. Open the Macro Explorer window to see the newly defined macro, My

Address, added to the list of available macros.

Playing Back the Macro

1. First, let's run the notepad program.



2. Once notepad is running, hold down the CTRL key, the SHIFT key and the
letter T. Then release all the keys.

3. Your address will type out into the notepad program.



Creating a Shortkey Macro

This topic shows how to create a macro assigned to a Shortkey. When completed
the macro will play back your email address.

Defining Shortkeys Default Settings
First, we need to define the default settings that will apply to all Shortkeys that

you may later create.
1. From the Macro Express Pro - Explorer menu click on Options > Preferences
to load the Preferences window.
2. Click on Activations and then the Shortkeys tab to display the Shortkeys
options.
3. Select the Use Prefix Keys option and enter z in the Prefix Keys entry box.

4. Click the OK button to return to the Macro Explorer.

v Note: This setting requires that z be pressed before typing any Shortkey macro or it will not run.

Setting up the Macro and Assigning the Shortkey

1. From the Macro Express Explorer menu click on the New Macro icon to open

the Create New Macro window.

2. Select Shortkey from the Activation list.

3. Type "email" (without the quotes) into the Original Shortkey entry space.

4. In the Nickname box, enter My Email Address and click OK to open the Script
Editor.

Creating the Macro

1. In the Script Editor click on the Scope tab and make sure Global is selected
from the drop down menu.
2. Now click on the Script tab to start writing the macro.

3. Scroll down the list of commands and click on the Keyboard command to



expand this listing.

4. Double click on the Text Type command found in this group to activate the
Text Type window.

5. Type your email address in the Keystrokes field.

6. If you want to have the macro paste the text into your application via the
Windows clipboard, select the Use Clipboard to Paste Text option from the
drop down menu. Otherwise the text is inserted into your application using
the Simulate Keystrokes default option, which types out the text letter by
letter.

7. Press the OK button to save the entry and return to the Script Editor.

v" Note: A new entry should now appear under the section called Macro Script. This entry should read
Text Type: followed by the email address that you entered. If you made a mistake entering your
email address, you can double click on this entry and edit the address in the Text Type window.

8. From the Script Editor, click on the Save and Close button to save the macro
and close the Script Editor.
9. Open the Macro Explorer to see the newly defined macro, "My Email

Address", added to the list of available macros.

Playing Back the Macro

1. To test the macro, run the notepad program.
2. Once notepad is running, type the following: zemail

3. Watch as your email address is typed into the notepad program.



Creating a Scheduled Macro

This page demonstrates creating a Scheduled Macro, one that plays back on a
schedule. To start, click on the New Macro icon from the Macro Express Pro -
Explorer window to open the Create New Macro window.

Setting the Schedule

o

. Select Schedule from the Activation list to display the scheduling options.

2. For this example select the "When a Specified Time has Elapsed" from the
Run the Macro drop down menu.

In the Schedule tab, select 0 hours, 0 minutes and 15 seconds.

Click on the Range tab.

Select the Play Macro Indefinitely option from the drop down list.

o 0 bk~ w

Leave the "Start calculating the next runtime at" fields alone. Check to make
sure the time listed is not later than the time on the computer clock. Make
sure that the date displays today's date.

7. Leave the "Run the macro between these hours of the day" option not

checked.

8. Leave every day of the week selected.

9. Enter "Display the Time" as the macro nickname.

10. Click the OK button to open the Script Editor,

Based on the schedule just set, the macro will run every 15 seconds.

Setting the Program Scope

We'll create this macro to only play back in the Notepad window and only if it is
already running.

1. Click on the Scope tab and select Window/Program Specific.
2. Click on the Add Window button to open the Select Window dialog.
3. Click on the Visible tab and enter "notepad" (without the quotes) in the



Window Title edit field.
4. Select Partial Match from the drop down list.
5. Leave the option "A window with this title must be on top" unchecked.

6. Click OK to save the Scope information.

Building the Macro

1. Click on the Script tab to start writing the macro.

2. To begin, expand the Windows/Programs category of commands.

3. Double click on the Window Activate command.

4. Enter "notepad" (without the quotes) for the Window Title and click on the
OK button.

5. Select Partial Match from the drop down list and click OK to save the
information and insert into the macro script.

6. Expand the Variables category of commands.

7. Double click on Date/Time to open the Date/Time window.

8. In the Date/Time tab, make sure the "Set it to the current date/time" option
is selected.

9. Click on the Operation tab.

10. Select the "Type the Date/Time stamp out" option.

11. Enter "h:mm:ss" (without the quotes) in the Choose a Date/Time
Format edit box.

12. Click OK to save the changes.

v Note: There should be two lines of script displayed in the Script Editor. Double click on either of
these entries to make changes.

13. From the Script Editor, click on the Save and Close button.

14. Open the Macro Explorer window to see your newly defined macro,
Display the Time, added to the list of available macros.

Playing back the Macro



As long as Macro Express is running, a timed macro should be ready to execute.
However, in this example the timed macro will only execute if Notepad is running.

1. To test the macro, run the Notepad program.
2. Once Notepad is running, just wait.

3. The time is typed into Notepad every 15 seconds.

Disabling the Macro

After verifying that the macro works, either delete or disable this macro since you
won't want this Scheduled Macro to continue executing every 15 seconds
indefinitely! To delete the macro, highlight the macro in the Macro Explorer list and
choose "Macros > Remove Macro" from the menu.

To keep this example around, but not to play back every 15 seconds, right mouse
click on the macro. Left click on Disable to disable the macro. The macro is now
displayed in the Explorer window with italicized red font and possibly a line drawn
through it, depending on Preference settings. This quickly alerts that the macro is
disabled and will not play back until it is enabled.



Capture a Macro using the Capture Icon

This example shows how to record a macro. We'll capture the macro in the
Windows Paint program.

Once Paint is running, we want to switch directly to Macro Express. If running
Macro Express in the notification area, left click on the Macro Express icon in the
notification area; otherwise click on Macro Express in the taskbar.

Defining the Macro

1. From the Macro Express Pro - Explorer window click on the Capture icon on

the sidebar to open the Create New Macro window.

2. HotKey should be the default Activation.

3. Click on the HotKey edit box to place the cursor in this field.

4. Next, hold down the SHIFT key, the CTRL key and the U key all at the same
time and release them. This is the hot key assigned to the macro we record.

5. Make sure the box next to Wait for the Hot Key to be Released Before
Activation is checked.

6. Enter My Paint Drawing as the nickname and click OK.

Defining the Capture Options

The Capture a Macro window opens so that the default capture options may be
modified before capturing the macro. The default settings are defined from the
Macro Explorer window in Options > Preferences > General > Capture. Let's adjust
the capture settings for this macro capture.

Set Scope

The first thing to do is to set the scope so that the macro only starts in the MS
Paint program.

1. Click on the Set Scope button to open the Set Scope window.
2. Change the scope to Window/Program Specific if not already selected.

3. Click on the Add Program button to open the Select a Program Window.



4. Click on the Running Processes tab and highlight mspaint.exe.
5. Make sure that the "This program must have a window on top" option is
checked.

6. Click OK and click OK again to save and return to the Capture a Macro
window.

Other Capture Options

1. Check the Capture the Keystrokes option.

N

Check the Capture Mouse option and select the Relative to Window option
from the drop down menu.

Make sure the Capture and Restore the Window Size option is checked.

Only Capture the Mouse Clicks should not be checked.

From the drop down menu select Capture the Macro Speed at Actual Speed.

o g b~ W

Choose "untitled - Paint" from the drop down list of the Begin Capture in
Window section.

Start Recording
Now we are ready to record the mouse movements, clicks and keystrokes.

1. Click on the Capture button. This closes the Capture a Macro window and
opens the Paint window.

2. At this point the macro is now recording. We'll just draw a simple face in
Paint.

3. Click on a color.

4. Draw a circle and place two eyes, a nose and mouth within the circle.

5. Terminate the capture by pressing the hot key we assigned to the capture -
CTRL+SHIFT+U.

6. A message appears indicating that the capture is complete.

Play back the Macro



1. Open the Paint window. If it is not already the active window, click on the
Paint entry in the task bar.

2. We need to start with a clean screen in Paint. So click on File > New in Paint
and follow the prompts to have a fresh screen.

3. Press the hot key CTRL+SHIFT+U to start the macro playback.

4. The face just drawn will be redrawn complete with any hesitations made
while capturing!



Capture a Macro - System Hot Key

Macro Express has eight hot keys automatically assigned as System Macros. One
of these System Macros is called Start / Stop Capture and by default is defined as
CTRL+ALT+SHIFT+X. Pressing CTRL+ALT+SHIFT+X starts the recording of a
macro. Pressing it a second time stops the recording. The system macro hot key
combination may be changed to another hot key combination not presently being
used in Macro Express.

Capture Settings

Before recording any macros using the System Hot Key we first need to define the
default capture settings.

1.

v

From the Macro Express Pro - Explorer click on Options > Preferences >
General and select the Capture tab to display the Capture default settings.

Note: These are the settings that are used when the System Start / Stop Capture Hot Key function
is invoked. These are also the default settings that appear when clicking on the Capture icon to
start a macro recording.

. Leave the scope set to global.

3. Check the Capture Keystrokes option.

Check the Capture Mouse option and select the Relative to Window option
from the drop down menu.

Make sure the Capture the Window Size option is checked.

We also want to just capture the mouse clicks. We don’t need to capture
every movement of the mouse. If we were drawing or dragging with the
mouse, then we would want to capture all mouse movements.

Turn off the “Capture at a specific speed” option to capture the macro without
any delays. Be careful when doing this. In some applications the macro may
play back too fast and not work correctly.

Check the Display a Prompt Before Capturing box to display a message
indicating the capture is starting.

Click OK to save the settings.



Capturing the Macro

An important thing to remember when recording a macro is to make sure that the
program to start recording in is active and on top. Our example recording uses the
WordPad application.

When recording, try to use keystrokes as much as possible, rather than the
mouse. But there are certain functions that do not have keystroke equivalents and
require the mouse. For this example we'll record a simple macro to change the font
color. This can be done with just keystrokes.

1. First run the Windows WordPad program.

2. Once focus is on WordPad, press CTRL+ALT+SHIFT+X.

3. A notice may appear warning about the use of the ALT key. Click OK.

4. Next appears a notice that the macro is about to start recording. Click the OK

button to start recording.

The macro is nhow recording. Let's do something fairly simple such as selecting a
new font color.

5. Press Alt + h then type C2 to open the text color choices.

6. Arrow down several times to choose a color and press Enter.

7. Terminate the macro capture by pressing the same system macro,
CTRL+ALT+SHIFT+X.

Macro Information

The "Create New Macro" window opens for assigning a macro activation.

1. Select HotKey as the Initial Activation if not already the default.

2. Place the cursor in the hotkey edit window and press CTRL+SHIFT+S.

3. Release the keys to display CTRL+SHIFT+S in the edit box and use as the
macro activation hot key.

4. Type WordPad Color Change in the nickname field and press OK.

Play back the macro



. Open a WordPad window with a little bit of text in it.
. Highlight the text in the WordPad window.
. Press the hot key CTRL+SHIFT+S to run the macro.

. The text color is changed to what we chose in the macro.



Create Macro with Quick Wizard

In this tutorial we'll demonstrate how to create a macro using the Quick Wizard.
The Wizards will guide us step by step through the creation process. For this
example we will create a reminder message to display on screen at the time we
designate.

1.

From the Macro Express Pro - Explorer window click on the Quick Wizards

icon to start the wizard.

. Select the first choice shown - Create a Reminder, etc. option and click on the

Next button.

3. Select the Create a Reminder option and click on the Next button.

8.
9.
10.
11.
12.

The next screen just points out a few possible uses for the reminders. Click
Next to continue.

In the Edit window enter the text. For this example, enter "This is a reminder
to purchase Macro Express at www.macros.com/orders.htm." Click on the
Next button to continue.

Select the Sound Beep notification option to also play a beep when the macro

runs.

. Check the box next to Delete this macro after displaying the reminder. Once

the macro has run, the macro is removed from the list of macros in the

Macro Explorer and sent to the Macro Recycle Bin.

Click Next to set up the schedule for the reminder message.

From the drop down list, change the Macro Run option to Once.
Change the Run At time to 5 minutes ahead of the current time.
Make sure the date is set to today's date and click Next.

Insert "My Reminder" in the Macro Nickname edit field (without the
quotes) and click Finish to close the Wizard.

Open the Macro Express Explorer window to see the new macro in the list of
created macros. Wait the 5 minutes specified and the reminder message will pop
up on the screen.

Close the message and the macro is removed from the macro list in the Explorer



window and sent to the Macro Recycle Bin.




Create a Popup Menu

This example demonstrates how to create a popup menu. Before creating a popup
menu, you must already have some macros defined.

v Note: If you have not done so, first create both a Hot Key macro and a Shortkey macro as
described in the Creating a Hot Key and Shortkey tutorials. This example is based on the

assumption that you have already created these macros.

Initial setup of the menu

1. From the Macro Express Pro - Explorer menu click on Macro > New Macro to

open the Create New Macro window.

2. Make sure that the Hot Key activation is selected and place the cursor in the
hot key edit box.

3. Hold down the ALT key, the SHIFT key and the Z key all at the same time
and release them. ALT+SHIFT+Z should appear in the edit box. This is the
hot key we will use for the popup macro.

4. Enter My Menu as the macro nickname.

5. Check the box next to build as a Popup macro and click OK to open the Menu
Builder.

The Menu Builder

The Menu Builder contains two columns. The left hand column lists all macros
available for use in the menu. The right hand column displays the macros that we
assign to the menu.

Adding Macros to the Menu

For this example we will only include two macros in the menu. But in practice
you can add many more.

a. Highlight the My Address macro (the one we created earlier) and then
click on the green Insert %] button.

b. Next highlight the My Email Address macro (created earlier) and click
on the green Insert button.



These two macros should now be displayed in the right hand column.

Select Menu Style and Positioning

a. Before saving the menu, click on the Miscellaneous tab and make sure
the Menu is Enabled button is checked.

b. Select Nickname and Scope from the drop down menu as the Menu
Style.

C. Enter 500 in both the X and Y menu positioning fields.

d. Check the box next to Place an icon in the notification area option.

Select an Icon to Display in Notification Area

The next step is to select an icon to use with the menu. Right above the Menu
tab and to the left of the Menu Nickname is an icon. Hovering the mouse cursor
over the icon displays the text - Change Macro Icon.

a. Click on this icon to open the Select an Icon window.
b. Click on the Browse (...) button to open a view of the Macro Express Pro
folder.

Double click on the Icons folder to display the folder contents.

You will see a number of .dll files containing icon sets - .ico files.

Double click on the IconsLG.dll file to open the Select an Icon window.

D a O

Click on the blue push pin icon, item number 1, and click OK.

The icon in the Build a Menu window has been updated to reflect the

Q

change made.

h. This new icon will be displayed in the notification area.

i Click on Save and Close to save the menu.

j. Return to the Macro Explorer window to see the newly defined popup
macro, ALT+SHIFT+Z, added to the list of available macros.

Testing the Popup Menu

There are two methods for activating the menu we created. One is to press the hot



key we assigned or to left mouse click on the icon displaying in the notification
area.

Hot Key Activation
Let's test out the popup menu and run the macros in Notepad. Once notepad is

running, hold down the ALT+SHIFT+Z keys.

# Name Scope
@A My Address Global
&B My Email Address Global

Double Click or Press a Number or Letter

A menu like the one above should appear, listing the two macros previously
defined. Either press the corresponding letter or number next to the macro or
double click on the macro in the menu to run the selected macro in notepad.

Notification Area Activation
Another way to invoke the popup menu is to left click on the blue push pin icon in the
notification area. This icon should now be showing in the notification area, because of

the settings defined previously.

Menu Styles
The popup menu may be displayed in four different forms, including Nickname and
Scope, which is what we are currently using. Now take a quick look at the other

options for displaying the menu.

First Part of Macro

a. Double click on the Popup Menu macro from the list of macros in the
Macro Explorer to open the Menu Builder window.

b. Click on the Miscellaneous tab.

C. Select the First Part of Macro option from the Menu Style drop down list.

d. Click on Menu > Save Menu to save the change.

e. Left click on the "blue push pin" icon in the notification area.



f. The menu opens displaying the first part of the contents of each macro.

Icon

a. Close the popup menu and return to the Menu Builder.
b. Click on the Miscellaneous tab and select the Icons Only option from the

Menu Style drop down list.

C. Next, choose the Horizontal option and enter 10 for Maximum Icons per
Row.

d. Click on Menu > Save Menu to save the change.

e. Now click on the "blue push pin" icon in the notification area.

f. The menu displays a list of icons.

g. Click on one of the icons in the menu to run the macro.

Windows Default

a Return to the Menu Builder and click on the Miscellaneous tab.

b. Select the Windows Default option from the Menu Style drop down list.
C. Click on Menu > Save Menu to save the change.

d. Now click on the "blue push pin" icon in the notification area.

e. The menu displays as shown below.

My Address
& My Email Address

X Cancel

f. Click on the macro you want in order to execute the macro.
g. Windows also assigns underscores to each of the macros, where
possible.

h. So in the example above, pressing the M key activates the My Address



Mmacro.



Tutorial - Macro Scopes

Macro Scope

The macro scope indicates under what conditions a macro should play back. Four
categories are available. They are Global, Global Except, Window Specific and
Program Specific.

A. Global macros play back in all Windows programs.
B. Global Except macros run in all Windows programs or windows except the
application or window specified.
C. Window Specific macros run only a window that has a matching Window Title
as specified by the macro.
D. Program Specific macros only play back in a selected program.
Let's look at some real examples of how this all works. To illustrate the process,

let's run two different programs for testing the macro and scope. Run Windows
Notepad and Windows WordPad.

Global Macro

We have actually already created a couple of Global macros. If you have not
created these macros, please refer to the Hot Key section for instructions on
creating the CTRL+SHIFT+T macro. A global macro plays back in all Windows
programs.

To illustrate, bring Notepad to the foreground (click on it in the taskbar). Now
press CTRL+SHIFT+T to see the address typed into the program. Now bring
WordPad to the foreground (click on it in the taskbar). Press CTRL+SHIFT+T to see
the address typed into WordPad.

Program Specific Macro
We will first change the CTRL+SHIFT+T macro to become a Program Specific
macro.
1. Minimize Notepad and WordPad.
2. With Macro Express Pro - Explorer the active window, highlight the
CTRL+SHIFT+T macro (nickname of "My Address") from the Macro Explorer



and click on the Edit Macro button to open the Script Editor.
3. Click on the Scope tab from the Script Editor.
4. From the Current Scope drop down menu, select Window/Program Specific.

5. Click on the Add Program button to open the Select a Program window.

v Note: The Select a Program window has two tabs, Start Menu and Running Processes. The Start
Menu tab allows you to look through programs in your Start Menu to locate the .exe file. Or you can
click on the Browse button to find the file anywhere on your computer.

6. For our example, click on the Running Processes tab to list all programs
currently running on the computer.

7. Make sure that the box next to "This program must have a window on top" is
checked.

8. Scroll through the list of programs running and find notepad.exe.

9. Highlight it in the list and click on the OK button.

10. To see what effect the changes have on the macro and bring Notepad
to the foreground (click on it in the taskbar). Press CTRL+SHIFT+T to see
the address typed into the program.

11. Now bring WordPad to the foreground (click on it in the taskbar). Press
CTRL+SHIFT+T. Nothing happens because the macro is set to only work in
Notepad.

Global Except
The next step is to change the CTRL+SHIFT+T macro to become a Global Except

macro.

1. First minimize Notepad and WordPad.

2. With Macro Express Pro - Explorer the active window, highlight the
CTRL+SHIFT+T (nickname of "my address") macro from the Macro Explorer
and click on the Edit Macro button to open the Script Editor.

3. Click on the Scope tab.

4. From the Current Scope drop down menu, select Global Except.

We can now choose to have the macro work everywhere except a specific window



or program that we select. For this tutorial we will use the program option.

5. Notepad.exe should be displayed as the program that will not allow the
macro to work.

a. If not, highlight any entries and click on the Remove button to delete
them.

b. With no programs or windows selected click on the Add Programs button.
c. From the Select a Program window click on the Running Processes tab to
list all programs currently running on the computer.

d. Make sure that the box next to "This program must have a window on
top" is checked.

e. Scroll through the list of programs running and find notepad.exe.
Highlight it in the list and click on the OK button.

6. To see what effect the changes have on the macro, bring Notepad to the
foreground (click on it in the taskbar) and press CTRL+SHIFT+T. Nothing
happens because the macro is defined to not work with Notepad.

7. Now bring Wordpad to the foreground (click on it in the taskbar). Press
CTRL+SHIFT+T to see the address typed into the program.

8. Activate another program that accepts text input such as an email program

and press CTRL+SHIFT+T. The address types into the program.

Window Specific Macro

The last step is to change the CTRL+SHIFT+T macro to become a Window Specific
macro. The macro only plays if a window with a specific title is open or on top. (A
Window Title is the text that appears in the top caption bar of most windows).

1. First minimize WordPad and Notepad.

2. With Macro Express Pro - Explorer the active window, highlight the
CTRL+SHIFT+T macro from the Macro Explorer and click on the Edit Macro
button to open the Script Editor.

3. Click on the Scope tab from the Script Editor.

4. From the Current Scope drop down menu, select Windows/Program Specific.



5. Highlight Notepad.exe listed in the edit field.
6. Click on the Remove button to delete this entry.
7. Click on the Add Window button to open the Select Window dialog.

v" Note: The Select Window dialog contains two tabs, Visible and Hidden. You may select a window
that is visible or a hidden program window that is never displayed. For this tutorial we will use a
Visible window.

8. Highlight Untitled - Notepad.

9. Check the box next to "A window with this title must be on top".

10. Click OK to save.

11. To see what effect these changes have on the macro, bring Notepad to
the front of the screen (click on it in the taskbar). Press CTRL+SHIFT+T to
see the address typed into the program.

12. Now bring WordPad to the front of the screen (click on it in the
taskbar). Press CTRL+SHIFT+T. Nothing happens because CTRL+SHIFT+T

is set to only work in an Untitled - Notepad window.



Copy and Paste Between Two Applications

Below is a simple example of how to set up a copy and paste routine between two
applications. Use this as a guideline for creating routines between other
applications.

You might be tempted to try and use the ALT+TAB key to switch between
programs. This is actually not always reliable and in fact will not even work via
Macro Express on some computers due to the low level nature of this key
command. The solution is to use the Windows Activate command.

Setting up the Macro

Choose a HotKey and macro Scope.

1. From the Macro Express Pro - Explorer menu click on Macro > New Macro to
open a Create New Macro window.

2. The Initial Activation should default to HotKey.

3. Click on the HotKey edit box to place the cursor in this field.

4. Hold down the CTRL key, the SHIFT key and the P key all at the same time
and release them.

5. CTRL+SHIFT+P should appear in the edit box.
This is the hot key used to activate the macro.

6. Enter Copy and Paste in the Nickname field and click OK to open the Script
Editor.

7. Click on the Scope tab and make sure that the macro scope is set to global.

8. Then click on the Script tab to start building the macro.

Building the Macro in the Script Editor

The object of the macro is to repetitively copy one line at a time over to WordPad.

1. This first command instructs the macro to bring notepad to the front and be

ready to receive keystrokes.

a. Scroll through the list of command categories and click on



Windows/Programs to expand the list.

b. Double click on the Window Activate command.

c. In the Activate Window field, enter "notepad" (without the quotes) as the
Window title.

d. Make sure the Partial Match option is selected. Click on the OK button to
save the entry.

2. The next step in this process is to highlight a single line of text byusing
Shift+End.

a. To do this scroll through the list of command categories and click on
Keyboard to expand the category.

b. Double click on Text Type to open the Text Type window.

c. Click on Shift and then End in the yellow area of this window to insert
<SHIFT><END> into the Keystrokes edit field.

d. Click OK to save the changes.

3. The next step is to copy the highlighted text to the Windows Clipboard.

a. Scroll through the list of command categories and click on Clipboard to
expand the category.

b. Double click on the Clipboard Copy command to insert into the script.

4. Before pasting the text into WordPad, we will first move the cursor to the

next line in notepad so that the macro is ready to copy the next line of text.

a. To do this, scroll through the list of command categories and click on
Keyboard to expand the category.
b. Then double click on Text Type to open the Text Type window.

c. Click on Home and then Arrow Down in the yellow area of this window to



insert <HOME><ARROW DOWN> into the Keystrokes edit field.
d. Click OK to save the changes.

5. This step activates WordPad and allows text entry into this window.

a. To activate WordPad, click on the Windows/Programs category of
commands to expand the list.

b. Double click on the Window Activate command.

c. In the Activate Window field, enter "wordpad" (without the quotes) as
the Window title.

d. Make sure the Partial Match option is selected.

e. Click on the OK button to save the entry.

6. The next step of the macro is to paste the text from the clipboard into
WordPad.

a. Scroll through the list of command categories and click on Clipboard to
expand the category.

b. Double click on the Clipboard Paste command to insert into the script.

7. Now place an <ENTER> in the macro to move the cursor to a new line in
WordPad.

a. Scroll through the list of command categories and click on Keyboard to
expand the category.

b. Double click on Text Type to open the Text Type window.

c. Click on Enter in the list of options in the yellow area of this window to
insert <ENTER> into the Keystrokes edit field.

d. Click OK to save the changes.



8. Two final issues need to be addressed. The first is to place the macro in a
loop so that it copies multiple lines. In this example we will set the macro to

copy the first 5 lines in notepad over to WordPad.

a. Highlight the first line of the macro script - Activate Window: "notepad".
b. Scroll through the list of command categories and click on Repeat to
expand the category.

c. Single click on the Repeat Start option and then click on the Insert
Command Before Selected arrow - the top green arrow of the three insert
arrows to open the Repeat Options window.

d. Make sure the Repeat Start option is selected and enter 5 in the Number
of Times to Repeat entry field.

e. Click OK to save the change and insert the Repeat command as the first

line of the macro.

9. This step closes the repeat loop.

a. Single click on the End Repeat command
b. Click on the Add Command to End of Script button - the bottom of the
three Insert buttons to insert an End Repeat command as the last command

of the macro script.

10. The last thing is to address a possible timing issue. It's possible for
Macro Express to send the Clipboard Paste command before WordPad has
fully activated. So what we need to do is insert a short delay right after

activating either window.

a. Add a Delay command to the script.

1) Scroll through the list of command categories and click on Timing to



expand the list.
2) Then double click on Delay to open the Set Delay window.
3) Select the Delay in Seconds option and enter .5 (one half second).
4) Click OK to save the change.

b. Make a duplicate of the Delay command

1) Find the delay command we just created in the script and highlight

2) Then click on the Duplicate button L=l to the right of the script to

make a copy of this command.
You should now have two Delay commands listed in the script.

c. Positioning the Delay commands in the script.

1) Highlight one of the Delay commands and click on the Up or Down
arrow on the right side of the Macro Script.

2) Move the delay command so that it is positioned below the Activate
Window: "notepad" command and above the Text Type:<SHIFT><END>
command.

3) Highlight the other Delay command and move it so that it is
positioned below the Activate Window: "wordpad" command and above the

Clipboard Paste command.

11. Click on File > Save to save the macro.

Macro Script

The macro script should look like what is displayed below. If the macro does not
look like this, arrange the commands so that they are in the following order.



Repeat Start (Repeat 5 times)
Window Activate: notepad
Delay: 0.5 seconds
Text Type (Simulate Keystrokes): <SHIFT><END>
Clipboard Copy
Text Type (Simulate Keystrokes): <HOME><ARROW
DOWN>
Window Activate: wordpad
Delay: 0.5 seconds
Clipboard Paste
Text Type (Simulate Keystrokes): <ENTER>
End Repeat

Testing the Macro

1. To test the macro run the notepad and WordPad applications.

2. Enter five lines of text into notepad or copy the first five lines of the

macro script displayed above and paste them into notepad.

Make sure you don't have any blank lines between the lines of text.

4. Next, place the mouse cursor at the beginning of the first line of text in
notepad.
5. Then press CTRL + Shift + P to start the macro and watch it switch

between both programs, copying each line from notepad and pasting into

WordPad.



Using Text String Variables

Below is an example of using Text String Variables. There are hundreds, even
thousands of uses for Text String Variables. This example provides an idea of how
they can be used and manipulated.

This macro, when completed, fixes typing transposition errors such as "adn" or
"teh" instead of "and" or "the". Just place the cursor between the two transposed
letters and press the assigned hot key to correct the typing error.

Setting up the Macro

1. From the Macro Express Pro - Explorer menu click on Macro > New Macro to

open the Create New Macro window.

2. Hot Key should already be selected as the Activation.

3. Click on the HotKey edit box to place the cursor in this field.

4. Hold down the F4 key and release it.

5. F4 should appear in the edit box. This is the hot key we will define for the
macro.

6. Enter "Fix Transposed Letters" (without the quotes) in the Nickname field.

7. Click OK to open the Script Editor.

8. In the Script Editor click on the Scope tab and make sure that the macro

scope is set to global.

9. Click on the Script tab to start building the macro.

Building the Macro in the Script Editor
1. Add a Comment line to the script as a reminder on how to use the macro.
a. Scroll through the list of command categories and click on Macro Control

to expand the list.

b. Double click on the Comment command.



c. Type "Place cursor between the transposed letters" (without the quotes)
in the Comments Text edit field.
d. Click OK to save the entry.

The text is displayed in the Script Editor in bold blue font.

2. The next step is to highlight the two letters that are reversed using the Text

Type command.

a. Scroll through the list of command categories and click on Keyboard to
expand the category.

b. Double click on Text Type to open the Text Type window.

c. Click on Arrow Left from the list of options in the yellow area of this
window.

d. Then click on Shift Down, Arrow Right, Arrow Right and Shift Up.

The entire entry should look like the following: <ARROW
LEFT><SHIFTD><ARROW RIGHT><ARROW RIGHT><SHIFTU>.

e. Click OK to save and return to the Script Editor.

3. This next step cuts the highlighted text and copies it to the clipboard.

a. Scroll through the list of command categories and click on Clipboard to
expand the category.
b. Double click on Clipboard Cut to insert the clipboard cut command as the

next item in the script.

4. Now save the clipboard contents to a text string variable.

a. Scroll through the list of command categories and click on Variables to



expand the category.

b. Double click on Variable Set String to open the Variable Set String
window.

c. Select the Set Value from Clipboard option from the drop down menu.
d. Enter %T[1]% in the Destination Variable field and click OK to save.

5. Save the first letter to a new variable - T[2].

a. Scroll through the list of command categories and click on Variables to
expand the category.

b. Double click on Variable Modify String to open the Variable Modify String
window.

c. Select Copy Part of Text from the drop down list to copy the first letter of
the variable T[1] and save it to variable T[2].

d. Enter %T[2]% in the Text Variable field and enter %T[1]% the Variable
to copy from field.

e. Enter the number "1" (without the quotations) in the Starting Position
field.

f. In the Number of Characters to Copy field enter the number "1" (without
the quotations).

g. Click OK to save.

6. Save the second letter to a separate variable - T[3].

a. Scroll through the list of command categories and click on Variables to
expand the category.

b. Double click on Variable Modify String to open the Variable Modify String
window.

c. Select the Copy Part of Text option from the drop down list.

d. Enter %T[3]% in the Text Variable field and enter %T[1]% in the



Variable to copy from field.

e. Enter the number "2" (without the quotations) in the Starting Position
field.

f. In the Number of Characters to Copy field enter the number "1" (without
the quotations).

g. Click OK to save.

7. This last step plays back the corrected text.

a. Scroll through the list of command categories and click on Keyboard to
expand the category.

b. Double click on Text Type to open the Text Type window.

c. In the Keystrokes edit field, type the following: %T[3]%%T[2]%.

This types out the second letter of the transposed text first, reversing the

order and correcting the typing error.

d. Click OK to save and return to the Script Editor.

Macro Script

The macro script should look like what is displayed below. If the macro doesn't look
like this, arrange the commands so that they are in the following order.

// Place cursor between transposed letters.

Text Type (Simulate Keystrokes): <ARROW LEFT><SHIFTD><ARROW
RIGHT><ARROW RIGHT><SHIFTU>

Clipboard Cut

Variable Set String %T[1]% from the clipboard contents

Variable Modify String %T[2]% to a substring in %T[1]% starting at 1 and 1
characters long

Variable Modify String %T[3]% to a substring in %T[1]% starting at 2 and 1
characters long

Text Type (Simulate Keystrokes): %T[3]%%T[2]%




Click on Script > Save Macro to save the macro just created.

Testing the macro
To test the macro, run the notepad program. (Depending on your version of
Windows, click on the Windows Start button, enter notepad in the Search field and

press enter. Or right click on the Windows Start button, select Run, enter notepad
and click OK.)

Type the following text into notepad - Tihs is a tset. (Include the typing errors.)

Insert the cursor between the "i" and "h" in the word "Tihs". Press the F4 key to play back
the macro. The letters are reversed to correct the spelling to "This". Try the same thing with
the misspelled word "tset".

v" Note: If assigning original names to variables, rather than using T[1], D[1], etc., then the following characters are
not allowed in the variable name: []<>,.-+=\[/*%



Advanced - Using Integer Variables

The object of the completed macro is to generate three random numbers from 1 to
100 and display the results. This macro requires using Integer Variables as well as
Arrays.

Setting up the Macro

1. From the Macro Express Pro - Explorer menu click on Macro > New Macro to

open the Create New Macro window.

2. Hot Key should already be selected as the Activation.

3. Click on the HotKey edit box to place the cursor in this field.

4. Hold down the CTRL key, the SHIFT key and the R key all at the same time
and release them.

5. CTRL+SHIFT+R should appear in the edit box. This is the hot key we will
define for the macro.

6. Enter "Generate Random Numbers" (without the quotes) in the Nickname
field.

7. Click OK to open the Script Editor.

8. In the Script Editor click on the Scope tab and make sure that the macro
scope is set to global.

9. Click on the Script tab to start building the macro.

Building the Macro in the Script Editor

1. Scroll through the list of commands and expand the Variables category.
Double click on the Variable Set Integer command to open the window of the
same name.

2. From the drop down list select the Set to a Random Value option.

Creating the variable and array



a. Place the cursor in the Destination Variable field to display the Variables
button to the right of the field.

b. Click on the Variables button to open the Insert Variable window.

c. Click on the Add button to open the Variable Properties window.

d. Enter "Random" in the Variable Name field.

e. From the drop down Variable Type list select Integer Variables.

f. Check the box next to Create as an Array.

g. Enter 3 (three) in the Elements field and click OK to return to the Insert
Variable window.

h. Expand the list of Integer variables (click on +) to see the Random
variable created.

i. Highlight the Random variable to see Random|[ ] displayed in the Variable
Name field.

j. Insert the number 1 (one) between the brackets so it displays as
Random[1].

k. Click OK to return to the Variable Set Integer command.

3. The Destination Variable field should now display %Random[1]% as the
variable.

4. Enter the number 1 (one) in the Minimum Value field.

5. Enter the number 100 (one hundred) in the Maximum Value field.

6. Click OK to save the command and place it in the Script Editor.

Generating the Random Numbers

7. In the Script Editor highlight the Variable Set Integer command shown in the
script and click on the Duplicate button X2l twice (on the right hand side of the
script) so that you should now see three identical lines in the script.

8. Double click on the second line in the script to open the Variable Set Integer

command.

9. Edit the Variable name by replacing the 1 (one) in brackets with a 2 (two). It



should now display as %Random[2]%.

10. Click OK to save and return to the Script Editor.

11. Double click on the third line in the script to open the Variable Set Integer
command.

12. Edit the Variable name by replacing the 1 (one) in brackets with a 3
(three). It should now display as %Random[3]%.

13. Click OK to save and return to the Script Editor.

Have the macro display the results
These next steps set up the display of the three random numbers in a text box.

After completing lines 14 through 27, the Text Box Display command window
should look like the image below.
14. Scroll through the list of commands and expand the Dialogs category.
Double click on the Text Box Display command to open the window of the same
name.
15. Insert "Display random numbers" in the Header field.
16. Place the cursor in the Text Box field and the Variables button will appear to
the right of the field.
17. Click on the Variables button and expand the Integer Variables type.
18. Select the Random variable to place Random|[ ] in the Variable Name field.
19. Insert 1 (one) between the brackets so that it reads as Random[1] and
click OK.
20. This places %Random[1]% in the Text Box field.
21. Copy the text %Random[1]% to the clipboard. Highlight the text and press
Ctrl + C to copy to the clipboard.
22. Move the cursor to the second line (Right Arrow and the Enter key).
23. Press Ctrl + V to paste the text into the second line.
24. Move the cursor to the third line and press Ctrl + V to paste again.
25. You should now have three identical lines of %Random[1]%.

26. In the second line, replace the 1 (one) with 2 (two) so that it reads



%Random[2]%.

27. In the third line, replace the 1 (one) with 3 (three) so that it reads
%Random[3]%.

28. Click on the OK button to save and return to the Script Editor.

M Text Box Display

Options On Error Comments
Text Box Command:
Text Box Display ~
Header:
‘Display Random Values v

Box Content:
B /7 UF=

%~Random[1]% v
%Random[2]%
%Random[3]%

= % Tahoma v 10 ~ [[lcBlack -

Width: |278 e
Height: ‘200 ‘ Y,

[ Always on Top
Keep Focus

Left: ‘Center

|
Top: ‘Center ‘
|

===

Monitor: ‘0

| Set Size and Position

OK Cancel

In the Script Editor, click on Script > Save Macro to save the macro just created.

Macro Script
The macro script should look like what is displayed below. If the macro does not
look like this, arrange the commands so that they are in the following order.



Variable Set Integer %Random[1]% to a random value
between 1 and 100

Variable Set Integer %Random[2]% to a random value
between 1 and 100

Variable Set Integer %Random[3]% to a random value
between 1 and 100

Text Box Display: Three Random Numbers

Testing the Macro

Press Ctrl + Shift + R to run the macro. A text box opens and displays three
random numbers between 1 and 100.

v Note: If assigning original names to variables, rather than using T[1], D[1], etc., then the following
characters are not allowed in the variable name: []<>,.-+=\|/*%



Advanced - ASCII Text File Process

This sample tutorial reads the contents of a text file in .csv format and inserts the
data into another application. Formatting the text to one of the ASCII formats
(comma delimited, tab delimited or ASCII delimited) is a quicker and more reliable
way to transfer data than the copy and paste routine described in a previous
tutorial. The macro reads directly from the file and inputs the results directly into

the

receiving application. No need to switch back and forth between applications -

no copying from one program and pasting to another.

Creating a .csv file

The

1.

ZIP

first step is to create a .csv file with data for the macro to read.

Copy the ZIP code data shown below to the clipboard. (Highlight the text in
the ZIP Code Data box and press Ctrl + c.)

Open the notepad program. (Depending on your version of Windows, click on
the Windows Start button, enter notepad in the Search field and press
enter. Or right click on the Windows Start button, select Run, enter notepad
and click OK.)

Place the cursor in the notepad program and press Ctrl + v to paste the text
into notepad.

Click on File > Save As and make note or remember the location of where the
file is about to be saved.

In the Name field remove .txt and type Utah ZIPS.csv.

. Click on the Save button to save the file.

Code Data



84022,UT,DUGWAY,TOOELE,435,UTC -7:00,Y
84023,UT,DUTCH JOHN,DAGGETT,435,UTC -7:00,Y
84024,UT,ECHO,SUMMIT,435,UTC -7:00,Y
84025,UT,FARMINGTON,DAVIS,801,UTC -7:00,Y
84026,UT,FORT DUCHESNE,UINTAH,435,UTC -7:00,Y
84027,UT,FRUITLAND,DUCHESNE,435,UTC -7:00,Y
84028,UT,GARDEN CITY,RICH,435,UTC -7:00,Y
84029,UT,GRANTSVILLE, TOOELE,435,UTC -7:00,Y
84031,UT,HANNA,DUCHESNE,435,UTC -7:00,Y
84032,UT,HEBER CITY,WASATCH,435,UTC -7:00,Y
84033,UT,HENEFER,SUMMIT,435,UTC -7:00,Y
84034,UT,IBAPAH, TOOELE,435,UTC -7:00,Y

Setting up the Macro

1. From the Macro Express Pro - Explorer menu click on Macro > New Macro to

open the Create New Macro window.

2. Hot Key should already be selected as the Activation.

3. Click on the HotKey edit box to place the cursor in this field.

4. Hold down the CTRL key, the SHIFT key and the Z key all at the same time
and release them.

5. CTRL+SHIFT+Z should appear in the edit box. This is the hot key we will
define for the macro.

6. Enter "Process ZIP Code Data" (without the quotes) in the Nickname field.

7. Click OK to open the Script Editor.

8. In the Script Editor click on the Scope tab and make sure that the macro

scope is set to global.

9. Click on the Script tab to start building the macro.

Building the Macro
Process the ASCII Text File

1. Scroll through the list of commands and expand the Files/Folders category.

Double click on the ASCII File Begin Process command to open the window
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10.

11.
12.

of the same name.

. Change the File Format option to Comma Delimited Text (.csv) from the drop

down list.
Click on the Browse button to the right of the Filename field and navigate to
the location of the saved .csv file.
Highlight the file and click on the Open button to place the name of the file
and file path into the Filename edit box.
Place the cursor in the box next to Variable array to receive result and then
click on the Variables button to open the Insert Variable window.
Click on the + sign next to Type: Text Variables to expand the category.
Click on the T to place the letter T in the Variable Name field.
Click OK to save and return to the ASCII File Begin Process window.
Leave the Starting Index set to 1.
Leave the Begin Processing on Record: field set to 1 in order to start
processing the first line of the text file.
Make sure the Process All Records option is selected.

Click OK to save and return to the Script Editor.



M ASCII File Begin Process X

Options On Error Comments

Filename:
‘D:\TestMacros\Utah Zips.csv ‘ - |V

File Format: |[Comma Delimited Text (.csv) ~

Variable array to receive result: ‘%T% ‘ v
Starting Index:
Begin processing on record: ‘l ‘ v
Process All Records v

[ ] Parse blank lines
[ Clear the array before processing the file

OK Cancel

v" Note: The T variable is an array that by default allows up to 99 variables - T[1], T[2] and so on up
to T[99]. We could also have named our own variable and created the array by clicking on the Add
button in the Insert Variable window. This process is described in the Advanced - Using Integer
Variables tutorial.

The window should look like the above when finished, other than the location of the
Utah ZIPS.csv file.

Insert the text into another application

1. Scroll through the list of commands and expand the Keyboard category.
Double click on the Text Type command to open a window of the same
name.

2. Click on the Variables button at the bottom of the window to open the Insert

Variable command.

Click on the + sign next to Type: Text Variables to expand this category.

Click on the T to place T[ ]in the Variable Name field.

Enter the number 1 between the brackets so that it looks like T[1].

Click OK to save and return to the Text Type window.

N o o bk~ w

Highlight the %T[1]% found in the Text Type window and press Ctrl c to copy



to the clipboard.

8. Press Enter to move the cursor to the line below the %T[1] found on the first
line and press Ctrl v to paste.

9. %T[1]% should now be displayed on two lines.

10. Move to line 3 and paste again.

11. Repeat the process so that %T[1]% is displayed seven times, each
underneath the other.

12. On the last line, press the Enter key twice to move the cursor two lines
below the last line of text.

13. Go to line 2 and change %T[1]% to %T[2]%.
14. Go to line 2 and change %T[1]% to %T[3]% and so on.
15. Click OK to save and return to the Script Editor.

End Process ASCII Text File
1. Scroll through the list of commands and expand the Files/Folders category.

Double click on the ASCII File End Process command to insert the command
at the end of the script.

2. Click on Script > Save Macro to save the macro just created.

Macro Script

The macro should look like the following in the Script Editor. If the macro doesn't
look like the script shown below, arrange the commands so that they are in the
following order. The file path in the first command most likely will be different,
based on where you saved the Utah ZIPS.csv file.



ASCII File Begin Process: C:\Insight
Software\Utah ZIPS.csv

Text Type (Simulate Keystrokes):
%T[1]%

%T[2]%

%T[4]%

%T[5]%

%T[6]%

%T[7]%

ASCII File End Process

Playing Back the Macro

Start the WordPad program. (Depending on your version of Windows, click on the

Windows Start button, enter wordpad in the Search field and press enter. Or right
click on the Windows Start button, select Run, enter wordpad and click OK.) Make
sure the text cursor is in the WordPad program and then press CTRL+SHIFT+Z to

play back the macro.

The data is inserted in a vertical format as shown below.

84022

urt
DUGWAY
TOOELE
435

uTC -7:00
Y

84023

urt

DUTCH JOHN
DAGGETT
435

UTC -7:00

Y

v Note: This is a simple example of what can be done using the Process an ASCII Text File command.
When entering the data into a database, choose which variables to insert and in what order, or add



Tabs to move from field to field, etc. Create macros to update the record in the database, wait for a
fresh screen, insert the second line of the text file into the database, and so on.



Using Window Controls

This is an example of using Window Controls with Windows 10. The macro sends
text to notepad while the program window is minimized to the task bar.

A copy of notepad needs to be open. To do this type notepad in the "Type here to search box" in the Task
Bar and press Enter.

Select a Macro Activation
For this example we will create a hot key activated macro.
1. From the Macro Express - Explorer click on the New Macro icon to open the
Create New Macro window.
2. HotKey should be the default Activation.
3. Click on the HotKey edit box to place the cursor in this field.
4. Press the Ctrl + Alt + 4 keys and release them. Ctrl + Alt + 4 should appear
in the edit box.
5. Enter "Text to Notepad" (without the quotes) in the Macro Nickname edit
field.
6. Click OK to save the changes and open the Script Editor.

Set the Macro Scope

1. With the Script Editor open, click on the Scope tab.
2. Set the Current Scope to Global.

Writing the Macro

Setting the Control Variable

Click on the Script tab.

Expand the Window Controls category of commands.

Double click on the Get Control command to open the Get Control window.
Select the Hide Macro Express option.

Click on the Variables button to the right of the Store the Control In field.

a M w0 Dh ke



6. Expand the Control Variables list and click on the C variable.

\‘

. In the Variable Name field enter the number 1 between the brackets to show
C[1] and click OK to save.
8. Click on the Launch Utility button to open the Capture Window Control
window.
9. If notepad is not visible on the screen open the program window.
10. Click on the blue X crosshairs on the Capture Window Control window
and drag it over top of the notepad edit field. It will be outlined in black as

shown.

File Edit Format View Help

100%  Windows (CRLF) UTF-8

11. Release the mouse button to insert the control information into the
Control Details panel.



Capture Window Control X

Drag the crosshairs below by clicking on them and
dragging them over the control you wish to capture. Let
go of the left mouse button to capture the control. . .
A"
Control Details
v NOTEPAD.EXE
v Untitled - Notepad: (Notepad)

Save the control using the z-order of the control v

Relative to bottom-right
Restore parent window size

Save Cancel

12. Click the save button to save the information and return to the Get

Control Window which should now look like the following image.

M Get Control X

Options On Error Comments

Launch Utility | [ ] Hide Macro Express

Details:

v-NOTEPAD.EXE
v -Untitled - Notepad (Notepad)

Store the control in:

%C[1]% I

Top-Level Window Caption:

‘Untitled - Notepad ‘ v
Exact Match M Use wildcards

OK Cancel

13. Click OK to save and return to the Script Editor.



Sending Text to the Control

1. Expand the Keyboard Category of commands and double click on the Text
Type command to open the Text Type window.

2. Enter some text in the edit field, such as This is a test.

3. Click on the Simulate Keystrokes drop down list and select Send Text Directly
to Control.

4. Click on the Variables button to the right of the Control field.

5. Expand the Control Variables list and click on the C variable.

6. In the Variable Name field enter the nhumber 1 between the brackets to show
C[1] and click OK to save the variable selection.

7. Click OK in the Text Type window to save the change and return to the Script
Editor.

Macro Script

When finished the macro script should look like the following example. If something
is not in the correct order, highlight the command and click on the Up or Down
arrows to the right of the Script and move the command to its proper location.

Get Control: (NOTEPAD.EXE) Using z-order -> %C[1]%
Text Type (Send Text Directly to Control %C[1]%): This is a

test.

Run the Macro

Make sure that notepad is running, but minimized to the task bar. Press the Ctrl +
Alt + 4 hotkey. Open Notepad from the task bar. You will notice that the text has
been inserted into notepad. The program window does not need to have focus in

order for the text to be inserted.



Playing Back Macros

Macro Activation

Below is a chart listing the options available to activate a macro.

Activation

Description

Hot Key

A hot key is a key combination such as CTRL+ALT+A,
CTRL+Right Mouse Click, etc. The macro activates when
the keys are pressed and released.

Shortkey

A shortkey is a set of characters such as abc, myname,
etc. The macro activates when the keys are typed into
an application.

Schedule

The macro runs as a scheduled event. These events can
be scheduled to play at startup of Macro Express, hourly,
daily (choose any or all days of the week), weekly,
monthly, one given time, every "x" minutes or after "x"
minutes of inactivity.

Window
Title

This option looks for a specific window title. The macro
activates when the window either gains focus, loses
focus, opens or closes, depending on the option selected.

Mouse Event

Use either the left, middle or right mouse buttons to
activate the macro. Select an area of the screen to click
on or designate a window part to click on, such as scroll
bar, title bar, buttons, etc. to activate the macro.

The Control Event option activates a macro when a
specific Windows control or the window that contains the

Control control gains focus. The control may be a window
Event button, edit box or another identifiable portion of a
window.
Directory Modification looks for changes to files in a
folder or to the folder itself. The macro activates when a
Directory change is made to the specified folder or to a file within
- . that folder. Some of the available options include the
Modification macro looking for changes to file size, attributes, write
time, security descriptor or checking if a file has been
renamed or deleted.
S Activate a macro when a System Event, such as a
ystem : .
Event Windows message, resolution change or color change

OCcCurs.




Process
Event

The Process Event activation method initiates a macro
when a Process (an executable program or service) first
starts or when it closes.

TCP/IP

This options looks for the TCP/IP stack to become
available or unavailable.

Clipboard
Text

Activate a macro based on the contents of the clipboard
text. Select whether the clipboard does or does not
match what was selected as the clipboard trigger. Or
choose whether the clipboard contains or does not
contain specific text.

Floating
Menu

A Floating Menu is a menu of macros displayed as a
floating tool bar and sits on top of other open
applications. The floating menu either displays icons
(representing the macros), the first part of the text of
the macro or the macro nickname and scope. Clicking on
one of the macros or typing a corresponding number or
letter activates that macro from the floating menu.

No
Activation

No Activation indicates that there is not an activation
associated with the macro. In such cases, the macro
may be included as a subroutine of another macro using
the Macro Run command. Or the macro may be used in
a popup menu of macros and no other macro activation
is desired for the macro.

Popup
Menu

A popup menu of macros is a list of macros displayed in
a window. Clicking on one of the macros or typing a
corresponding number or letter activates that macro
from the popup menu. The popup menu itself is
activated by either a hot key or by right clicking on a
notification area icon. The popup menu may show icons
(representing the macros), the first part of the text of
the macro or the macro nickname and scope.

Command
Line
Parameters

Invoke a macro using a command line parameter. The
specific command line parameters to invoke a macro are
the /A and /MXE commands. Both the macexp.exe and
the meproc.exe programs may be used. See the
command line parameters help section for more detail.

Windows
Explorer /
File Explorer

Double clicking on a playable macro file (.MXE) from
within Windows Explorer/File Explorer executes the
macro.




Run Macro
Now

Run a macro from the Macro Express - Explorer by using
the Run Macro Now option. Right click on the macro in
the Macro Explorer and then left click on the Run Macro
Now menu item. Or highlight the macro in the Macro
Explorer list and click on the Run Now button.

Windows
API Calls

This option is only intended for the programmer who
wants to add macro functionality directly from their own
programs. While the command line parameter options
can be used via another program, the following method
may be much quicker and remove the overhead of
having to run an external program such as macexp.exe
Oor meproc.exe.

Instruct the Macro Express Player to directly execute a
macro in the currently loaded macro file by specifying its
nickname or instruct it to run a playable macro. The
macro nickname is case sensitive. If more than one
macro shares the same nickname, only the first one
found in the macro file is activated.

Windows API Examples

The following examples demonstrate the basic steps of how to activate a macro using
Windows API messages and are presented in several different programming languages.
These examples assume familiarity with basic Windows APl commands and terminology.
The process involves posting a series of messages directly to the Macro Express Player.

These examples use the message WM_USER+20 to run a macro within the currently
loaded macro file. To run a playable macro, change the messages in the examples from

WM_USER+20 to WM_USER+21.




Delphi Example

var
[ : integer;
S : string;
Hwnd : THandle;
begin
Hwnd := FindWindow('TMainWin', 'Macro Express Player');
if(IsWindow(Hwnd)) then
begin
S := MacroName;

fori := 1 to length(S) do
PostMessage(Hwnd, WM_USER+20, ord(S[i]), 0);
PostMessage(Hwnd, WM_USER+20, 0, 0);
end
else
ShowMessage('Macro Express is not running');
end;

C/C++/Visual C Example

HWND hwnd = FindWindow("TMainWin", "Macro Express
Player");
if( IsWindow(hwnd) ) {

for(int x = 0; x < strlen(s); x ++)

PostMessage(hwnd, WM_USER+20, s[i], 0);

PostMessage(hwnd, WM_USER+20, 0, 0);
b
else

MessageBox(GetForegroundWindow(), "Macro Express is
not running”, "Error", 0);




VBA Example

HWND hwnd = FindWindow("TMainWin", "Macro Express
Player");
if( IsWindow(hwnd) ) {

for(int x = 0; x < strlen(s); x ++)

PostMessage(hwnd, WM_USER+20, s[i], 0);

PostMessage(hwnd, WM_USER+20, 0, 0);
b
else

MessageBox(GetForegroundWindow(), "Macro Express is
not running"”, "Error", 0);

Private Declare Function FindWindow _
Lib "User32" Alias "FindWindowA" ( _
ByVal IpClassName As String, _
ByVal [pWindowName As String) As Long

Private Declare Function PostMessage _
Lib "User32" Alias "Porterage" ( _
ByVal Wand As Long, _
ByVal MSG As Long, _
ByVal warm As Long, _
ByVal Parma As Long) As Long

Private Sub Unsacred)
'Runs a macro express macro

Const WM_USER = &H400
Const Command = WM_USER+20
Const Macroname = "Macroname"

Dim hwnd, I, Result As Long

hwnd = FindWindow("TMainWin", "Macro Express Player")
ForI = 1 To Len(Macroname)
Result = PostMessage(hwnd, Command,
Asc(Mid(Macroname, I, 1)), 0)
Next I
Result = PostMessage(hwnd, Command, 0, 0)
End Sub




Hot Keys

A hot key is a combination of keys that, when pressed together, plays back a
macro. Macro Express allows hot key combinations ranging from a single key up to
four keys pressed simultaneously.

M Create New Macro X

Activation Create New Macro

@ Select an initial activation on the left. Additional activations can be added after the macro is et
HotKey created.

O Shortkey
HotKey
O Schedule L . |
Click in the box to the right and press the HotKey:  |Ctrl+N
(O Window Title or select the HotKey from the list below:
() Mouse Event Ctrl+A Reserved for Windows feature PN
Ctrl+B Unassigned
Control Event
O ontrotven Ctrl+C Reserved for Windows feature
() Directory Modification Ctri+D Reserved 1 Macro In Use
O System Event Ctri+E 1 Macro In Use
Ctrl+F Unassigned
(O Process Event Ctrl+G Unassigned
O TCP/IP Ctrl+H 1 Macro In Use
. Ctri+I Unassigned
(O Clipboard Text Ctri+7 1 Macro In Use
O Floating Menu Ctr[+K Unassigned
o Cir+L 1 Macro In Use
(O No Activation Ctrl+M Unassigned
Ctrl+N Unassigned
Ctrl+0 Unassigned
Cirl+P lInascinnard N

Wait for the HotKey to be released before activating

Macro Nickname: ‘

[]Build as a Popup Macro

Cance

To activate a new macro with a hot key, select the HotKey option in the Create
New Macro window. Place the cursor in the edit box and hold down the hot key
combination wanted. That combination is inserted in the edit box and will be the
combination used to activate the macro.

If unsure which combination to use, scroll through the list of keys and highlight the
one wanted.

Available Hot Keys
Hot keys designated as Reserved for Windows are used by Windows for specific



functions, but may be overridden by Macro Express. For example, Ctrl + C is
used to copy highlighted text to the clipboard, but the key may be assigned to
Macro Express to perform a different function.

Hot Keys shown as Restricted to Windows are reserved by Windows for its own
internal use. Depending on the version of Windows being used, these hot keys
may not activate Macro Express macros. They will only perform the function
assigned by Windows.

Wait for the Hot Key to be Released before Activating

This default setting requires that all keys in the hot key sequence be released in
order for the macro to start playing. De-selecting this option allows the macro to
start playing as soon as the hot key sequence is pressed.

Macro Nickname

Optionally assign a name to the macro to later help more readily determine what
the macro does.

Build as a Popup Menu
Select this option to open the Menu Builder window and create a popup menu.

Hot Key Combinations

Macro Express Pro supports 846 different hot key combinations. Below is a
comprehensive list of available hot keys:

Ctrl+A Alt+Shift+U Ctrl+ Win+Ctrl+8

Ctrl+B Alt+Shift+V Alt+ Win+Ctrl+9

Ctrl+C Alt+Shift+W Ctrl+Shift+ Win+Ctrl+F1
Ctrl+D Alt+Shift+X Alt+Shift+ Win+Ctrl+F2
Ctrl+E Alt+Shift+Y Ctrl+Alt+ Win+Ctrl+F3
Ctrl+F Alt+Shift+Z Ctrl+Alt+Shift+ Win+Ctrl+F4
Ctrl+G Alt+Shift+0 KeyPad / Win+Ctrl+F5
Ctrl+H Alt+Shift+1 Ctrl+Keypad / Win+Ctrl+F6
Ctrl+l Alt+Shift+2 Alt+Keypad / Win+Ctrl+F7

Ctrl+) Alt+Shift+3 Shift+KeyPad / Win+Ctrl+F8



Ctrl+K
Ctrl+L
Ctrl+M
Ctrl+N
Ctrl+O
Ctrl+P
Ctrl+Q
Ctrl+R
Ctrl+S
Ctrl+T
Ctrl+U
Ctrl+V
Ctrl+W
Ctrl+X
Ctrl+Y
Ctrl+z
Ctrl+0
Ctrl+1
Ctrl+2
Ctrl+3
Ctrl+4
Ctrl+5
Ctrl+6
Ctrl+7
Ctrl+8
Ctrl+9
Ctrl+F1
Ctrl+F2
Ctrl+F3
Ctrl+F4
Ctrl+F5
Ctrl+F6
Ctrl+F7
Ctrl+F8
Ctrl+F9
Ctrl+F10
Ctrl+F11
Ctrl+F12
Alt+A
Alt+B
Alt+C
Alt+D
Alt+E
Alt+F

Alt+Shift+4
Alt+Shift+5
Alt+Shift+6
Alt+Shift+7
Alt+Shift+8
Alt+Shift+9
Alt+Shift+F1
Alt+Shift+F2
Alt+Shift+F3
Alt+Shift+F4
Alt+Shift+F5
Alt+Shift+F6
Alt+Shift+F7
Alt+Shift+F8
Alt+Shift+F9
Alt+Shift+F10
Alt+Shift+F11
Alt+Shift+F12
Ctrl+Alt+Shift+A
Ctrl+Alt+Shift+B
Ctrl+Alt+Shift+C
Ctrl+Alt+Shift+D
Ctrl+Alt+Shift+E
Ctrl+Alt+Shift+F
Ctrl+Alt+Shift+G
Ctrl+Alt+Shift+H
Ctrl+Alt+Shift+
Ctrl+Alt+Shift+)
Ctrl+Alt+Shift+K
Ctrl+Alt+Shift+L
Ctrl+Alt+Shift+M
Ctrl+Alt+Shift+N
Ctrl+Alt+Shift+O
Ctrl+Alt+Shift+P
Ctrl+Alt+Shift+Q
Ctrl+Alt+Shift+R
Ctrl+Alt+Shift+S
Ctrl+Alt+Shift+T
Ctrl+Alt+Shift+U
Ctrl+Alt+Shift+V
Ctrl+Alt+Shift+W
Ctrl+Alt+Shift+X
Ctrl+Alt+Shift+Y
Ctrl+Alt+Shift+Z

Ctrl+Shift+Keypad /
Alt+Shift+Keypad /
Ctrl+Alt+Keypad /
Ctrl+Alt+Shift+Keypad /
KeyPad *
Ctrl+Keypad *
Alt+Keypad *
Shift+KeyPad *
Ctrl+Shift+Keypad *
Alt+Shift+Keypad *
Ctrl+Alt+Keypad *
Ctrl+Alt+Shift+Keypad *
KeyPad -
Ctrl+Keypad -
Alt+Keypad -
Shift+KeyPad -
Ctrl+Shift+Keypad -
Alt+Shift+Keypad -
Ctrl+Alt+Keypad -
Ctrl+Alt+Shift+Keypad -
KeyPad +
Ctrl+Keypad +
Alt+Keypad +
Shift+KeyPad +
Ctrl+Shift+Keypad +
Alt+Shift+Keypad +
Ctrl+Alt+Keypad +
Ctrl+Alt+Shift+Keypad +
Insert

Delete

Home

End"

Page Up

Page Down

Left Arrow

Right Arrow

Up Arrow

Down Arrow
Ctrl+Page Up
Alt+Page Up
Shift+Page Up
Ctrl+Shift+Page Up
Alt+Shift+Page Up
Ctrl+Alt+Page Up

Win+Ctrl+F9
Win+Ctrl+F10
Win+Ctrl+F11
Win+Ctrl+F12
Win+Alt+A
Win+Alt+B
Win+Alt+C
Win+Alt+D
Win+Alt+E
Win+Alt+F
Win+Alt+G
Win+Alt+H
Win+Alt+l
Win+Alt+)
Win+Alt+K
Win+Alt+L
Win+Alt+M
Win+Alt+N
Win+Alt+O
Win+Alt+P
Win+Alt+Q
Win+Alt+R
Win+Alt+S
Win+Alt+T
Win+Alt+U
Win+Alt+V
Win+Alt+W
Win+Alt+X
Win+Alt+Y
Win+Alt+Z
Win+Alt+0
Win+Alt+1
Win+Alt+2
Win+Alt+3
Win+Alt+4
Win+Alt+5
Win+Alt+6
Win+Alt+7
Win+Alt+8
Win+Alt+9
Win+Alt+F1
Win+Alt+F2
Win+Alt+F3
Win+Alt+F4



Alt+G
Alt+H
Alt+l
Alt+)
Alt+K
Alt+L
Alt+M
Alt+N
Alt+O
Alt+P
Alt+Q
Alt+R
Alt+S
Alt+T
Alt+U
Alt+V
Alt+W
Alt+X
Alt+Y
Alt+Z
Alt+0
Alt+1
Alt+2
Alt+3
Alt+4
Alt+5
Alt+6
Alt+7
Alt+8
Alt+9
Alt+F1
Alt+F2
Alt+F3
Alt+F4
Alt+F5
Alt+F6
Alt+F7
Alt+F8
Alt+F9
Alt+F10
Alt+F11
Alt+F12
Ctrl+Shift+A
Ctrl+Shift+B

Ctrl+Alt+Shift+0
Ctrl+Alt+Shift+1
Ctrl+Alt+Shift+2
Ctrl+Alt+Shift+3
Ctrl+Alt+Shift+4
Ctrl+Alt+Shift+5
Ctrl+Alt+Shift+6
Ctrl+Alt+Shift+7
Ctrl+Alt+Shift+8
Ctrl+Alt+Shift+9
Ctrl+Alt+Shift+F1
Ctrl+Alt+Shift+F2
Ctrl+Alt+Shift+F3
Ctrl+Alt+Shift+F4
Ctrl+Alt+Shift+F5
Ctrl+Alt+Shift+F6
Ctrl+Alt+Shift+F7
Ctrl+Alt+Shift+F8
Ctrl+Alt+Shift+F9
Ctrl+Alt+Shift+F10
Ctrl+Alt+Shift+F11
Ctrl+Alt+Shift+F12
F1

F2

F3

F4

F5

F6

F7

F8

F9

F10

F11

F12

Shift+F1

Shift+F2

Shift+F3

Shift+F4

Shift+F5

Shift+F6

Shift+F7

Shift+F8

Shift+F9
Shift+F10

Ctrl+Alt+Shift+Page Up
Ctrl+Page Down
Alt+Page Down
Shift+Page Down
Ctrl+Shift+Page Down
Alt+Shift+Page Down
Ctrl+Alt+Page Down
Ctrl+Alt+Shift+Page Down
Ctrl+Left Arrow

Alt+Left Arrow
Shift+Left Arrow
Ctrl+Shift+Left Arrow
Alt+Shift+Left Arrow
Ctrl+Alt+Left Arrow
Ctrl+Alt+Shift+Left Arrow
Ctrl+Right Arrow
Alt+Right Arrow
Shift+Right Arrow
Ctrl+Shift+Right Arrow
Alt+Shift+Right Arrow
Ctrl+Alt+Right Arrow
Ctrl+Alt+Shift+Right Arrow
Ctrl+Up Arrow

Alt+Up Arrow

Shift+Up Arrow
Ctrl+Shift+Up Arrow
Alt+Shift+Up Arrow
Ctrl+Alt+Up Arrow
Ctrl+Alt+Shift+Up Arrow
Ctrl+Down Arrow
Alt+Down Arrow
Shift+Down Arrow
Ctrl+Shift+Down Arrow
Alt+Shift+Down Arrow

Ctrl+Alt+Down Arrow

Ctrl+Alt+Shift+Down Arrow

KeyPad 0
Ctrl+Keypad O
Alt+Keypad 0
Ctrl+Alt+Keypad 0
KeyPad 1
Ctrl+Keypad 1
Alt+Keypad 1
Ctrl+Alt+Keypad 1

Win+Alt+F5
Win+Alt+F6
Win+Alt+F7
Win+Alt+F8
Win+Alt+F9
Win+Alt+F10
Win+Alt+F11
Win+Alt+F12

ESC

LMouse
Shift+LMouse
Ctrl+LMouse
Alt+LMouse
Ctrl+Shift+LMouse
Ctrl+Alt+LMouse
Shift+Alt+LMouse
RMouse
Shift+RMouse
Ctrl+RMouse
Alt+RMouse
Ctrl+Shift+RMouse
Ctrl+Alt+RMouse
Shift+Alt+RMouse
MMouse
Shift+MMouse
Ctrl+MMouse
Alt+MMouse
Ctrl+Shift+MMouse
Ctrl+Alt+MMouse
Shift+Alt+MMouse
Win+Space

Space

Enter

KeyPad .
Alt+KeyPad .
Ctrl+KeyPad .
Win+KeyPad .
Win+KeyPad 0
Win+KeyPad 1
Win+KeyPad 2
Win+KeyPad 3
Win+KeyPad 4
Win+KeyPad 5
Win+KeyPad 6



Ctrl+Shift+C
Ctrl+Shift+D
Ctrl+Shift+E
Ctrl+Shift+F
Ctrl+Shift+G
Ctrl+Shift+H
Ctrl+Shift+l
Ctrl+Shift+)
Ctrl+Shift+K
Ctrl+Shift+L
Ctrl+Shift+M
Ctrl+Shift+N
Ctrl+Shift+0O
Ctrl+Shift+P
Ctrl+Shift+Q
Ctrl+Shift+R
Ctrl+Shift+S
Ctrl+Shift+T
Ctrl+Shift+U
Ctrl+Shift+V
Ctrl+Shift+w
Ctrl+Shift+X
Ctrl+Shift+Y
Ctrl+Shift+Z
Ctrl+Shift+0
Ctrl+Shift+1
Ctrl+Shift+2
Ctrl+Shift+3
Ctrl+Shift+4
Ctrl+Shift+5
Ctrl+Shift+6
Ctrl+Shift+7
Ctrl+Shift+8
Ctrl+Shift+9
Ctrl+Shift+F1
Ctrl+Shift+F2
Ctrl+Shift+F3
Ctrl+Shift+F4
Ctrl+Shift+F5
Ctrl+Shift+F6
Ctrl+Shift+F7
Ctrl+Shift+F8
Ctrl+Shift+F9
Ctrl+Shift+F10

Shift+F11

Shift+F12

Ctrl+Enter

Alt+Enter
Shift+Enter
Ctrl+Shift+Enter
Alt+Shift+Enter
Ctrl+Alt+Enter
Ctrl+Alt+Shift+Enter
Ctrl+Tab

Shift+Tab
Ctrl+Shift+Tab
Ctrl+Alt+Tab
Ctrl+Alt+Shift+Tab
Ctrl+Backspace
Alt+Backspace
Shift+Backspace
Ctrl+Shift+Backspace
Alt+Shift+Backspace
Ctrl+Alt+Backspace
Ctrl+Alt+Shift+Backspace
Ctrl+Space
Alt+Space
Shift+Space
Ctrl+Shift+Space
Alt+Shift+Space
Ctrl+Alt+Space
Ctrl+Alt+Shift+Space
Ctrl+Insert
Alt+Insert
Shift+Insert
Ctrl+Shift+Insert
Alt+Shift+Insert
Ctrl+Alt+Insert
Ctrl+Alt+Shift+Insert
Ctrl+Delete
Alt+Delete
Shift+Delete
Ctrl+Shift+Delete
Alt+Shift+Delete
Ctrl+Home
Alt+Home
Shift+Home
Ctrl+Shift+Home

KeyPad 2
Ctrl+Keypad 2
Alt+Keypad 2
Ctrl+Alt+Keypad 2
KeyPad 3
Ctrl+Keypad 3
Alt+Keypad 3
Ctrl+Alt+Keypad 3
KeyPad 4
Ctrl+Keypad 4
Alt+Keypad 4
Ctrl+Alt+Keypad 4
KeyPad 5
Ctrl+Keypad 5
Alt+Keypad 5
Ctrl+Alt+Keypad 5
KeyPad 6
Ctrl+Keypad 6
Alt+Keypad 6
Ctrl+Alt+Keypad 6
KeyPad 7
Ctrl+Keypad 7
Alt+Keypad 7
Ctrl+Alt+Keypad 7
KeyPad 8
Ctrl+Keypad 8
Alt+Keypad 8
Ctrl+Alt+Keypad 8
KeyPad 9
Ctrl+Keypad 9
Alt+Keypad 9
Ctrl+Alt+Keypad 9
Win+A

Win+B

Win+C

Win+D

Win+E

Win+F

Win+G

Win+H

Win+l

Win+J

Win+K

Win+L

Win+KeyPad 7
Win+KeyPad 8
Win+KeyPad 9
Win+KeyPad /
Win+KeyPad *
Win+KeyPad -
Win+KeyPad +
Win+Ctrl+KeyPad .
Win+Ctrl+KeyPad 0
Win+Ctrl+KeyPad 1
Win+Ctrl+KeyPad 2
Win+Ctrl+KeyPad 3
Win+Ctrl+KeyPad 4
Win+Ctrl+KeyPad 5
Win+Ctrl+KeyPad 6
Win+Ctrl+KeyPad 7
Win+Ctrl+Keypad 8
Win+Ctrl+KeyPad 9
Win+Ctrl+KeyPad /
Win+Ctrl+KeyPad *
Win+Ctrl+KeyPad -
Win+Ctrl+KeyPad +
Win+Alt+KeyPad .
Win+Alt+KeyPad 0
Win+Alt+KeyPad 1
Win+Alt+KeyPad 2
Win+Alt+KeyPad 3
Win+Alt+KeyPad 4
Win+Alt+KeyPad 5
Win+Alt+KeyPad 6
Win+Alt+KeyPad 7
Win+Alt+KeyPad 8
Win+Alt+KeyPad 9
Win+Alt+KeyPad /
Win+Alt+KeyPad *
Win+Alt+KeyPad -
Win+Alt+KeyPad +
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Ctrl+Shift+F11
Ctrl+Shift+F12

Ctrl+Alt+A
Ctrl+Alt+B
Ctrl+Alt+C
Ctrl+Alt+D
Ctrl+Alt+E
Ctrl+Alt+F
Ctrl+Alt+G
Ctrl+Alt+H
Ctri+Alt+l
Ctrl+Alt+)
Ctrl+Alt+K
Ctrl+Alt+L
Ctrl+Alt+M
Ctrl+Alt+N
Ctrl+Alt+O
Ctrl+Alt+P
Ctrl+Alt+Q
Ctrl+Alt+R
Ctrl+Alt+S
Ctrl+Alt+T
Ctrl+Alt+U
Ctrl+Alt+V
Ctrl+Alt+W
Ctrl+Alt+X
Ctrl+Alt+Y
Ctrl+Alt+Z
Ctrl+Alt+0
Ctrl+Alt+1
Ctrl+Alt+2
Ctrl+Alt+3
Ctrl+Alt+4
Ctrl+Alt+5
Ctrl+Alt+6
Ctrl+Alt+7
Ctrl+Alt+8
Ctrl+Alt+9
Ctrl+Alt+F1
Ctrl+Alt+F2
Ctrl+Alt+F3
Ctrl+Alt+F4
Ctrl+Alt+F5
Ctrl+Alt+F6

Alt+Shift+Home
Ctrl+Alt+Home

Ctrl+Alt+Shift+Home

Ctrl+End
Alt+End
Shift+End
Ctrl+Shift+End
Alt+Shift+End
Ctrl+Alt+End

Ctrl+Alt+Shift+End

Ctrl+.

Alt+.
Ctrl+Shift+.
Alt+Shift+.
Ctri+Alt+.
Ctrl+Alt+Shift+.
Ctrl+,

Alt+,
Ctrl+Shift+,
Alt+Shift+,
Ctrl+Alt+,
Ctrl+Alt+Shift+,
Ctrl+/

Alt+/
Ctrl+Shift+/
Alt+Shift+/
Ctrl+Alt+/
Ctrl+Alt+Shift+/
Ctrl+;

Alt+;
Ctrl+Shift+;
Alt+Shift+;
Ctrl+Alt+;
Ctrl+Alt+Shift+;
Ctrl+"

Alt+"
Ctrl+Shift+"
Alt+Shift+"
Ctrl+Alt+"
Ctrl+Alt+Shift+"
Ctrl+\

Alt+\
Ctrl+Shift+\
Alt+Shift+\

Win+M
Win+N
Win+0O
Win+P
Win+Q
Win+R
Win+S
Win+T
Win+U
Win+V
Win+W
Win+X
Win+Y
Win+Z
Win+0
Win+1
Win+2
Win+3
Win+4
Win+5
Win+6
Win+7
Win+8
Win+9
Win+F1
Win+F2
Win+F3
Win+F4
Win+F5
Win+F6
Win+F7
Win+F8
Win+F9
Win+F10
Win+F11
Win+F12
Win+Ctrl+A
Win+Ctrl+B
Win+Ctrl+C
Win+Ctrl+D
Win+Ctrl+E
Win+Ctrl+F
Win+Ctrl+G
Win+Ctrl+H
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Shift+0
Shift+1
Shift+2
Shift+3
Shift+4
Shift+5
Shift+6
Shift+7
Shift+8
Shift+9
Shift+A
Shift+B
Shift+C
Shift+D
Shift+E



Ctrl+Alt+F7
Ctrl+Alt+F8
Ctrl+Alt+F9
Ctrl+Alt+F10
Ctrl+Alt+F11
Ctrl+Alt+F12
Alt+Shift+A
Alt+Shift+B
Alt+Shift+C
Alt+Shift+D
Alt+Shift+E
Alt+Shift+F
Alt+Shift+G
Alt+Shift+H
Alt+Shift+
Alt+Shift+)
Alt+Shift+K
Alt+Shift+L
Alt+Shift+M
Alt+Shift+N
Alt+Shift+0O
Alt+Shift+P
Alt+Shift+Q
Alt+Shift+R
Alt+Shift+S
Alt+Shift+T

Ctri+Alt+\
Ctrl+Alt+Shift+\
Ctrl+[

Alt+[
Ctrl+Shift+[
Alt+Shift+[
Ctri+Alt+[
Ctrl+Alt+Shift+[
Ctrl+]

Alt+]
Ctrl+Shift+]
Alt+Shift+]
Ctri+Alt+]
Ctrl+Alt+Shift+]
Ctrl+-

Alt+-
Ctrl+Shift+-
Alt+Shift+-
Ctrl+Alt+-
Ctrl+Alt+Shift+-
Ctrl+=

Alt+=
Ctrl+Shift+=
Alt+Shift+=
Ctrl+Alt+=
Ctrl+Alt+Shift+=

Win+Ctrl+l
Win+Ctrl+)
Win+Ctrl+K
Win+Ctrl+L
Win+Ctrl+M
Win+Ctrl+N
Win+Ctrl+O
Win+Ctrl+P
Win+Ctrl+Q
Win+Ctrl+R
Win+Ctrl+S
Win+Ctrl+T
Win+Ctrl+U
Win+Ctrl+V
Win+Ctrl+W
Win+Ctrl+X
Win+Ctrl+Y
Win+Ctrl+Z
Win+Ctrl+0
Win+Ctrl+1
Win+Ctrl+2
Win+Ctrl+3
Win+Ctrl+4
Win+Ctrl+5
Win+Ctrl+6
Win+Ctrl+7

Shift+F
Shift+G
Shift+H
Shift+
Shift+)
Shift+K
Shift+L
Shift+M
Shift+N
Shift+0
Shift+P
Shift+Q
Shift+R
Shift+S
Shift+T
Shift+U
Shift+V
Shift+W
Shift+X
Shift+Y
Shift+Z
Backspace



Shortkey

A shortkey is a set of characters such as abc, myname, etc. When the characters
are typed into an application, the macro runs. To create a new macro with a
shortkey, select the Shortkey option to display the shortkey edit box. In this field
enter a series of characters from two to 32 characters in length.

M Create New Macro
Activation

() HotKey

(®) Shortkey

() Schedule

() window Title
() Mouse Event
(O Control Event
() Directory Modification
() System Event
O Process Event
(O Tep/p

(O Clipboard Text
() Floating Menu
() No Activation

Create New Macro
Select an initial activation on the left. Additional activations can be added after the macro is created. ===

Shortkey
Original Shortkey: ‘emal’l ‘

(® Use Global Settings (Customizable from Options | Preferences | Activations | Shortkeys)
(O Customize Settings (for this macro only)

Match First Character's Case between Shortkey and Replacement Text
If the first letter in the text is uppercase, don't change it to lowercase

Require Exact Uppercase/Lowercase Match on Shortkey

No Case Sensitivity

Do not Remove Keystrokes Typed

Macro Nickname: ‘MY Email Address |

[ ] Build as a Popup Macro

cace

v Note: Before using the Shortkey option be sure to first define the shortkey default settings. Click
on Options > Preferences > Activations - Shortkeys tab to customize the settings.

Shortkey Specifications

Up to 32 characters may be entered as an original shortkey. In addition, up to 3
Prefix Keys may optionally be used and are applied to all original shortkeys
created. The following Prefix characters may be entered and used:

« The letters A through Z (both upper and lower case)



« The numbers 0 through 9
« The following characters: ! @ # $ % N & _ =< > 7?2 .,; , * -/ +
" ") ]and space bar

Alternatively use the suffix key option and press the space bar, the enter key or a
suffix character of . , : ; ? ! or - after typing the shortkey to activate the macro.

Macro Nickname

Optionally assign a name to the macro to more readily determine what the macro
does.

Build as a Popup Menu
Select this option to open the Menu Builder window and create a popup menu.




Schedule

Schedule Overview

Scheduled Macros are macros that can be scheduled to play back at a specific time.
Just set the schedule for the macro and it will play back unattended at the
designated time. No need to press a hot key or click on an icon. The macro plays
back at the selected time. In order for the macro to execute, Macro Express must
be running in the background.

There are a number of scheduling options available. These are briefly described
below. Click on the links for more detailed information.

Schedule

Description

At Startup

At Startup instructs Macro Express to immediately execute the mac
Express first starts up. If Macro Express is in the Start Up group, th
would play back when Windows first starts.

Once

Running a macro Once plays the macro back on one specific date ar

Hourly

An Hourly macro runs the macro repeatedly at a specific time each

Daily

A Daily macro runs the macro once each day on the days of the wex

Weekly

A Weekly macro runs once a week at the time specified.

Monthly

A Monthly macro runs at a specific time on the same day of the moi

System Idle

Setting the schedule with the System Idle option plays back the ma
has been idle (no keyboard or mouse activity) for the number of mi
option allows up to 720 minutes after the computer has been idled.

When
Specified
Time has
Elapsed

This option repetitively runs a macro every XX number of minutes c
intervals can be between 1 second and 99,999 minutes, 59 seconds
scheduled to run every 1 second and the macro takes 5 seconds to
function will not operate properly.

If planning to use macros that will run more frequently than every 1
change the Scheduler Frequency default setting. The default instruc
check every 10 seconds to see if a timed macro is ready to play bac
be reduced in order for scheduled macros to play back more freque

When Macro

File Loaded

This option instructs the macro to play back when the macro file cor
first loaded.




v Note: Screen Savers prevent a Scheduled Macro from operating correctly. Focus cannot be given to
a program if a screen saver is running. Also, the security measures built into the "Lock Workstation"
function of Windows prevent Macro Express from executing a macro.



When the Program Starts

Running a macro At Startup instructs Macro Express to immediately execute the
macro when Macro Express first starts up. If Macro Express is placed in the Start

Up folder, the macro plays back as soon as Windows starts and loads Macro

Express.

H Create New Macro
Activation

() HotKey

() Shortkey

(® schedule

() Window Title
() Mouse Event
O Control Event
() Directory Modification
() System Event
O Process Event
O Tep/P

(O Clipboard Text
O Floating Menu
(O No Activation

Create New Macro

Select an initial activation on the left. Additional activations can be added after the macro is created. ===

Run the macro
When the program starts M

Schedule Range

(® Every time this event occurs
(O Only the first time this occurs for the day

Macro Nickname: ‘5Chedu|e

[_]Build as a Popup Macro

OK

Cancel

Schedule

Select the preferred schedule option.

Every Time this Event Occurs
This option plays back the scheduled macro every time Macro Express is started.




Only the First Time this Occurs for the Day
This option plays back the scheduled macro the first time Macro Express is started
for the day. If the program is restarted, the macro does not play back.

Range
Select a date and time range for the macro to play back from the three options
available in the drop down list. These range options are described below.

Run the Macro Within this Date Range

Select a range of dates during which the macro may run. The macro plays back
during the hours of the day and for the duration of the days selected. Select the
Start Date when the macro is to first start running. Then select the End Date when
the macro ceases to run.

Run Between These Times Each Day
Select a start and an end time for the macro to run.

Run the Macro Between the Dates and Time

Select a starting date and time. Then select an ending date and time. The macro is
available to run anytime between the dates and times specified.

Run the Macro Indefinitely

Run the Macro Indefinitely does not stop the macro on a specific date. It continues
to run at the appointed time until the schedule is canceled or the macro is disabled
or deleted.

Start Calculating the Next Run Time At
Select the date and time to start calculating the next run of the macro.

Run the Macro Between These Hours of the Day
Optionally choose to have the macro only available to run during certain hours
of the day. Insert the start and end times.

Run the Macro on These Days of the Week

Select which days of the week to run the macro. For example, remove the check
marks from Saturday and Sunday if the macro is not needed on weekends.



Once

Use the Once schedule to play only once at one specific date and time. The macro
will not play again, unless the schedule is reset.

H Create New Macro
Activation

() HotKey

O Shortkey

(®) Schedule

() Window Title
() Mouse Event
() Control Event
() Directory Modification
() System Event
O Process Event
(O T1cp/P

() Clipboard Text
(O Floating Menu
() No Activation

Create New Macro by
Select an initial activation on the left. Additional activations can be added after the macro is created. ===

Run the macro
Once >

Schedule Range

E ‘

Run at: ‘ 3:40 PM v
on: | 4/20/2020 ~ |

If the activation was missed, run at the next available time

Macro Nickname: ‘Schedule

[_]Build as a Popup Macro

OK Cancel

Schedule

Select the Date and Time for the macro to run. Once the macro is run the first
time, it will not run again.

If the activation was missed, run at the next available time

If the computer was shut down or Macro Express was closed at the scheduled
macro run, this option runs the macro later when the computer is started or Macro
Express is reopened.




Range
Select a date and time range for the macro to play back from the three options
available in the drop down list. These range options are described below.

Run the Macro Within this Date Range

Select a range of dates during which the macro may run. The macro plays back
during the hours of the day and for the duration of the days selected. Select the
Start Date when the macro is to first start running. Then select the End Date when
the macro ceases to run.

Run Between These Times Each Day
Select a start and an end time for the macro to run.

Run the Macro Between the Dates and Time

Select a starting date and time. Then select an ending date and time. The macro is
available to run anytime between the dates and times specified.

Run the Macro Indefinitely

Run the Macro Indefinitely does not stop the macro on a specific date. It continues
to run at the appointed time until the schedule is canceled or the macro is disabled
or deleted.

Start Calculating the Next Run Time At
Select the date and time to start calculating the next run of the macro.

Run the Macro Between These Hours of the Day
Optionally choose to have the macro only available to run during certain hours
of the day. Insert the start and end times.

Run the Macro on These Days of the Week

Select which days of the week to run the macro. For example, remove the check
marks from Saturday and Sunday if the macro is not needed on weekends.



Hourly

The Hourly schedule runs a macro at a specific time each hour or every xx number

of hours.

M Create New Macro
Activation

() HotKey

(O shortkey

(®) Schedule

() Window Title
() Mouse Event
() Control Event
() Directory Modification
() System Event
O Process Event
OTepfp

() Clipboard Text
() Floating Menu
(O) No Activation

Create New Macro b

Select an initial activation on the left. Additional activations can be added after the macro is created. ot

Run the macro
Hourly v

Schedule Range

Run every minutes after the top of the hour
Check again in hour(s)

If the activation was missed, run at the next available time
Don't run the macro again if the time is within

30 - | minutes of the next scheduled runtime

Macro Nickname: ‘Schedu|e| |

[]Build as a Popup Macro

caca

Schedule

Run Every [ ] Minutes After the Top of the Hour

Enter the number of minutes after the hour when the macro is set to start. If the
macro is to start at 12:15, 1:15, 2:15, etc., then insert 15 into the edit field.

Check Againin [ ] Hours
The default value is one, which means that the macro runs every hour. Insert the
number 2 for the macro to run every two hours, 3 for every three hours, etc.

If the activation was missed, run at the next available time




If the computer was shut down or Macro Express was closed at the scheduled
macro run, this option runs the macro later when the computer is started or
Macro Express is reopened.

Don't Run the Macro Again if the Time is Within [ ]| Minutes of the Next
Scheduled Runtime

If the scheduled activation was missed, it may not be desirable to run the
macro twice within a short period of time, such as 12:40 and 1:00. Insert a
value such as 30 in this field. For example, if the computer restarts at 12:40,
the macro does not run because the time is within 30 minutes of the next
scheduled macro at 1:00.

Range
Select a date and time range for the macro to play back from the three options
available in the drop down list. These range options are described below.

Run the Macro Within this Date Range

Select a range of dates during which the macro may run. The macro plays back
during the hours of the day and for the duration of the days selected. Select the
Start Date when the macro is to first start running. Then select the End Date when
the macro ceases to run.

Run Between These Times Each Day
Select a start and an end time for the macro to run.

Run the Macro Between the Dates and Time

Select a starting date and time. Then select an ending date and time. The macro is
available to run anytime between the dates and times specified.

Run the Macro Indefinitely

Run the Macro Indefinitely does not stop the macro on a specific date. It continues
to run at the appointed time until the schedule is canceled or the macro is disabled
or deleted.

Start Calculating the Next Run Time At
Select the date and time to start calculating the next run of the macro.

Run the Macro Between These Hours of the Day
Optionally choose to have the macro only available to run during certain hours
of the day. Insert the start and end times.



Run the Macro on These Days of the Week

Select which days of the week to run the macro. For example, remove the check
marks from Saturday and Sunday if the macro is not needed on weekends.



Daily

The Daily schedule runs a macro once a day at the time specified.

M Create New Macro

Activation Create New Macro b
O HotKey Select an initial activation on the left. Additional activations can be added after the macro is created. )
otKe:
O Shortkey
@ Schedl Run the macro
chedule ; ]
Dail v
() window Title =aly
(C) Mouse Event Schedule Range

Control Event =
o Run at: ‘ 1:00 PM = ‘
() Directory Modification

() System Event Run every day(s)

(O Process Event If the activation was missed, run at the next available time
OTcep/1p [ ] Don't run the macro again if the time is within
(O Clipboard Text 0 - 0 -

- -

O Floating Menu
() No Activation

Macro Nickname: ‘Schedule |

[_]Build as a Popup Macro

Schedule
Run At

Enter the time that the macro is to run each day.

Run Every [ ] Days

The default value is one, which means that the macro runs every day. Insert the
number 2 for the macro to run every two days, 3 for every three days, etc.

If the activation was missed, run at the next available time
If the computer was shut down or Macro Express was closed at the scheduled



macro run, this option runs the macro later when the computer is started or
Macro Express is reopened.

Don't Run the Macro Again if the Time is Within [ ] Hours and [ ]
Minutes of the Next Scheduled Runtime

If the scheduled activation was missed, it may not be desirable to run the
macro twice within a relatively short period of time. For example, let's say
that the value is set to 12 hours, the macro is scheduled to run at noon and
the computer is shut down before noon. If the computer is not restarted until
6:00am the following day, the skipped macro does not run because the time
is within 12 hours of the next scheduled playback at noon.

Range
Select a date and time range for the macro to play back from the three options
available in the drop down list. These range options are described below.

Run the Macro Within this Date Range

Select a range of dates during which the macro may run. The macro plays back
during the hours of the day and for the duration of the days selected. Select the
Start Date when the macro is to first start running. Then select the End Date when
the macro ceases to run.

Run Between These Times Each Day
Select a start and an end time for the macro to run.

Run the Macro Between the Dates and Time
Select a starting date and time. Then select an ending date and time. The macro is
available to run anytime between the dates and times specified.

Run the Macro Indefinitely

Run the Macro Indefinitely does not stop the macro on a specific date. It continues
to run at the appointed time until the schedule is canceled or the macro is disabled
or deleted.

Start Calculating the Next Run Time At
Select the date and time to start calculating the next run of the macro.

Run the Macro Between These Hours of the Day
Optionally choose to have the macro only available to run during certain hours
of the day. Insert the start and end times.



Run the Macro on These Days of the Week

Select which days of the week to run the macro. For example, remove the check
marks from Saturday and Sunday if the macro is not needed on weekends.



Weekly

The Weekly schedule runs a macro once a week at the time specified.

M Create New Macro X
Activation Create New Macro A
O HotKey Select an initial activation on the left. Additional activations can be added after the macro is created. )
O Shortkey
® Schedu Run the macro
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() System Event Check again in week(s)
O Process Event o . . .
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() Clipboard Text
O Floating Menu
() No Activation
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Run At
Enter the time of day and the day of the week that the macro is to run.

Check Again in [ ] Weeks

The default value is one, which means that the macro plays every week. Insert
the number "2" to have the macro run every two weeks, "3" for every three
weeks, etc.

If the activation was missed, run at the next available time
If the computer was shut down or Macro Express was closed at the scheduled



macro run, this option runs the macro later when the computer is started or
Macro Express is reopened.

Don't Run the Macro Again if the Time is Within [ ] Days and [ ] Hours
and [ ] Minutes of the Next Scheduled Runtime

If the scheduled activation was missed, it may not be desirable to run the
macro twice within a relatively short period of time. For example, insert a
value of "2' in the days field. If the computer is restarted on Monday after
being on vacation for a week and the macro is scheduled to run Tuesday, the
skipped macro from the prior week does not run because the date is within 2
days of the next scheduled macro set for Tuesday.

Range
Select a date and time range for the macro to play back from the three options
available in the drop down list. These range options are described below.

Run the Macro Within this Date Range

Select a range of dates during which the macro may run. The macro plays back
during the hours of the day and for the duration of the days selected. Select the
Start Date when the macro is to first start running. Then select the End Date when
the macro ceases to run.

Run Between These Times Each Day
Select a start and an end time for the macro to run.

Run the Macro Between the Dates and Time
Select a starting date and time. Then select an ending date and time. The macro is
available to run anytime between the dates and times specified.

Run the Macro Indefinitely

Run the Macro Indefinitely does not stop the macro on a specific date. It continues
to run at the appointed time until the schedule is canceled or the macro is disabled
or deleted.

Start Calculating the Next Run Time At
Select the date and time to start calculating the next run of the macro.

Run the Macro Between These Hours of the Day
Optionally choose to have the macro only available to run during certain hours
of the day. Insert the start and end times.



Run the Macro on These Days of the Week

Select which days of the week to run the macro. For example, remove the check
marks from Saturday and Sunday if the macro is not needed on weekends.



Monthly

This schedule runs a macro once a month at the selected time.

H Create New Macro

Activation Create New Macro b
O HotKey Select an initial activation on the left. Additional activations can be added after the macro is created. )
O Shortkey
@ Schedl Run the macro
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Schedule

Run At

To set the monthly schedule first enter the time of day that the macro is to play
back. Then select from one of the three monthly date options explained below.

On the [ ] Day of the Month
Select a day of the month to have the macro run, selecting from day 1 - 31.

v Note: If the 31st day of the month is chosen, the macro will not run during the months that only
have 28 or 30 days. Select the Last Day of the Month option instead.

On the First - Last



Use this option to select the first, second, third, fourth, or last day of any day of
the week. For example choose to have the macro run on the second Tuesday of
each month, the third Friday of the month, etc.

On the Last Day of the Month
Use this option to schedule the macro to run the last day of the month.

Check Again in [ ] Months

The default value is one, which means that the macro is scheduled to run every
month. Insert the number "2" to have the macro run every two months, "3" for
every three months, etc.

If the activation was missed, run at the next available time

If the computer was shut down or Macro Express was closed at the scheduled
macro run, this option runs the macro later when the computer is started or
Macro Express is reopened.

Don't Run the Macro Again if the Time is Within [ ] Days and [ ] Hours
and [ ] Minutes of the Next Scheduled Runtime

If the scheduled activation was missed, it may not be desirable to run the
macro twice within a relatively short period of time. If this is the case, then
insert a value such as 10 in the days field. If the computer is restarted on the
second Monday after being on vacation and the macro is scheduled to run on
the third Tuesday, the skipped macro will not run because the time is within
10 days of the next scheduled macro set for Tuesday.

Range
Select a date and time range for the macro to play back from the three options
available in the drop down list. These range options are described below.

Run the Macro Within this Date Range

Select a range of dates during which the macro may run. The macro plays back
during the hours of the day and for the duration of the days selected. Select the
Start Date when the macro is to first start running. Then select the End Date when
the macro ceases to run.

Run Between These Times Each Day
Select a start and an end time for the macro to run.

Run the Macro Between the Dates and Time



Select a starting date and time. Then select an ending date and time. The macro is
available to run anytime between the dates and times specified.

Run the Macro Indefinitely

Run the Macro Indefinitely does not stop the macro on a specific date. It continues
to run at the appointed time until the schedule is canceled or the macro is disabled
or deleted.

Start Calculating the Next Run Time At
Select the date and time to start calculating the next run of the macro.

Run the Macro Between These Hours of the Day

Optionally choose to have the macro only available to run during certain hours
of the day. Insert the start and end times.

Run the Macro on These Days of the Week

Select which days of the week to run the macro. For example, remove the check
marks from Saturday and Sunday if the macro is not needed on weekends.



System Idle

Setting the schedule with the When the System Has Been Idle option plays back
the macro after the computer has been idle (no keyboard or mouse activity) for
the number of minutes specified. This option allows for up to 720 minutes after the
computer has been idled.

M Create New Macro
Activation

() HotKey

() shortkey

(®) Schedule

() Window Title
() Mouse Event
() Control Event
() Directory Modification
() System Event
O Process Event
OTep/1p

(O Clipboard Text
() Floating Menu
() No Activation

Create New Macro b
Select an initial activation on the left. Additional activations can be added after the macro is created. e

Run the macro
When the system has been idle v

Schedule Range

After the computer has been idle for minute(s),
run every minute(s)

[ 10nly run once
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After the Computer has been Idle for [ ] Minutes
Insert the number of minutes the computer must be idle (no keyboard or mouse
activity) before the macro starts.

Run Every [ ] Minutes
This option plays back the macro every X number of minutes if the macro does
not use the keyboard or mouse to change the idle state of the computer.




Example

In the image above, the scheduler waits for the system to be
idle for 10 minutes. The macro waits 12 minutes before
running the macro.

If the macro does not require use of the keyboard or mouse,
it plays back again in 12 minutes.

If the macro does change the idle status of the computer,
then the macro does not play back again until the system has
been idle for 10 minutes followed by the 12 minute wait
period.

Only Run Once
Select this option to only run the macro once after the computer has been idle
for the number of minutes specified.

Range
Select a date and time range for the macro to play back from the three options
available in the drop down list. These range options are described below.

Run the Macro Within this Date Range

Select a range of dates during which the macro may run. The macro plays back
during the hours of the day and for the duration of the days selected. Select the
Start Date when the macro is to first start running. Then select the End Date when
the macro ceases to run.

Run Between These Times Each Day
Select a start and an end time for the macro to run.

Run the Macro Between the Dates and Time
Select a starting date and time. Then select an ending date and time. The macro is
available to run anytime between the dates and times specified.

Run the Macro Indefinitely
Run the Macro Indefinitely does not stop the macro on a specific date. It continues
to run at the appointed time until the schedule is canceled or the macro is disabled

or deleted.



Start Calculating the Next Run Time At
Select the date and time to start calculating the next run of the macro.

Run the Macro Between These Hours of the Day

Optionally choose to have the macro only available to run during certain hours
of the day. Insert the start and end times.

Run the Macro on These Days of the Week

Select which days of the week to run the macro. For example, remove the check
marks from Saturday and Sunday if the macro is not needed on weekends.



When a Specified Time has Elapsed

The When a Specified Time has Elapsed option repetitively runs a macro every XX number
of hours, minutes and/or seconds.

H Create New Macro
Activation

() HotKey

() Shortkey

(®) Schedule

() Window Title
(C) Mouse Event
() Control Event
() Directory Modification
() System Event
O Process Event
() TCR/IP

(O Clipboard Text
(O Floating Menu
() No Activation

Create New Macro b
Select an initial activation on the left. Additional activations can be added after the macro is created. e

Run the macro
When a specified time has elapsed v

Schedule Range

Run every hours and minutes and seconds
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Run Every

Enter the time between every scheduled run of the macro. If the macro is to run every 30
minutes, then set the hours and seconds to 0. Set the minutes to 30.

v" Note 1: If a macro is scheduled to run every 1 second and the macro takes 5 seconds to execute, then this
function will not operate properly.

v" Note 2: If the macro is scheduled to run more frequently than every 10 seconds, it is necessary to change the
Scheduler Frequency default setting. This setting instructs Macro Express to check every 10 seconds to see if
a scheduled macro is ready to play back. Reduce this number in order for scheduled macros to play back more

frequently.




Range
Select a date and time range for the macro to play back from the three options
available in the drop down list. These range options are described below.

Run the Macro Within this Date Range

Select a range of dates during which the macro may run. The macro plays back
during the hours of the day and for the duration of the days selected. Select the
Start Date when the macro is to first start running. Then select the End Date when
the macro ceases to run.

Run Between These Times Each Day
Select a start and an end time for the macro to run.

Run the Macro Between the Dates and Time

Select a starting date and time. Then select an ending date and time. The macro is
available to run anytime between the dates and times specified.

Run the Macro Indefinitely

Run the Macro Indefinitely does not stop the macro on a specific date. It continues
to run at the appointed time until the schedule is canceled or the macro is disabled
or deleted.

Start Calculating the Next Run Time At
Select the date and time to start calculating the next run of the macro.

Run the Macro Between These Hours of the Day
Optionally choose to have the macro only available to run during certain hours
of the day. Insert the start and end times.

Run the Macro on These Days of the Week

Select which days of the week to run the macro. For example, remove the check
marks from Saturday and Sunday if the macro is not needed on weekends.



When the Macro File is Loaded

This is similar to the At Startup schedule with one difference. Any time that the
macro file containing the scheduled macro is loaded, the macro runs. When Macro
Express loads, the file opens and the macro plays back.
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Every Time this Event Occurs

Select this option to play back the macro every time the file loads. If another
macro file is opened and then the original file containing the scheduled macro is
reopened, the macro executes. Or if Macro Express is shut down during the day
and later restarted, the macro runs.

Only the First Time this Occurs for the Day
This option limits the playback to just once a day. The first time the file loads for




the day, the macro will play back - but not afterwards, until the next day.

Range
Select a date and time range for the macro to play back from the three options
available in the drop down list. These range options are described below.

Run the Macro Within this Date Range

Select a range of dates during which the macro may run. The macro plays back
during the hours of the day and for the duration of the days selected. Select the
Start Date when the macro is to first start running. Then select the End Date when
the macro ceases to run.

Run Between These Times Each Day
Select a start and an end time for the macro to run.

Run the Macro Between the Dates and Time

Select a starting date and time. Then select an ending date and time. The macro is
available to run anytime between the dates and times specified.

Run the Macro Indefinitely

Run the Macro Indefinitely does not stop the macro on a specific date. It continues
to run at the appointed time until the schedule is canceled or the macro is disabled
or deleted.

Start Calculating the Next Run Time At
Select the date and time to start calculating the next run of the macro.

Run the Macro Between These Hours of the Day
Optionally choose to have the macro only available to run during certain hours
of the day. Insert the start and end times.

Run the Macro on These Days of the Week

Select which days of the week to run the macro. For example, remove the check
marks from Saturday and Sunday if the macro is not needed on weekends.



Window Title

The Window Title activation instructs the macro to execute any time a specific
event occurs for the window title selected.
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Window Title to Look For

In the edit box, enter the title of the Window for the macro to find. The window

title is that which appears in the caption bar of a window. Macro Express examines

all window titles running on the computer in an attempt to find a match.

Click on the Browse button to see a list of all windows currently running on the

computer. This includes both windows that are visible when open and other system

windows that are not seen, though open. Select the window and click OK.



Partial Match/Exact Match

The Window Title does not need to be an exact match. A partial match will work.
For example, if looking for the Windows Notepad program, one could insert
"notepad" or "notep". This is particularly useful as some Window Titles change
based on whether a given file is open. Case sensitivity is not required. For
example, "NOTepad" will work as well as "notepad".

The Title contains Wildcards

Select this option if a wildcard is included in the window title name. A wildcard
includes the " * " or " ? " characters in the title to expand the possibilities of a
match. These are similar to the wildcards used in Windows for searches.

Event to Activate On
Select from one of four different events to trigger the macro. These are described
below.

Event Description
Window Gains The macro starts as soon as the specified window
Focus becomes the active window and has focus.

Window Loses The macro begins playback as soon as the window
is minimized or sent to the background.

Focus

Window is Closed | The macro starts when the defined window is
closed.

Window is The macro starts when the specified window is

Opened open.

Macro Nickname
Optionally assign a nhame to the macro to more readily determine what the macro
does.

Build as a Popup Menu
Select this option to open the Menu Builder window and create a popup menu.




Mouse Event

Create macros that run when the mouse button or a combination of mouse buttons
is clicked.

v Note: Windows may prevent some mouse activations from working based on various combinations
of mouse buttons, window parts, etc. that are selected.

M Create New Macro X

Activation Create New Macro

Select an initial activation on the left. Additional activations can be added after the macro is e
O HotKey created.

Shortke’
85 hed Iy Button(s) to Activate the Macro with:
Chedule
() Window Title
v| Middle
@ Mouse Event Right
|
() Control Event g
() Directory Modification ~ What to click on: Area on the screen &

O System Event Enter the rectangular region (in pixels) to monitor for the click

om0 e e
ocator mouse locator to sele
O Clpboard Tex Right: Bottom: coordinates

(O Floating Menu You can also select the coordinates by placing your mouse in the desired
position. Then, press Ctrl+Space to capture the top-left coordinates and

(O No Activation Alt+Space to capture the bottom-right coordinates.

System Menu
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Button(s) to Activate the Macro with

Macro activations may be assigned to the Left, Middle or Right mouse buttons. If
selecting more than one mouse button, such as in the example above, then the
macro will activate by pressing either the Left or the Middle mouse button.

What to click on

After assigning the mouse button or buttons to press, select what to click on in



order to trigger the macro - Area on Screen, Area on Window or Window Part.
These are explained below.

Area on Screen

Use this option to define regions on the screen that can be assigned as a mouse
activated macro. Clicking on the assigned area triggers the macro. This option
requires the input of four pixel coordinates - Left, Top, Right, and Bottom. Click
on the area within these four pixel coordinates to start the macro.

Area on Window

Use this option to define regions on a window that can be assigned as a mouse
activated macro. Clicking on this area of the window triggers the macro. This
option requires the input of four pixel coordinates - Left, Top, Right, and
Bottom. Click on the area within these four pixel coordinates to start the macro.

Locator

Click on the Locator button to launch this small utility to quickly help define
the pixel coordinates. After the locator is running, move the mouse to the
upper left corner of the region to be defined. Press Ctrl+Space to insert the
pixel coordinates in the Left and Top fields. Then move the mouse to the
lower right corner of the region to be defined. Press Alt+Space to insert the
pixel coordinates into the Right and Bottom fields. Press OK to save the
coordinates.

This action defines a square or rectangular area on the screen. Click within
the defined square or rectangular area with the designated mouse button to
start the macro.

Window Part

Define a macro to start by clicking on a specific part of a window. Parts include
the window border, window title bar, window menu, horizontal scroll bar,
vertical scroll bar, system menu, minimize button and maximize button.

v" Note: A few options have been excluded because they will interfere with Windows. These include
such things as Left Mouse with the Maximize or Minimize buttons.

Macro Nickname

Optionally assign a name to the macro to more readily determine what the macro
does.



Build as a Popup Menu
Select this option to open the Menu Builder window and create a popup menu.




Control Event

For our purposes, Control refers to the identifiable parts of a specific application
window. Controls may include such things as a button, an edit box, a toolbar, a
window title bar or others. The control may be part of the main application window
or be part of a child window (a window within a window).

WA Create New Macro X

Activation Create New Macro

Select an initial activation on the left. Additional activations can be added after the macro is e
O HotKey created.

O Shortkey Control Event

O Schedule You can use the utility program to select a control for this activation.
O Window Title Hide Macro Express

() Mouse Event : :
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OK Cancel

With Control Activation selected, the macro plays back when the control gains
focus or the window with the control gains focus. In the example above the control
name is listed. The program .exe is displayed followed by the window component
that must be active in order for the macro to play back.




Launch Utility

The first step is to select the control that will activate the macro. Below is an image
of the Capture Window Control window that appears when launching the control
utility.

To select a Window Control place the mouse cursor on the crosshair image, hold
down the left mouse button and drag the mouse over the control. When dragging
the crosshairs over title bars, buttons, edit boxes, forms, toolbars, etc., the outline
of the controls are highlighted. Once the control needed is highlighted, release the
left mouse button. Click on the Save button to return to the Create New Macro
window. The control details are saved in the edit box.

Capture Window Control it

Drag the crosshairs below by clicking on them and
dragging them over the control you wish to capture. Let

go of the left mouse button to capture the control. .
T

Control Details
v WORDPAD.EXE
Q-Document - WordPad: (WordPadClass)
v-: (msctls_statusbar32) Index=13
v: (Afx:00007FF670830000:0) Index=1
-1 (Button) Index=3

Save the control using the z-order of the control v

Relative to bottom-right
Restore parent window size

Save Cancel

Save the control using the z-order of the control

This method saves the control information based on the order in which the
controls are created or manipulated by the parent program. In some
applications, the z-order may change without notice or the user being able to
determine that it has changed.

Save the control using the contents of the control

This option makes the capture of a control more exact by also capturing the text
found in the control. So for example, assume capturing an edit box with the
word Test in it. During playback the macro looks for the edit box and verifies



that it contains the word Test. If the edit box text is changed to something else,
such as Reset or left blank, then the control that was captured, such as C[1],
will not match the actual control in the window - edit box.

Save the control using its coordinates

There are some controls that change information each time the window with the
control is opened or the program with the control is restarted as mentioned
above. This renders the information saved to the control obsolete and the
control will not be found the next time the macro is run. This Coordinates option
saves the control information based on the location of the control in the window.

Relative to the bottom-right

Typically the coordinates of the control are measured from the top, left corner
of the window that contains the control. Use this alternative method to obtain
the position of the control from the bottom, right corner of the window.

Restore parent window size

This option restores the size of the parent window (the window that contains
the control) to the size of the window when the original capture of the control
was made.

v Note: Not every button, menu item or component on a program is actually a Control. Sometimes
the only control in a given program is the window or dialog that pops up when the program starts.
We have also noticed that many of Microsoft's programs seem to have fewer controls than
programs from other manufacturers. How the controls work will depend upon the way the program
in use is designed.

Hide Macro Express

Hide Macro Express does what it implies. The program hides or gets out of the way
after pressing the Launch Get Control Utility. This makes it easier to locate the
application containing the control to capture.

Launch the Macro When
After selecting the control, decide when to activate the macro. Choose either when
the control gains focus or when the window that contains the control gains focus.

The Control Gains Focus
This option requires that the control be part of the active window and the
control gain focus. For example the mouse cursor could be in an edit box, giving



focus to this control. Or a button may be highlighted and have control.

The Control's Window Gains Focus

With this option the macro starts when the window containing the selected
control gains focus.

Control Details

This edit box lists the details of the selected control using the Launch Utility. The
information should match what was listed in the Capture Window Control window.

Macro Nickname

Optionally assign a name to the macro to later help more readily determine what
the macro does.

Build as a Popup Menu

Select this option and click on the OK button to open the Menu Builder and create a
popup menu.




Directory Modification

This activation type looks for changes to files in a folder or to the folder. A macro
starts when a change is made to a file in the selected folder or to the folder itself.
Some of the available options include the macro looking for changes to file size,
attributes, write time, security descriptor or checking if a file has been renamed or
deleted.

v Note: There is a maximum of 64 Directory Modification macros that may be active at any one time.
Any macros over the 64 limit are ignored. This total spans multiple macro files that may be open.

M Create New Macro X

Activation Create New Macro
Hotk Select an initial activation on the left. Additional activations can be added after the macro is e
(O HotKey created.

() Shortkey
O Schedule

() Window Title
(O Mouse Event What to watch: A file's size changes v

(O Control Event [ | Watch subfolder

(®) Directory Modification
() System Event

Directory Modification
Path to watch: ‘C:\Users\John\Documents\Insight Software\Logs ‘ [:]

O Process Event
(O TCp/P

(O Clipboard Text
(O Floating Menu
() No Activation
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OK Cancel

Path to Watch

Insert the folder path for the macro to monitor or click on the Browse button to
select the folder path.



What to Watch

Select from a list of file activities that the macro can monitor. These activities are
explained below.

Create, Rename or Delete a File
The macro activates when a file in the selected folder is either created, renamed
or deleted.

Create or Delete a Directory
The macro starts when the specified folder is created or deleted.

File or Directory Attributes Change

The macro plays back when the attributes of a file in the folder or the folder
itself is changed. The file attributes may include the Read-Only flag, Archive
setting, etc.

A File's Size Changes
Use this option to initiate a macro when the size of a file in the selected folder
changes.

A File's Last Write Time Changes
The macro starts when the last write time (or modified time) of a file in the
folder changes.

A Security Descriptor Changes
The macro starts if one of the security options of a file in the folder or the folder
itself has changed.

Watch Subfolders

Select this option to monitor any subfolders of the primary folder chosen.

Macro Nickname
Optionally assign a name to the macro to later more readily help determine what
the macro does.

Build as a Popup Menu



Select this option and click on the OK button to open the Menu Builder and create a
popup menu.




System Event

The System Event activation looks for changes to the system. The macro starts
when the specified system change occurs.

M Create New Macro
Activation

() HotKey

O Shortkey

O Schedule

() Window Title
() Mouse Event
() Control Event
() Directory Modification
(®) System Event
O Process Event
(O Tecp/1P

(O Clipboard Text
() Floating Menu
() No Activation

Create New Macro

Select an initial activation on the left. Additional activations can be added after the macro is e

created.

System Event

What to activate on: System Colors Change

Message
Use Constants File

Use Constant Value
Offset from WM_USER

Use RegisterWindowMessage

Message:
WParam:

LParam:

Macro Nickname: ‘

[ ]Build as a Popup Macro

Cancel

Incoming Message
Windows is a message based operating system. There are messages broadcast
throughout the system when certain events occur, such as when a hardware

component is added or removed.

This is another way for custom applications to launch macros. Rather than passing
the nickname through the postmessage routine, use this method to post a single

message.

When using the Incoming Message activation, select from the four types of



messages available.

Use Constants File

The user specifies an ini file containing a list of constant names and their values.
The "Message to Post" field should contain a constant name from this file.

An example would be the WM_LBUTTONDOWN message in the PostMessage.ini
file. In the file, the following line appears:

WM_LBUTTONDOWN=513

This means that when the user specifies WM_LBUTTONDOWN as the message,
message 513 is actually sent.

Constants File

The user specifies in the "Message to Post" field a message number to send to
the specified control.

Offset from WM_USER

WM_USER is a Windows constant that marks the beginning of the messages
that programmers can use for anything. In this case, the user specifies either a
positive or negative number that is added to WM_USER. Currently, Windows
defines WM_USER as 1024.

Use RegisterWindowMessage

This command allows the user to enter a constant string that can be used by
Windows to generate a message. This is primarily used to communicate with
other applications that have registered the same message.



Microsoft Definition of RegisterWindowMessage

The RegisterWindowMessage function defines a new window
message that is guaranteed to be unique throughout the
system. The message value can be used when sending or
posting messages.

The RegisterWindowMessage function is typically used to
register messages for communicating between two
cooperating applications.

If two different applications register the same message
string, the applications return the same message value. The
message remains registered until the session ends.

Only use RegisterWindowMessage when more than one
application must process the same message. For sending
private messages within a window class, an application can
use any integer in the range WM_USER through Ox7FFF.

Message

The message input into this field comes from one of three sources. The
message will be a constant from the Constants file, a string passed to
RegisterWindowMessage, or a value from WM_USER.

WParam - LParam

These fields allow the user to specify the WParam and LParam parameters.
The contents of these parameters depend upon the message being sent.
These values can be found in the Platform API library at
https://msdn.microsoft.com.

v Note: Consult https://msdn.microsoft.com for a list of messages available.

v Note: When Macro Express is installed, three .ini files ( PostMessage.ini, PostCommCtrl.ini and
PostRichEdit.ini ) are also installed into the Macro Express folder. The default path is C:\Program
Files (x86)\Macro Express Pro 6. These .ini files contain message definitions that can be used for
reference. Double click on the files to open and view in Notepad or Wordpad.

System Colors Change
Use this option to start a macro when a change is made to the Windows system
colors on the computer.



Resolution Change
Use this option to activate a macro when the system's screen resolution is changed.

Macro Nickname
Optionally assign a name to the macro to later more help readily determine what
the macro does.

Build as a Popup Menu
Select this option and click on the OK button to open the Menu Builder and create a
popup menu.




Process Event

The Process Event activation method initiates a macro when a Process first starts
or when it closes.

M Create New Macro K

Activation Create New Macro
Select an initial activation on the left. Additional activations can be added after the macro is e
(O HotKey created.

O Shortkey
Process Event

O Schedule
O Window Title Process to watch: NOTEPAD.EXE | E

() Mouse Event What to watch for: |Process Starts Running ~

() Control Event

() Directory Modification
() System Event

@ Process Event

(O Tecp/1P

(O Clipboard Text

() Floating Menu

() No Activation

Macro Nickname: ‘

[ ]Build as a Popup Macro

OK Cancel

Process to Watch

Click on the Browse button to select the process to monitor. Browse through a list
of processes in the Start menu or from a list of processes currently running on the
computer. Or look for where the process is installed on the computer.

What to Watch For

Process Starts Running
The macro activates as soon as the chosen process starts running.



Process Stops Running
The macro starts when a process ends or closes.

Macro Nickname
Optionally assign a name to the macro to later more readily help determine what
the macro does.

Build as a Popup Menu
Select this option and click on the OK button to open the Menu Builder and create a
popup menu.




TCP/IP

The TCP/IP activation monitors when an Internet or Network connection has been
made or released.

M Create New Macro K

Activation Create New Macro
Select an initial activation on the left. Additional activations can be added after the macro is e
(O HotKey created.

O Shortkey

() schedule

() Window Title
(C) Mouse Event
() Control Event
() Directory Modification
() System Event
O Process Event
(® TCP/IP

(O Clipboard Text
() Floating Menu
() No Activation

TCP/IP Monitoring
Start macro when: [TCP/IP Stack is available v

Activates the macro when an Internet/network connection is made

Macro Nickname: ‘

[ ]Build as a Popup Macro

caca

TCP/IP Stack is Available

This option activates the macro when an Internet or Network connection is
successful.

TCP/IP Stack is Unavailable

This option activates the macro when all Internet or Network connections are
released.




Macro Nickname
Optionally assign a name to the macro to later more readily help determine what
the macro does.

Build as a Popup Menu
Select this option and click OK to open the Menu Builder and create a popup menu.




Clipboard Text

This activation method starts a macro based on the contents of the clipboard.
Select whether the clipboard does or does not match the text entered into the edit
field. Or choose whether the clipboard contains or does not contain specific text.

H Create New Macro
Activation

() HotKey

() shortkey

(O schedule

() Window Title
(") Mouse Event
O Control Event
() Directory Modification
() System Event
O Process Event
(O Tep/ip

(®) Clipboard Text
O Floating Menu
() No Activation

Create New Macro

Select an initial activation on the left. Additional activations can be added after the macro is ey

created.

Clipboard Contents

Activate the macro when the clipboard text

equals

v |Macro Express

Macro Nickname: ‘

[_]Build as a Popup Macro

Cace

Equals / Does not Equal
These options require that the text in the clipboard match or not match the word
or phrase selected as a trigger. For example, suppose Macro Express is listed as
the clipboard text trigger and the Equals option is selected. The macro starts when

the words Macro Express are copied to the clipboard.

The macro starts if the activate option is changed to Does not Equal and text other
than Macro Express is copied to the clipboard.

< Use the Does not Equal option with caution as this may trigger macros unexpectedly when copying



items to the clipboard.

Contains / Does not Contain

These options require that the text in the clipboard contain or not contain the word
or phrase selected as a trigger. For example, suppose Macro Express is listed as
the clipboard text trigger and the Contains option is selected. The macro starts
when the words "I really like Macro Express" are copied to the clipboard. It plays
back because the trigger - Macro Express - is part of the clipboard contents.

The macro starts if the option is changed to Does not Contain and text that does
not include the words Macro Express is copied to the clipboard.

% Use the Does not Contain option with caution as this may be trigger macros unexpectedly when
copying items to the clipboard.

Macro Nickname

Optionally assign a name to the macro to later more readily help determine what
the macro does.

Build as a Popup Menu
Select this option and click on the OK button to open the Menu Builder and create a
popup menu.




No Activation

It is possible to create a macro and not assign any activation key to the macro.
There are two primary uses for the No Activation option. First, create generic
macro templates that can be incorporated into other macros - a set of instructions
useful for insertion into several other macros. The Macro Run command allows for
inserting No Activation macros into other macro scripts.

A second use for this option is to place the macro in a popup or floating menu. A
macro activation is not necessary if the macro is part of a popup or floating menu.
The only way to invoke the macro would be through the menus.

Macro Nickname
Optionally assign a name to the macro to later more readily help determine what
the macro does.

Build as a Popup Menu
Select this option and click on the OK button to open the Menu Builder and create a
popup menu.




Stopping a Macro

Occasionally it may be necessary to stop a running macro before it has finished.
There are several ways to stop a running macro.

Aborting a Macro
Below are several ways to stop a running macro.

« Press the default key sequence of Win + End.

. Ifthe Running icon displays when a macro is running, right mouse click on

the icon in the notification area.
« Change the default sequence to another combination in Options >

Preferences > Playback > Miscellaneous.

Please note that macros that consist of many keystrokes can send the keystrokes
rather quickly and they are buffered in Windows. Once such commands have been
buffered in Windows, aborting a macro does not cancel them. In these cases, it
may appear that the abort command did not work when in reality the macro has
already finished issuing its commands and Windows is now processing them.

If more than one macro is running, all macros will be stopped when initiating any
of the above mentioned actions.

v" Note: The Timed Delay in Seconds and the Wait for Time to Elapse commands suspend Macro
Express for the amount of time specified. During this delay period the macro cannot be terminated.

Macro Stop

The Macro Stop command stops the execution of a macro before the macro steps
have completed. Insert the Macro Stop command into the macro script. Whenever
this line in the macro is reached, the macro terminates. In most cases this
command is used in conjunction with a conditional statement. For example, if a
desired condition is not met, terminate the macro.




Using the Macro Explorer

Macro Explorer

By default Macro Express opens to the Macro Express Pro - Explorer window. This
window displays a list of macros contained in the file currently open. The Macro
Explorer is the starting point for creating new macros or editing existing ones.

M Macro Express Pro - Explorer — O X
File Macro Category Search Options Tools Help
AL 47ICHONEEIE B
Categories Macros
WA System Macros 0 ‘Nickname _ ‘Activat_ions_ ‘Scope ‘Modiﬁec‘Category Last Ru ‘E
r@ macex.mex Process Text File No Activation Global 5/30/20: Never
5 B | : H Process Folder No Activation Global 5/30/20: Never
- samp F._-s.mex H Rename File with the Date in thiNo Activation Global 5/30/20: Never
g WorkFile.mex H Copy and Paste Repeatedly No Activation Global 5/30/20: Never
_______ H _ Repeat Until No Activation Global 2/13/20: Never
. < PRepeat With Prompt No Activation Global 5/30/20: Never
Run Control Panel No Activation Global 5/30/20: Never
H Variables and Mouse No Activation Global 9/19/20 Never
H Wait for Mouse or Key No Activation Global 5/30/20: Never
H Window Resize and Reposition No Activation Global 6/2/201 Never
H Show Macro Progress No Activation Global 2/7/201! Never
H Access a program in the System No Activation Global 8/21/20: Never
H Split and Combine Strings No Activation Global 5/30/20: Never
WA Date Time Math No Activation Global  6/2/201 Never E
M Repeat With Prompt
Activation Scope
Global
38 Macros D:\Program Files (x86)\Macro Expres=

Actions

The icons at the top of the Macro Explorer window are the primary methods for
navigating through the program. Clicking on any of these icons will load a different
program function.

Create a new macro (.mex) file.

‘ ] ‘New File



'|_ 'u"’ 1_' d 1

Open File

Open an existing macro (.mex) file. Or click on the
triangle button to view a list of recently used macro
files and select one to open.

New
Macro

Click on the New Macro button to start the process of
building a macro in the Script Editor or Direct Editor.
The first step prompts to select an activation method
and assign a name to the macro. The next step
opens the Script Editor to begin creating the macro.
The Script Editor is the default editor. If desired, click

on the Direct Editor icon while in the Script Editor
to switch to the Direct Editor.

Run Now

Click this button to run the macro that is highlighted
in the Macro Express Pro - Explorer window.

Edit
Macro

Highlight a macro from the list of already created
macros. Click on the Edit Macro button to open the
Script Editor and display the macro. Or double click
on the macro in the list to open it in the Script Editor.

Capture

Starts the process for recording or capturing a
macro. Keystrokes and mouse clicks/movements are
recorded and saved.

Quick
Wizards

Opens the Quick Wizards dialog. There are 25+
different wizards to provide step by step instructions
for creating various macro types.

A

Recycle
Bin

Macro Express has its own recycle bin. Any macros
deleted from the Macro Explorer are sent to the
Recycle Bin. If a macro is deleted by mistake it can
be restored to its original file. Or the macros in the
recycle bin may be removed permanently.

Categories

Use the Categories option to assign macros to user defined categories. With large
numbers of macros created, the categories provide an easy way to locate macros
for further editing, refinement, exporting, etc.

For example create a Password category to hold any macros containing important
passwords or assign any MS Word specific macros to a MS Word category. This
makes it easy to quickly find the macro needed.



Categories

H System Macros
v D macex.mex
r[j Help
D Responses
r"‘::l_I .
|/ Tutorials
D * Unassigned *

=

samples.mex
— .
D WorkFile.mex

Upon installation there are three default categories - System Macros, All
Categories and Unassigned. These categories may not be renamed or deleted.
Additional categories may be created as shown in this example. Since Macro
Express allows more than one macro file to be open at a time, multiple sets of
categories may be displayed - a set for each open file.

v" Note: A macro may only be assigned to one category.

Macros

The Macros section displays the list of macros in the file or category that is
currently open. When saving macros in the editors, quick wizards or with a macro
capture, the program will return to the Macro Explorer. The list of macro
information is displayed in six columns.

Index

The index column lists the macros in the order that they were created. The first
macro created in the file displays as number 1, the second macro as humber 2,
etc.

Nickname
Optionally assign a nickname to any macro to help more readily identify the
purpose of the macro. Any not assigned a nickname display with a blank field.

Activation

The Activation column displays the method selected to execute the macro. This
column displays the hot key combinations, any timed macros, the letter
combinations used for any shortkeys or any other type of activation method
chosen. If more than one activation is assigned to the macro, this column
displays Multiple for that macro. If the Show Preview Pane option is selected
highlight the macro to view all of the activations in this pane.




Scope
This column lists the macro scope, whether it is global, global except, window
specific, program specific, a system macro, a popup menu or a floating menu.

Category
This column lists the category to which the macro was assigned.

Modified

The Modified column displays the date and time that the macro was last
modified.

Last Run
The Last Run column displays the date and time that the macro was last run.

Sorting Macros

To quickly sort the list of macros displayed, click on one of the column headers,
Nickname, Activation, Scope, Category, Modified or Last Run. The macros will be
sorted based on the column header selected. Click on the header a second time to
reverse the sort order.

Right Click Context Menu

Right mouse click on a macro in the macro list to open the context menu. The
menu options include Run Macro Now, Copy Macro, Edit Macro, Enable/Disable
Macro, Recapture Macro, Delete Macro and Macro Properties.

Keyboard Shortcuts

Below is a listing of the Keyboard Shortcuts available in the Macro Explorer.

Keystroke Action

Ctrl+F Find

F3 Find Again

Delete Delete highlighted macro
Ctrl+P Print macro list



These keyboard shortcuts are used to navigate through the program. These
keystrokes perform the same function as clicking on the Actions Icons in the left
hand column of the program.

Keystroke Action

Alt+E Edit highlighted macro, when not in the Macro Recycle bi
Alt+E Return to Macro Explorer from Recycle Bin

Alt+N New Macro

Alt+P Capture

Alt+Q Quick Wizards

Alt+B Recycle Bin




System Macros

Macro Express defines several system macros for a variety of program functions.
The macros are stored in a System Macro file and are available with any macro file
currently open. Each of the system macros is described below.

Reassigning a System Macro hot key

The system macros are assigned to hot keys but may be renamed at any time to
something that is easier to remember. To rename a system macro, expand the
System Macros category right mouse click on the macro. Left click on Properties
from the menu to open the System Macro window as shown below. Click on the
Change button and select another hot key combination. The new hot key will
display in the Activations column of the Macro Express Pro - Explorer window.

System Macro

Name: Start/ Stop Capture
Current HotKey: Ctrl+Alt+Shift+X

0K Cancel

Descriptions of the available system macros

System Macro

Default Hot
Key

Description

Terminate
Macro Express

Ctrl+Alt+Shift+V

Terminates Macro Express, Editor and Pl

Run Macro
Express Editor

Ctrl+Alt+Shift+W

Activates the Macro Express - Explorer v
Explorer program to the forefront from i
minimized state.

Start/Stop
Capture

Ctrl+Alt+Shift+X

Starts capturing keystrokes or mouse m
macro. When finished capturing, press C
to stop recording.

Resume Pause

Ctrl+Alt+Shift+Y

If a macro contains a Pause command p
Ctrl+Alt+Shift+Y hot key to resume the
Pause window.




Menu of Macros
for Topmost
Window

Ctrl+Alt+Shift+Z

Opens a popup menu listing all Window ¢
Specific macros that pertain to the windc
the hot key is pressed.

For example, press the hotkey while not
window and all Window or Program Spec
notepad will be displayed in the menu.

Optionally choose to display any macros
Except that do not exclude the active wit
display all global macros.

Select to display the icons associated wil
name of each macro in the menu, or the
script.

Suspend /
Resume Macro
Express

Ctrl+Alt+Shift+U

Toggles between suspending Macro Expi
active status. No macros will play back v
suspended.

The icon in the notification area is chang
Macro Express is suspended.

Capture a
Temporary
Macro

Ctrl+Alt+Shift+T

This is a quick way to capture a macro f¢
assigning of hotkeys or checking setting:
macro is saved temporarily for playback

Play the
Captured
Temporary
Macro

Ctrl+Alt+Shift+S

Starts the play back of the temporary m




File Menu

File Commands

File Menu

New File

Macro Express allows for creation of multiple files with different macros in each file.
Click on the File > New File option to create a new file. A dialog box appears
prompting for a file name and folder location.

Open File
Click on this option to open a previously created macro file. A dialog box appears
prompting to select the file.

Close File

If more than one macro file is currently open, use this option to close one of the
files. A dialog box appears prompting to select the file and choose from which
folder.

Backup Macro File(s)

This option immediately backs up the macro file that is currently open. If using the
automatic backup schedule, this option does disturb the schedule previously
created. It uses the settings defined in the Backup Preference panel, such as
where the backup is saved and how many backup copies are created.

Restore Macro File

Use this option to restore from a backup file. A Windows dialog will open prompting
to select the backup file. The dialog opens to the folder designated in the Backup
preferences panel for file backups. If the backup options were recently changed,
then it may be necessary to browse to the location where previous backups were
stored.

Performing the restore closes the file currently open and replaces it with the
backup file selected.




Reopen

This is a convenient way to open a macro file previously used. This option displays
the last several macro files opened. Click on the desired file to load into Macro
Express.

This may close all other open macro files depending on the Close open macro files
before loading another macro file preference setting selected.

Import
There are three different import options available in Macro Express. Click on the
topic of interest below to obtain more information.

Import Macros
Import Text File
Import Playable Macro

Export
There are three different export options available in Macro Express. Click on the
topic of interest below to obtain more information.

Export Macros
Output Macro Information
Export as Playable Macro

Print Macro List

Click on File > Print Macro List or click on the speed button to print a list of all
macros currently assigned. The list contains the activation method, such as the hot
key combination used, the nickname assigned, if any, and macro scope (global,
system, window specific or program specific). The list includes the information as
shown in the Macro Explorer window.

Printer Setup

Select this option to ensure printer settings are accurate before printing the macro



list.

Terminate Macro Express Editor

Selecting this option closes the Macro Express Pro - Explorer window but leaves the
Player running. The macros still run with the Explorer window closed.

Terminate Macro Express Editor and Player

Selecting this option closes the Macro Express Pro - Explorer and Player. It shuts
down the entire program, at which point no macros can run.



Import/Export Macros

Import Macros

The import and export functions are convenient methods to transfer macros
between Macro Express users. Use the Export command to save the macros to a
disk or drive. On another computer import the macros from the disk, flash drive, or
similar device.

M import Macros X
Please select the macros that you would like to import:
| |Index |Name Activation Scope -
1 Access a program in the System Tray No Activation Global
2 Calc ulator and Note pad No Activation Global
3 Copy and Paste Repeatedly No Activation Global
4 Counter from Run to Run No Activation Global
30 Date Time Math No Activation Global
35 Disable/Enable Welcome Menu of Sample MNo Activation Global
5 Floating Menu of Sample Macros Floating Menu Global
fn Compare Version Numbers No Activation Global
3 fn Display Size Adjust No Activation Global
38 Get Miscellaneous Information No Activation Global .
7 Hide a Program No Activation Global
8 Launch Web and Fill Qut Form No Activation Global
32 Macro Express Pro Helper Macros No Activation Global
9 Maximize and Minimize No Activation Global
11 Menu and Question No Activation Global
37 Menu of Sample Macros Schedule Global
12 Multiple Choice Menu with Default No Activation Global
13 Open Explorer Folder No Activation Global
14 Paste Text No Activation Global E
24 Dival Calar Hovadacimal fram Manca | aeate Chel o Shifta 1 Glahal
Select All Clear OK Cancel

To import macros, click on File > Import > Import Macros. A Select a File to Import
window opens with a standard dialog box to browse through folders to find the
correct file. All Macro Express macro files have a file extension of .mex. Highlight
the file to import and click on Open. A list of all macros found in that file are
displayed.

Please select the macros that you would like to import
Highlight the macros to import by clicking on each macro.



Select All
This option highlights all macros in the file so that all are imported.

Clear
This option clears any highlighted macros so that none are imported until a new

selection is made.

Click on the OK button to start the import process. A progress bar displays during
the import process until the Import Complete message appears. Click OK to return
to the Macro Explorer. This finishes the process and the macros are now found in

the current file.

v Note: If importing a popup menu, all of the macros contained in the menu must also be imported.
Once imported, you will most likely need to rebuild the menu.



Import Text File

Selecting File > Import > Import Text File from the Macro Express Pro - Explorer
menu imports a group of Shortkey or Hot Key macros. A standard Windows dialog
box opens prompting to navigate and select the text file to import.

The text file must be in a specific format. An improper format will cause
unpredictable results. The formatting of the lines in the text file is described below.

Line 1 - The first line requires an <ITEM NAME> tag followed by the shortkey
or hotkey name. The hotkey name is the key sequence used and must be in the
format found in the Create New Macro window. If a match is not made on one of
these, then it is assumed that the name supplied is a shortkey.

Line 2 - This line contains the nickname assigned to the macro.

Line 3 - Line 3 contains the macro text and commands. This line may span
multiple lines as shown in the examples below.

The <ITEM NAME> tag marks the start of a new macro in the text file.

Example
This example shows the format for two shortkey macros
followed by a hot key macro to be imported.

<ITEM NAME>issadd

Our Address

Insight Software Solutions, Inc.

P.O. Box 106

Kaysville, UT 84037

<ITEM NAME>downm

Download Macro Express

You can download a 30 day evaluation copy of Macro Express
from www.macros.com/download.htm.

<ITEM NAME> Ctrl+Shift+m

ME Pro 6 Overview

Macro Express is the premier macro utility on the market.
With Macro Express, you can record, edit and play back
mouse and keyboard macros. Its powerful tools and robust
features will noticeably boost your productivity.




Macro Express - Explorer > File > Import > Import Text File
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Import Playable Macro

A "Playable Macro" file format is available. Files with an .MXE file extension are
similar to .EXE files. Double clicking on the .MXE file from within Windows Explorer
plays back the macro.

Macro Express is not required to be running to execute the .MXE macro, though
installation of the Macro Express player is necessary. The .MXE file may also be
executed from a command line parameter to run a batch file.

Importing the macro

This option is used for importing a playable macro from another machine on a
network or from a disk that contains a playable macro and converting it to a .MEX
macro.

From the Macro Express - Explorer window click on File > Import > Import a
Playable Macro. A dialog box prompts to search for the .MXE file to import. Once
located, highlight the file to import and click OK to import the file.

The Copy Hot Key window opens prompting to assign a hot key or other method
for executing the macro. The imported macro is then placed into the list of macros
displayed in the Macro Express Pro - Explorer window.



Export Macros

The import and export functions are a convenient way to transfer macros between
Macro Express users. Use the Export command to save macros to a disk or drive.
On another computer Import the macros from the disk, flash drive, or similar
device.

M Export Macros X
Please select the macros that you would like to export:
Drag a column header here to group by that column
Name Activation & |Scope Category
Paste Text No Activation Global .
Play System Sounds No Activation Global
Menu and Question No Activation Global
Process a CSV Delimited File No Activation Global
Process Text File No Activation Global
Process Folder No Activation Global
Rename File with the Date in the |No Activation Global
Copy and Paste Repeatedly No Activation Global
Repeat Until No Activation Global
Repeat With Prompt No Activation Global P
23 Run Control Panel No Activation Global
24 Variables and Mouse No Activation Global
25 Wait for Mouse or Key No Activation Global
26 Window Resize and Reposition |No Activation Global
27 Show Macro Progress No Activation Global
1 Access a program in the System T|No Activation Global
29 Split and Combine Strings No Activation Global
M3I} Date Time Math No Activation Global hd
Include the category information in the new file
Please enter the name of the new macro file:
‘C:\Users\David\Documents\samples.mex ‘ E
‘ Select All ‘ | Clear OK | ‘ Cancel ‘

Macro Express Explorer > File > Export > Export Macros

Please Select the Macros that you Would Like to Export

To export macros, click on File > Export > Export Macros. A window opens showing
all macros from the macro file currently in use. Highlight the macros to export.

Select All
This option highlights all macros in the file so that all are exported.

Clear



This option clears any highlighted macros so that none are exported until
another selection is made.

Include the Category Information in the New File
This option saves the category information in the new file if the macros selected for
export have been assigned to categories.

Please Enter the Name of the New Macro File
Enter the name and file path of the file where the macros will be exported. Or click
on the browse button to navigate to the location of the file to be saved.

Click OK to export to the new file. The file is saved as a Macro Express macro
(.mex) file which can be opened directly by Macro Express using the File > Open
File menu or the macros may be imported.

v Note: If exporting a popup menu, all of the macros contained in the menu must also be exported.
Most likely the menu will need to be rebuilt in the new file.



Output Macro Information

Use this option to select what information from the macro file to save to a text file.
As shown in the window below, select which items to output and click OK. A
standard dialog box prompts for a file hame and folder destination for storing the

data.

The newly generated text file contains selected information about each macro in
the file.

Macro Information to Output
Activation Name
Scope Icon Path
Script

cace

Macro Information to Output

Activation - Lists the Hot Key, Shortkey or other activation of the macro.
Scope - Lists the scope of the macro.

Script - Displays the macro script in Direct Editor format.

Name - Lists the name assigned to the macro.

Icon Path - Lists the names of the icons used.

The information saved may be printed in any text editor.



Export Playable Macro

A "Playable Macro" file format is available in Macro Express. Files with an .MXE file
extension are similar to .EXE files. Double clicking on the .MXE file from within
Windows Explorer, My Computer or the desktop plays back the macro.

Macro Express is not required to be running to execute the .MXE macro, though
installation of the Macro Express player is necessary. The .MXE file may also be
executed from a command line parameter to run a batch file or similar.

Exporting the macro

The Export as Playable Macro option exports (creates) any defined macro as a
playable .MXE macro. From the Macro Express Pro - Explorer window highlight the
macro to export and click on File > Export > Export as Playable Macro. Or right
click on the macro and select Export > Export as Playable from the context menu.

A dialog box prompts for a file name and folder destination for storing the .MXE
file. By default, the macro nickname is inserted as the file name but may be
changed if desired.

Windows does not allow the following characters in a file name: | ? : \/" < >
and *. If the macro nickname contains any of these characters, they will be
deleted from the default .MXE file name.

v Note: Any activation assigned to the original macro, such as a hot key, schedule or other, is not
stored in the playable macro. Double click on the .MXE file to activate the macro.

v Note: Do not include any commands in the playable macro. The macro from the Macro
Run command is not compiled into the playable macro and will cause an error when running.



Macro

New Macro

To create a new macro, click on Macro > New Macro from the menu or click on the
New Macro icon to open the Create New Macro window. The first step is to select
the type of macro activation needed. The hot key activation is the default
selection. After assigning the activation type, enter a macro nickname and press
OK to proceed to the Script Editor.

M Create New Macro X
Activation Create New Macro
() HotKey Select an initial activation on the left. Additional activations can be added after the macro is created. ==
@ Shortkey
Shortke
() schedule y -
O Window Title Original Shortkey: ‘ema|l ‘
(C) Mouse Event (® Use Global Settings (Customizable from Options | Preferences | Activations | Shortkeys)
(O Control Event (O Customize Settings (for this macro only)
() Directory Madification
(O System Event Match First Character's Case between Shortkey and Replacement Text
(O Process Event If the first letter in the text is uppercase, don't change it to lowercase
O Tep/p Require Exact Uppercase/Lowercase Match on Shortkey
() Clipboard Text No Case Sensitivity
O Floating Menu
(O No Activation Do not Remove Keystrokes Typed
Macro Nickname: ‘MY Email Address |
[_]Build as a Popup Macro
carel
Hot Keys

To activate a new macro with a hot key, make sure the Hot Key choice is selected.
Place the cursor in the edit box and hold down the Hot Key combination to use. The
combination pressed is placed in the edit box. When the macro is complete, press
this hot key combination to activate the macro.



Or scroll through the list of keys and highlight the one wanted. This also places the
hot key combination in the edit box.

v Note: Use the hot key combinations displayed in red with caution. These combinations may conflict
with basic Windows functionality, such as the clipboard copy (Ctrl + c).

Shortkeys

Select the Shortkey option and type in the shortkey (up to a 32 letter code) to use
to activate the macro. A shortkey is a set of characters such as abc, myname, etc.
See the program specifications for a complete list of characters accepted as
shortkeys.

The macro runs when the characters are typed into an application that accepts text
input. The Shortkeys activation will not trigger a macro from the Windows desktop
or other applications that do not accept text input.

v Note: Before using the Shortkeys feature click on Options > Preferences > Activations > Shortkeys
tab to define the settings.

Scheduled Macro

Selecting Schedule activates the Scheduler options. Select the schedule wanted
and click OK to build the macro in the Script Editor. The macro then plays back at
the time designated.

Window Title

This option instructs a macro to execute any time the selected Window Title has
focus. In other words, the macro runs once the window is activated.

In the edit box, enter the title of the Window that will start the macro. The title of
the window is that which appears in the caption bar of a window. Macro Express
examines all Window Titles running on the computer in an attempt to find a match.
The Window Title does not need to be an exact match.

A partial match also works. For example, "notepad" or "notep" would be sufficient
for the Windows Notepad program. This is particularly useful as some Window
Titles change based on which file is open.

Case sensitivity is not required. For example, "NOTepad" works as well as
"notepad".



Mouse Event
This option uses mouse clicks to activate macros. Two different methods are
available.

1. Define regions on the screen that can be assigned to a mouse activation.
Clicking on the defined area of the screen runs the macro.

2. Click on a specific part of a window to execute the macro. Window parts
include the window border, window menu, window caption bar, horizontal
scroll bar, vertical scroll bar, system button, minimize button and maximize
button.

v" Note: A few options have been excluded where they will interfere with essential functionality of the
windows such as Left Mouse with the Maximize or Minimize buttons.

Macros may be assigned to the left, middle or right mouse button and may have a
scope of global, window or program specific.

Control Event

The Control option activates a macro when a specific Window control becomes
active or the control's window becomes active. The control may be a window
button, edit box or another identifiable portion of a window.

Directory Modification

The Directory Modification activation looks for changes to files or folders. When a
change is made to the file or folder specified, the macro will start. Among the
options, the macro may look for changes to file size, attributes, write time or if a
file has been renamed or deleted.

System Event

The System Event activation looks for changes to the system such as an incoming
message, resolution change or system color change. When the specified system
change occurs, the macro starts.

Process Event
The Process Event activation method starts a macro when a Process starts or shuts
down.

TCP/IP



The TCP/IP activation monitors when an Internet or Network connection has been
made or released.

Clipboard Text

The Clipboard Text activation method starts a macro based on the contents of the
clipboard. Select whether the clipboard does or does not match the text supplied in
the edit field. Or choose whether the clipboard contains or does not contain the
text.

Floating Menu

A floating menu has the same form and options as a Popup Menu except that it
always remains on top and is always accessible as long as the Macro Express
Player is running. A floating menu can be minimized to just the caption bar to free
up space if needed. Multiple floating menus can be created. The last location of the
floating menu is retained and used with subsequent runs of Macro Express. Use the
Build Macro Menu window to select which macros to include in the floating menu.

None

This option does not assign an activation to the macro. There are at least two
possible uses for the No Activation option. First, create generic macro templates
that can be incorporated into other macros - a set of instructions that may be
useful for insertion into other macros. Use the Macro Run command to insert this
type macro into other macros.

A second use for this option is to place the macro in a popup or floating menu. A
macro activation is not necessary if the macro is part of a popup or floating menu.
The only way to invoke the macro would be through the menus.

Macro Nickname

Assign a name to the macro to help remember what the macro does. The
nickname, along with the activation, is displayed in the Macro Explorer and is
optional.

Build as a Popup Menu
Selecting a Popup Menu activates the Menu Builder. After selecting the activation,
check the Build as a Popup Menu box and click OK to open the Menu Builder




window. In this window select which macros to include in the popup menu. When
activated, the popup menu displays all macros included in the menu. Choose which
one to run from the menu.



Capture Macro Introduction

The simplest type macro to create is a recorded macro. The macro records each
keystroke, mouse click or mouse movement made. After saving the macro, play
back the macro and watch it repeat each of the steps just recorded. If a mistake is
made in the recording, either re-record the macro or edit the macro with the Script
Editor.

The first step before capturing a macro is to select capture options, such as
whether to record mouse movements, playback speed, base the mouse position
relative to the position of the window or entire screen, etc. Use the Options >
Preferences > General > Capture menu to define the default capture settings.

Each time a capture is started, the options selected are stored as the default
values. If a change to one of the settings is necessary for a particular recording,
make the change before the capture starts.

There are two different ways to initiate a macro capture. Examples for using both
of these methods are outlined in the Tutorial section of the Help file and also in this
section for convenience.

Assign Macro Activation First

Click on the Capture Icon or Macro > Capture Macro from the menu to start the
capture process. This method requires selecting the macro activation and
reviewing or changing the default capture options before starting the capture.

Assign Macro Activation After Capture

The second method uses the System Macro, Ctrl+Alt+Shift+X. While in another
application, press the System Macro to begin capturing a macro in that application.
This method uses the capture default settings that were defined in the Preferences
section. After the capture is complete, follow the prompts to assign a macro
activation.




Quick Wizards

The Quick Wizards are a convenient way to step through the macro creation
process. The sequence is essentially the same for each of the wizards and are
basically self explanatory. We'll briefly discuss the basic steps of the wizard.

Wizard Steps

1. Select the category or type of macro to create and then click on the Next
button.

2. The second step prompts to select the specific type of macro to create. Click
Next to advance.

3. A window opens listing the functions of the wizard selected as well as giving
some examples of macros that may be created with this wizard. Click Next
to advance to the next screen.

4. Depending on the wizard selected, a prompt appears asking what to do with
the macro or instructions are provided to begin building the macro. Input
the necessary information and click next to proceed.

5. After entering the necessary information for the macro, the next step is to
select a method for executing the macro - hot key, timed macro, etc. Select
an activation method and click Next.

6. Define if the macro should play back in all programs, a single program or only
in a specific window. Make a choice and click Next to proceed.

7. Give the macro a nickname and optionally assign an icon with the macro.

8. Click Finish and the macro is complete.

These are the basic steps of the Wizard. Depending on the wizard selected there
may be several additional steps, each of which is self explanatory. Each step has a
Cancel button to exit the Wizard at any time. Each step includes a Back button to
backtrack and make any changes needed.

The Wizards have been divided into categories based on their functionality. Each of
the links below lead to brief explanations of each of the wizards and some of the
types of macros that can be created. The Tutorial section includes an example of
creating a macro with the Wizard.



Text

Internet and Networking
Multimedia

System and Files

v Note: The Quick Wizards are handy for less complicated macros. If planning to use If / Then logic,
variables or other advanced features, the macro will need to be created with the Script Editor.



Edit Macro

There are several ways to edit an existing macro. In the Macro Express Pro -
Explorer window highlight the macro to be edited. Then take one of the following
steps:

Click on the Edit Macro icon ‘&'
Click on Macro > Edit Macro from the menu

Double click on the macro in the Explorer list

I A =

Right click on the macro and select Edit Macro from the context menu

The above action opens the Script Editor where changes may be made to the

macro script.



Copy Macro

Macro Express provides for a simple method to copy an existing macro. From the
Macro Express Pro - Explorer window highlight the macro to copy. Then do one of
the following:

1. Click on the Copy Macro button

2. Click on Macro > Copy Macro(s) from the menu.

3. Right mouse click on the macro and left click on the Copy Macro menu
item.

The Create New Macro window appears prompting to select a new macro activation
for the copied macro. Select the macro activation, change the macro nickname if
desired and click OK to save. The new macro is now displayed in the Macro
Explorer window.

If the macro nickname is not changed it will be displayed as "copy of" followed by
the name of the original macro.



Enable or Disable Macro

A disabled macro will not execute, but the definition is retained for potential future
use. This is helpful for those instances where a particular macro is not needed for a
time, but may be needed later. Instead of deleting it and re-creating the macro
later, simply disable it and then enable in the future.

Disable a macro

To temporarily disable a macro, highlight the macro from the list in the Macro
Express Pro - Explorer and do one of the following:

1. Click on Macro > Disable Macro from the menu

2. Right click on the macro and select Disable Macro from the context menu

Disabled macros appear in the Macro Explorer with italicized red text to distinguish
from active macros. A disabled macro will not function again until it has been
Enabled.

Enable a macro

To enable a disabled macro, highlight that macro in the Macro Express Pro -
Explorer window and do one of the following:

1. Click on Macro > Enable Macro from the menu

2. Right click on the macro and select Disable Macro from the context menu

Floating Menus

When closing a floating menu by clicking on the "X" in the upper right corner of the
menu window, the floating menu is disabled. To enable the menu highlight the
floating menu from the list of macros in the Macro Explorer and click on Macro >
Enable Macro.

Macro Disable and Macro Enable Commands

Also use the Macro Disable and Macro Enable commands in macros themselves to
enable and disable other macros in the macro file - such as Floating Menus or
Scheduled macros.




Recapture Macro

To overwrite the results of a previous captured macro, highlight the macro from
the Macro Express Pro - Explorer list and do one of the following:

1. Click on Macro > Recapture Macro from the menu.
2. Right click on the macro and select Recapture Macro from the context
menu.

Either action opens the Capture a Macro window to check the capture settings
before recording. Then click the Capture button to start the macro capture.

Stopping the Capture

To stop the capture take one of the following actions:

1. Press the system hot key Ctrl + Alt + Shift + X
2. Right click on the camera icon in the notification area
3. Press the hot key combination of the macro being recaptured

Recapturing removes the contents of the existing macro and replaces it with the
newly captured script.



Delete Macro

To remove a macro that is no longer needed, first highlight that macro from the list
in the Macro Express Pro - Explorer.

There are several ways to delete the highlighted macro.

1. Click on the Delete Macro button A

2. Click on Macro > Delete Macro(s) from the menu.
3. Press the Delete key on the keyboard.
4

. Right mouse click on the macro and left click on the Delete Macro menu item.

A dialog window opens to verify that the macro should be deleted. Select Yes to
confirm the deletion or No to cancel.

For mass deletions highlight a group of macros and delete them all at the same
time.

Deleted macros are sent to the Macro Express Recycle Bin. If necessary a deleted
macro can be restored to its original macro file. Or periodically empty all macros
from the Recycle Bin.

v Note: To bypass the Macro Recycle Bin highlight the macros to be deleted and press Shift + Delete.
This permanently deletes the macros without placing them in the Macro Recycle Bin.

Macro Delete Command

The Macro Delete command deletes other macros during macro playback. Insert
the command at the end of a macro script and the macro can delete itself upon
completion of the playback.

This feature is handy for use with one-time reminder messages. The macro runs at
its appointed schedule, displays the reminder and then is deleted upon completion.
The reminder macro doesn't need to remain in the Macro Explorer list after it has
run.



Run Macro Now

This option does what it's title implies. It runs the macro selected. There are
several ways to use this feature.

First Highlight the macro in the Macro Express Pro - Explorer window.

—
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1. Click on the icon.
2. Click on Macro > Run Macro Now from the menu.
3. Right click on the macro to open the context menu and left click on the

Run Macro Now menu item.

Of course, make sure that the macro to "Run Now" is appropriate for the window
currently open, etc.



Move to Category

Use this menu command to assign macros to categories already created. Highlight
the macro to be assigned and click on Macros > Move to Category to display a list
of categories such as in the example below. Highlight the category to move the
macro into and press the OK button. The macro is now assigned to the category
selected.

M

| Select a location for the macro:

M System Macros
v 3 WorkFile.mex
= Applications
= Examples
| = Samples
= Test Scripts
— * Unassigned *

OK Cancel |

The other method is to drag the macro from the Macro Express Pro - Explorer list
to the desired category. To drag the macro, highlight the macro, hold down the left
mouse button and move the pointer to the category listed in the Category column.
When the mouse is pointing to the correct category, release the left mouse button.
The macro is assighed to the category. Expand the category to view all macros
stored in that category.

With either of the above options, also highlight a block of macros and move them
all at once to the category of choice.

v Note: The categories selected are specific to the macro file that is currently open. When opening a
new macro file, the categories created for the new file are displayed. If more than one macro file is
open, multiple sets of categories are displayed, one set for each macro file.



Place on Desktop

Use this option to place an icon of any macro onto the desktop. In order to do this,
highlight the macro from the list of macros in the Macro Express Pro - Explorer.
Then click on Macros > Place on Desktop. The icon previously assigned to the
macro is displayed on the desktop.

Selecting a Desktop Icon

Change a macro's icon by double clicking on the macro from the list of macros in
the Macro Explorer to open the Script Editor. The icon in the example below, a red
number two, is displayed to the left of the macro nickname.

2 Macro Nickname: ‘k}enerate Random Numbers ‘

« Click on the icon to open the Select an Icon window.

« Click on the browse button to open a folder with a number of icon options.

« Or browse to another location on the hard drive where other icons may be
stored.

o« Choose the icon desired.

If an icon was not selected at the time the macro was created, the default Macro
Express icon is displayed.

v Note 1: When creating an icon on the desktop, the macro nickname also becomes the file name.
Windows does not accept the following characters in a file name: /\ : * < > | ? and *.

v" Note 2: To remove an icon from the desktop, right mouse click on the icon and select delete from
the menu that opens.



Macro Properties

This view of the Properties window may be accessed from the Macro Express Pro -
Explorer in a couple of ways.

1. Highlight the macro and then click on Macros > Properties from the

Macro Explorer menu

2. Right click on the macro and left click on Macro Properties from the
context menu.

M Macro Properties X

General Activations Scope Security Macro Logs

Macro Name

2 ‘Generate Random Numbers

Information
Last Modified:  2/28/2020 10:14:36 AM

[v] The macro is enabled

cace

The following information is available about the macro selected.

General

This Tab provides some basic information about the macro such as the last
modified date or scheduled time if a scheduled macro. Click on the check box to
change the status of the macro from Enabled to Disabled or vice versa. This panels
also allows editing of the Macro Name.



Activations
This tab displays what activation(s) are in use for the macro. The activation(s) may
be modified from this screen.

Scope

The Scope tab displays the macro scope and any programs or windows assigned if
using Program or Window Specific scopes. The selections may be modified from
this panel.

Security
The Security Tab allows for changes to the existing passwords assigned to the
macro or to add a password.

Logging

The Logging Tab displays any error logging that the macro is defined to use. The
logging options are set in Preferences > Playback > Miscellaneous and will log
errors or will log all commands in the macro, depending on the option selected.

The field in this tab is not editable. Click on the Clear Log button to remove all log
entries.



Macro Recycle Bin

The Macro Express Recycle Bin works similar to the Windows Recycle Bin. When a
macro is deleted from the Macro Express Pro - Explorer, the macro is removed
from the macro file that is currently open. The deleted macro is sent to the Macro
Express Recycle Bin and is displayed in the bin along with any other macros
previously deleted from the current file.

v Note: Highlight the macro or macros in the Macro Explorer window and press Shift + Delete to
permanently delete the macros and bypass the Macro Recycle Bin. This step permanently deletes
the macros with no chance for recovery.

Three options are available in the Recycle Bin - Restore Macros, Delete Macros or
Empty Recycle Bin.

Restore Macro(s)

The Restore Macros option returns a deleted macro from the recycle bin back to its
original file. The macro is again available for use in the Macro Express - Explorer.
This is a quick way to restore accidentally deleted macros.

To restore, highlight one or more macros in the Deleted Macro list. To highlight a
block of macros, click on the first macro to restore, hold down the Shift Key and
click on the last macro in the block. Click on the Restore Macro(s) option to place
the deleted macros back into the macro file from which they were deleted.

Delete Macro(s)

Delete Macros permanently removes the selected macros from the Recycle Bin with
no chance to retrieve later. To remove, highlight one or more macros in the
Deleted Macro list. To highlight a block of macros, click on the first macro to delete,
hold down the Shift Key and click on the last macro in the block. Click on the
Delete Macro(s) option to remove from the Recycle Bin.

Empty Recycle Bin
Click on the Empty Recycle Bin option to remove all macros from the Recycle Bin.
These macros cannot be retrieved once they are removed from the Recycle Bin.



Category

Using Categories

Use this option to assign macros to categories. For example create a Password
category to hold any macros containing important passwords or assign any MS
Word specific macros to a MS Word category. The categories provide a simple way
to find macros after they have been created. A macro may only be assigned to one
category.

When the program is first installed, there are two default categories - All
Categories and Unassigned which may not be changed. But new categories may be
added, renamed or deleted.

« All Categories displays all of the macros in the file.
« The Unassigned category displays all macros not assigned to a sub-category

of All Categories.

The category icons may be turned on or off via the Macro Express Pro - Explorer
menu Options > Preferences > Appearance > Explorer tab.

New Category

Select this menu option to add a new category. A new category folder and edit box
appears in the category list. Type in the name to assign the category. Also create
sub-categories within the category list. To do this, right click on the main folder
and then left click on New Category. A new category sub-folder is added to the list.



M Create New Category — O X

Name:

|Sales

Select where to place category:

M Systemn Macros
v [ macex.mex
= Applications
= Email
= Examples
3 Test Scripts
2 * Unassigned *
& samples.mex
= Customer Support.mex
= gpg.mex
= WorkFile.mex

coe

Rename Category

To change the name of a category already created, highlight the category and click
on the Category > Rename Category menu option. The category name is
highlighted so that a new name may be inserted, similar to the way Windows
Explorer works.

Enable/Disable Category

This option disables or enables all of the macros in the category selected. If the
category contains both enabled and disabled macros, then the status is toggled.
The enabled macros are now disabled and the disabled macros in the category are
enabled.

Delete Category

Highlight the name of the category to remove. Then click on Category > Delete
Category. A warning message appears verifying that the deletion should continue.
Click Yes to delete the category and all of it's sub-categories.

Placing Macros in Categories



Once a category is created, there are two methods for moving macros into a
category.

Highlight the macro to be assigned and click on Macros > Move to Category to
display a list of categories such as in the example below. Choose the category to

move the macro into and press the OK button. The macro is now assigned to the
category selected.

&7 Move to Category — ] X

Select a location for the macro:

System Macros
v [ macex.mex
= Examples
[ Help
[ Tutorials
= Work
[ * Unassigned *

coc

The other method is to drag the macro from the Macro Explorer list to the desired
category. To drag the macro, highlight the macro, hold down the left mouse button
and move the pointer to the category listed in the Category column. When the
mouse is pointing to the correct category, release the left mouse button. The

macro is assigned to the category. Expand the category to view all macros stored
in that category.

Using either of the above methods, highlight a block of macros and move them all
at once to the category of choice.

v Note: The categories selected are specific to the macro file that is currently open. When opening a
new macro file, the categories created for the new file are displayed. If more than one macro file is
open, multiple sets of categories are displayed, one set for each macro file.



Set/Clear Password(s)

This menu option provides password protection to a category of macros. Select
whether to prevent users from running, editing or viewing macros in the selected
category. Selecting All Categories effectively password protects the entire macro
(.mex) file. The Lock icon indicates that a password is currently in place.

Password to Run macro
password set

&

]

Password to Edit macro
password set

Password to View macro
password not set

o s

Run Password

None of the macros in the password protected category will run without first typing
the password. When a macro is activated, a prompt appears requesting the
password be input. Once the password is successfully entered, the macro starts
running.

Edit Password

The macros in the password protected category are displayed, but may not be
edited without first typing the password.

View Password

None of the macros in the password protected category are displayed without first
typing the password. Once the password is successfully input, the macros in the
category may be viewed, edited, saved or deleted. Once another category is
opened, the password must be typed again to reenter the password protected



category.

Create a New Password

To create a password for the first time select the Run, Edit or View option and click
on the Change button. Leave the Original Password field empty and enter the
password in the New Password field. Confirm the password in the Confirm
Password field and save.

Change an Existing Password

To change an existing password select the Run, Edit or View option and click on the
Change button. Enter the current password in the Existing Password field. Insert
the new password in the New Password field. Confirm the password in the Confirm
Password field and save.

v" Note: Leave the New Password and Confirm Password fields blank if removing a password from the
category.



Search

Find

Use the Find feature to search through the list of macros in the Macro Express Pro
- Explorer window. It performs the search beginning with the macro highlighted
and continues through the rest of the list. Pressing CTRL + F or clicking on Search
> Find will open the Find window.

M Find «
Find what: ‘decrease y ‘ | Find Next |
Search in: | Nickname v Cancel

Match case

Find what:

Enter the details of the search (what is to be found) in this field.

Search in:

Perform the search on the Nickname, Activations, Scope or Modified columns in the
Macro Explorer window. Select which column to search through.

After entering the search criteria press the Find Next button. If a match is found,
the macro that matches is highlighted. If no match is found, a message "Reached
the end of the list" is displayed.

Match case

This option makes the search case sensitive. Capital and lower case letters need to
match exactly in order to find the right match.

Find Again

If the first match is not the macro being sought, press F3 or click on Search > Find



Again to go to the next match.



Options
Preferences

Activations

General Activation

Preferences

General Scheduler Shortkeys
Appearance
Email Hooks

File System [v] Auto restore the keyboard and mouse hooks

General [ ]Use the clipboard hook
Playback

Startup

Reset Page Apply Cancel

Macro Express Explorer > Options > Preferences > Activation > General Tab

Auto restore the keyboard and mouse hooks

This feature automatically attempts to have Macro Express re-assert itself as the
first program to take a look at the keystrokes passed through the Windows system

wide keyboard hooks even if other programs are loaded that also use these
keyboard hooks.



Typically this is not a problem unless a program is run *after* Macro Express and it
uses the keyboard hooks and it places itself there in an improper fashion. When
this occurs, keystrokes are no longer passed onto Macro Express and the Macro
Express Hot Keys and Shortkeys suddenly fail to trigger macros.

This feature should automatically give Macro Express first looks at the keystrokes
thus preserving the use of Macro Express Hot Keys and Shortkeys. In addition,
because Macro Express properly passes on keystrokes through the chain of
keyboard hooks, other programs will still function correctly.

The above also applies to the Windows mouse hooks.

Use the clipboard hook

This option turns on or off the ability to run clipboard activated macros. Select this
option to allow clipboard activated macros to run. If conflicts arise with other
programs using the clipboard, turn off this option.




Scheduler

Preferences K
[T General Scheduler Stortkeys
Appearance i} i}
Email Notification
File System Play a sound when a scheduled macro runs
General ‘DeviceDisconnect vl
Playback . .
aybac [v] Wait for the sound file to finish
Startup
Timer Interval
Check the scheduled macros every seconds
Other
[ ]Disable the screensaver when there are scheduled macros
Reset Page Apply Cancel
Notification

Select this option to play a sound (.wav) file when a scheduled macro is about to
execute. The sound file will not play back when using the When the program starts
and When the macro file is loaded schedule options. The default option is to not
play any sound.

Sound File

Enter the file name and path of the sound file into the edit field. Or click on the
Browse button to locate the sound file. You may also select one of the system
sounds available on your computer by clicking on the drop down arrow. Click on
the Test button to hear the sound selected.

A system sound is a sound assigned to specific Program Events within Windows



such as Asterisk, Device Connect or Windows Logoff. The sounds assigned to these
events are selected in the Windows Control Panel either individually or as part of a
theme. Not all system sounds listed in the Control Panel are available in this
command.

Wait for the sound file to finish

Placing a check in the box causes the playback of the macro to stop until the
sound file has finished playing. The macro resumes playback once the sound file
has finished.

Check the scheduled macros every __ seconds

Specify the interval, in seconds, for how often Macro Express checks to see if a
scheduled macro is ready to execute. Macro Express will shut off the timer if no
scheduled macros exist in the current file or none are active. The default setting is
to check for scheduled macros every 10 seconds.

Suppose a scheduled macro plays back every 3 seconds. For the macro to work
correctly, the Timer Interval needs to be set to check at least every 3 seconds.
Otherwise some of the scheduled times will not run.

Disable the screensaver when there are scheduled macros
Screen Savers prevent a scheduled macro from running. This option prevents a
screen saver from starting if Macro Express is running and if there are any active
scheduled macros in the macro file currently in use. It stops the screen saver from
starting, allowing the macro to run.




Shortkeys

Preferences X
General Scheduler Shortkeys
Appearance
Email Prefixes and Suffixes
File System (O Use prefix keys (® Use suffix keys
General ## [ 1Use punctuation characters ‘'), —-:/71"
Playback : Solitary usage Retype the suffix key
Startup )
Solitary usage separator characters ‘“* (1{}[:
Case Sensitivity
(O Match first character's case between shortkey and replacement text
If the first letter in the text is uppercase, don't change it to lowercase
(O Require exact uppercase/lowercase match on shortkey
(® No case sensitivity
Other
] Do not remove keystrokes typed
Reset Page Apply Cancel

A shortkey is a set of characters such as abc, myname, etc. The macro runs when
the characters are typed into an application. Click on Options > Preferences >
Activations and the Shortkeys tab to define the settings. Below are descriptions of
the default settings that can be assigned to all shortkeys.

Prefixes and Suffixes

The Prefix Key and Suffix Key options cannot be overridden elsewhere in the
program.

Use Prefix Keys
The Prefix Keys are used to designate up to three characters that may be added to



the beginning of every shortkey. A prefix key is a method to prevent the accidental
triggering of a macro during everyday typing.

This option places a prefix key or keys, such as z, ##, qq, etc., in front of each
shortkey. So, if the Prefix Key was set to ## and the shortkey was set to "test",
typing # #test starts the macro. Typing ## before any text would make it very
unlikely for a macro to start accidentally.

The other option is to leave the Prefix Keys field blank. In the above example,
typing the shortkey "test" would start the macro. No other keys are required.

Below is a list of the Prefix characters that are recognized by Macro Express.

o The letters A through Z (both upper and lower case)

o The numbers 0 through 9

o The followingcharacters: ' @ # $ % N & _ =< > 7?2 .,; , * -/ +
" " ) ]and space bar

Shortkey Detection
The program provides two methods of "shortkey" detection, Solitary Usage and
non Solitary Usage. Solitary usage is the default setting.

Solitary Usage

The solitary usage option indicates that a shortkey is recognized only when
the shortkey is preceded by a character or key that is not valid as part of the
shortkey name. This is best illustrated by the example below.

Assume the shortkey was named red and the macro text was a bright color.
The replacement would not take place if the word Fred were typed. Why?
Because "F" is a valid character in a short key name. We really didn't want
the replacement to take place because we were typing Fred and not red.

However, the replacement would take place if typing the word red preceded
by a blank space. Why? Because a blank space is not valid as part of a
shortkey.

Non Solitary Usage

The non solitary usage option (leaving the Solitary Usage option unchecked)
indicates that a shortkey will be recognized whenever the short key text is
typed, even if it is part of another word. The following example illustrates this
point.

Assume the shortkey was named red and the macro text was a bright color.
Typing the word Fred would cause the macro to start and the text typed



would be Fa bright color.

Typically the "non solitary usage" mode is used with a single prefix key or
two to ensure that a macro does not play back unintentionally.

Solitary Usage Separator Characters
One or two Prefix Keys may optionally be input that are applied to all original
shortkeys created. The following Prefix characters may be entered and used:

o The letters A through Z (both upper and lower case)

o The numbers 0 through 9

o Others: Essentially any other valid character or symbol suchas! @ # $ % N
d_=<>?2.;,*-/+\.

This list of Separator Characters provides a method to remove characters for
use as a prefix key. Attempting to assign an invalid character as a prefix would
not be allowed.

Use Suffix Keys

Another alternative is to use the Suffix Keys option. With this option activated,
type the shortkey and then press down either the Space Bar or the Enter Key to
activate the macro.

Use Punctuation Characters

Punctuation keyssuchas ., :;?!)']" " and - may also be used as a suffix
key for a shortkey when the Include Punctuation Characters box is selected. If
the shortkey was set to test, type the word test while in another Windows
application and press either the Space Bar, Enter Key or one of the punctuation
keys listed above to start the macro. Punctuation characters may be added or
removed from this list.

Retype Suffix Key

The Retype Suffix Key option, when checked, types the suffix key (Enter, Space
or punctuation keys) to the end of the macro text. This option is mainly for
those who use shortkeys as a simple text replacement in writing documents.

Assume a shortkey of test with a replacement text of This is a test. Typing the
word test into notepad or other text editor and using the space bar as the
trigger causes the macro to start. The replacement text is typed into the
application and the cursor moves one space to the right of the text.

Or typing test and using the ? to activate the shortkey causes the replacement
text to appear with a ? at the end of the text. If the Replay Suffix key is not
selected, the suffix key is not placed at the end of the replacement text.



Complete list of characters that can be used
with shortkeys

Up to 32 characters may be entered as an original short key
(which are to be replaced). In addition, up to 3 Prefix Keys
may optionally be entered in that are applied to all Original
Shortkeys created. The following Prefix characters may be
entered and used:

The letters A through Z (both upper and lower case)

The numbers 0 through 9

The foIIowmg characters: ! @ # $ % N & _ = < > ?
;o , ¥ -/ + 7 " ") ]and space bar

If not using a prefix key, use the suffix key and press the
space bar, the enter key or a suffix characterof ., : ; ? ! or -
after typing the shortkey to activate the macro.

v Note: Pressing down the CTRL or ALT key is detected by the program when using the Shortkeys

option and is interpreted as a key being pressed. Therefore, if the ALT or CTRL key is pressed in the

middle of a shortkey being typed, the shortkey will not be recognized and the macro will not start.

Case Sensitivity
The following options are the default options used for each new shortkey created.
These options can be overridden on an individual shortkey basis.

Match First Character's Case Between Shortkey & Replacement

Text

This option causes the upper case setting of the first letter in the shortkey to
dictate that the first character in the macro will be upper case (if the first thing
in the macro is a character). This option is mainly for those doing simple text
replacement in documents and facilitates an easy way to capitalize the
replacement text in instances where it needs to be, such as at the beginning of
a sentence.

Require Exact Upper Case/Lower Case Match on Shortkey

With this setting selected, the shortkey must be typed exactly as it appears
(upper and lower case letters) in order for the replacement to work.



No Case Sensitivity
Neither of the above cases apply with this option checked.

Other

Do Not Remove Keystrokes Typed

This option instructs the shortkey to not erase itself after being typed. Normally,
backspaces are issued to remove the shortkey from the screen before the macro is
executed.

When using shortkeys in non-text usage programs, it may not be desirable to have
"backspaces" issued. For example, using a shortkey in Internet Explorer where
focus is not on an edit box, will cause the "back" button to be pressed nhumerous
times due to the backspaces being issued. The Do Not Remove Keystrokes Typed
option will prevent this from happening.



Appearance

General Appearance

Preferences X
Activations General Explorer Script Editor Mouse Locator
X Other
Email
File System Show large icons in toolbars
General Theme: |Flat B2
Playback
Startup Font
Menu Font: AaBbCcDd 12345 Change

Reset Page Apply Cancel

Macro Express Explorer > Options > Preferences > Appearance > General Tab

Other

Show large icons in toolbars

Use this option to display the larger icons in the Macro Express - Explorer toolbar.
If this option is turned off, the smaller icons will be displayed. The Macro Express -
Explorer must be restarted before the change takes effect.
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Theme

Choose a theme from the drop down list to change the look of the Explorer
window. Choose from Blue Gradient, Retro, Flat, Standard or Custom options.

The Custom theme allows the user to select colors for various window
components, choose from several menu styles and choose the button alignment
and spacing in the program's windows and dialogs.

Font

Menu Font

Change the font type and style of the menus in the Macro Express Explorer, Script
Editor and Menu Builder windows.



Explorer

Preferences
Activations General Explorer Script Editor Mouse Locator
. Toolbars
Email
File System Show Toolbar
General Show Sidebar
Playback Macro Categories
Startup

Show macro category icons
Show large macro category icons
Show macro file names only

Macro List

Show Icon Show Modified date/time

[ ]show Index Show Category

Show Nickname Show Last Run Time

Show Activation []Show gridlines

Show Activation details Color every other line

Show Scope Draw a line through disabled macros

Other

Show Activation Pane
[]show full path in the Reopen list

Fonts
Grid Font: AaBbCcDd 12345 Change
Category Font: AaBbCcDd 12345 Change

Reset Page Apply Cancel

Macro Express Explorer > Options > Preferences > Appearance > Explorer Tab

Use these options to adjust the look of the Macro Express Pro - Explorer window.

Toolbars

Show Toolbar

Select to display the toolbar (similar to what is shown below). The toolbar is not
displayed in the Macro Explorer window when the option is not selected.
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Or if the Show large icons in toolbars option is turned off, the smaller icons will be



displayed.

Sidebar

Choose to display the sidebar (similar to what is shown below). The sidebar is not
displayed in the Macro Explorer window when the option is not selected. If the
large icon option has been selected, then the Sidebar option is not available.

Macro Explorer

b

Hew Macro

Edit: Macro

el

Capture

Quick Wizards
.|

Recycle Bin

Show macro category icons
This option displays folder icons next to each category in the Category field of the
Macro Explorer.

Show large macro category icons
Choose to show a larger size folder icon in the Category field.

Show macro file names only

Choose to display just the name of the macro file, rather than showing All
Categories with the macro file name in parentheses.




Macro List

Below is a chart containing the options to display in the Macro Express Explorer

window.

Display Description

Options

Show Icon Displays icons next to each macro listed in the Macro Express
has not been assigned to the macro, the default Macro Expres

Show Index Each macro is assigned an index number. Display the index nt

Show Nickname

Display the nickname assigned to each macro created.

Show Activation

Show the activation (hot key, shortkey, etc.) that is assigned

Show Activation
Details

Show additional details about the activation displayed, such as
in use. If a macro has more than one activation assigned, eacl
rather than showing "Multiple" in the Activations column.

Show Scope Display the scope that is assigned to each macro.
Show Modified Display the date and time that the macros were last modified
date/time

Show Category

Show the name of the category (if any) that the macro is assi

Show Last Run
Time

Show the date and time that the macro was last run.

Show gridlines

Show grid lines between each macro listed in the Macro Expre

Show preview
pane

Display a panel at the bottom of the Macro Explorer window p
details about the highlighted macro.

disabled macros

Color every Show every other macro in the Macro Express - Explorer list v
other line background. This helps to read across the line easier.

Draw a line This option draws a line through any disabled macros displaye
through - Explorer window to make it more readily apparent that the r

All disabled macros are displayed with italicized red font.

Other

Show full path in the Reopen list



In the Macro Express Pro - Explorer window click on File > Reopen to view a list of
the most recently used macro (.mex) files. By default the list only displays the file

name. Select this option to show the file name and the path where the file is saved
on the computer.

Fonts

Grid Font

Change the font type, style, size and color of the text displayed in the Macro
Express Explorer grid.

Category Font
Change the font type, style, size and color of the text displayed in the Macro
Express Explorer categories column.



Script Editor

Preferences
Activations General Explorer Script Editor Mouse Locator
; Font
Email
File System Script Font: AaBbCcDd 12345 Change
General
Playback Direct Editor Font: |AaBbCcDd 12345 Change
Startup
Other
Display command category icons
Reset Page Apply Cancel

Macro Express Explorer > Options > Preferences > Appearance > Explorer Tab

Script Font

Use this option to select the font type, color, size, etc. to display in the Script
Editor.

Direct Editor Font

Use this option to select the font type, color, size, etc. to display in the Direct
Editor.

Display command category icons
Each group of macro commands in the Script Editor, such as CD-ROM, Logic, etc.,



has a distinct icon associated with it. Each time a command from that group is used
and added to the macro script, the associated icon is also displayed in the script.

If not selected, the icons are not displayed in the category list or next to each
command in the macro script.



Mouse Locator Settings

Preferences X
Activations General Explorer Script Editor Mouse Locator
I
Email Display Pixel Color
File System Display Pixel Color as integer
General Display Pixel Color as hexadecimal in BGR format
Playback Display Pixel Color in separate RGB values
Startup Display Pixel Color as hexadecimal in RGB format

Copy to Clipboard
Copy Screen Position
Copy Pixel Color as integer
Copy Pixel Color as hexadecimal in BGR format
Copy Pixel Color in separate RGB values
Copy Pixel Color as hexadecimal in RGB format

If it is running, restart the Mouse Locator for changes to take effect.

Reset Page Apply Cancel

Style

The Translucent style is the default for the Mouse Locator. However, depending on
what is displayed underneath the Mouse Locator it may be difficult to read the
values for the mouse position and colors. Turn off the Translucent style if you
experience difficulties reading the text.

v' The Translucent Style is only available in Windows 7 and prior.

Display Pixel Color
To display colors, computers use the RGB Additive Color System. The letters R, G
and B represent Red, Green and Blue respectively. Separate values are used for



the amount of Red, Green and Blue. On a Windows computer, each color ranges
from O, all the way off, up to 255 (or FF hexadecimal) all the way on. Combining
different values for each basic color allows millions of different colors to be
displayed. For example, White has a value of 000000, Green has a value of O0OFF00
and black has a value of FFFFFF.

The hexadecimal number that represents a color can also be represented as an
integer value. For example, one orange color has a hexadecimal value of 2D42D4.
When displayed as an integer this value is 2966228. The Get Pixel command
returns the integer value of the color for a given pixel. This allows the integer
variable commands to test for specific colors in your macros.

The Mouse Locator displays colors in a variety of formats to make it convenient to
enter colors into other programs. For example, the Get Pixel Color uses an integer
color value. When entering a color for a web page the color value is in hexadecimal
RGB format. To enter a color in Word requires separate integer values for Red,
Green and Blue. And some programming languages require a hexadecimal BGR
(Blue, Green, Red) format.

The Display Pixel Color options allow you to choose which Pixel Color values to
display on the Mouse Locator.

Copy to Clipboard

You can use the Mouse Locator to get the value of a color on your computer
monitor. Make sure the Mouse Locator is the active window, then move your
mouse over the color you want and press Ctrl + c. The color will be copied to the
clipboard so you can paste it into another program.

By default, several values are copied to the clipboard including the Screen Position
of the mouse and the Pixel Color in a variety of formats. Here is an example:

990,385,2966228,2D42D4,212,66,45, #D4422D

The Copy to Clipboard options allow you to choose which values to include when
copying to the clipboard.



Email

General Email Settings

Preferences K

Activations General MAPI Settings Address Book
Appearance

Fmail Settings

File System Use MAPI to send email (requires a MAPI-compliant email client)
General Keep a log of all messages sent

Playback
Startup

Reset Page Apply Cancel

Use MAPI to send Email

Select this option to send messages through the default email program rather than
using the Macro Express email client. Macro Express will only be able to send email
using the default email client if it is compatible with the Messaging Application
Programming Interface (MAPI). Mainstream email programs such as Outlook,
Eudora, Thunderbird, etc. are compatible.

If using this option, the SMTP Settings tab changes to a MAPI Settings tab so the
options can be set.




Keep a Log of All Messages Sent

This option logs all email messages sent through Macro Express to an email log file.
From the Macro Explorer window click on Tools > Sent Email Log to review the
mails sent via Macro Express.




SMTP Settings

To successfully use the email commands via SMTP, the default email settings need
to be entered into the SMTP settings panel. Click on Options > Preferences > Email
to enable the email functions of Macro Express.

Preferences K
Activations General SMTP Settings Address Book
Appearance R
: Server Settings
File System Host: |relay.emai|.com
General Port: (Typically 25)
Playback
Startup Authentication

The SMTP server requires authentication

Username: |Insight |

Password: \ooooooooo \o

Email Address

Your name: |Insight Software Solutions |

Address: |info@wintools.com |

Reset Page Apply Cancel

Server Settings

The SMTP Server is what allows email to be sent over the Internet. The server
settings may be obtained from the Internet Email provider or from the
configuration section of the default email program on the computer.

Host - The "Host" value may appear as a series of numbers and periods such
as 192.168.0.1 or as a set of characters looking something like a web site name



such as mail.myisp.com.

Port - The port number is almost always 25. When in doubt, set this value to
25.

Authentication

The SMTP Server Requires Authentication

The email provider may require use of SMTP Server Authentication. If so, select
this option and insert the user name and password in the appropriate fields. If
authentication is not required, then leave this option unchecked.

Email Address

This is the name and email address that display in the return address of any email
sent through Macro Express. Please note that if the email address entered is
incorrect, the recipients of the email may not know how to reply to the message.



MAPI Settings

Preferences

s: Address Book

Activations General
Appearance

. Authentication

File System Profile name: |Insight Software Solutions, Inc. |

General Password: \oooooooooo \
Playback

Startup

Reset Page Apply Cancel

This option is only available if MAPI is selected in the Email > General tab.
The MAPI information - Profile Name and Password - is only required if using

multiple email profiles. Enter the email Profile to use with Macro Express and the
password.

If not using multiple email profiles then this information should be left blank.



Address Book

The Address Book is a list of names and email addresses to choose from when
creating email macros. Use this function to add names, make changes to existing
names or delete names from the list. Click on Options > Preferences > Email to
access this option. The Email Send command also has an option for editing the list
of email recipients.

Preferences X
Activations General SMTP Settings Address Book
Appearance Alice alice@myisp.com
Bil bill@myisp.com
File System Jason jason@yoohoohoo.com
General Jill jill@myemail.com
Joe joe@mywebsite.com
Playback Sally sally@mywebpage.com
Startup Steve steve@myfavoritesite.com
Add Modify Remove
Reset Page Apply Cancel

Click on the Add button to open the Email Recipient Maintenance window shown
below. The two fields will be blank. Just enter the person's name and email address
and click OK to add that person to the list.



H Email Address X

Name: ‘[nsight Software Solutions, Inc. ‘

Address: ‘hnfo@wintools.com ‘

Cance

Modify

If the email address has changed for someone on the list or other information
needs to be changed, highlight that person's name from the list and click on the
Modify button. The name and email address are displayed in the Email Address
window as shown above. Edit this information and click OK to save the changes.

Remove
To remove a person from the email recipient list, highlight that person's name and
click on the Remove button. The name will be removed from the list.



File System

File Paths

Use this option to set the default file locations for a number of files used by Macro
Express. Descriptions of the files are provided below.

Preferences
Activations File Paths Network Macro File
Appearance R
Email File Paths
Email Address Book
File System
p | |C:\Users\James\OneDrive\Documents\Insight Software\Address Book.txt | .| |EF
enera
Playback Sent Email Log
Startup |C:'\Users'\James'\OneDrive\Documents'\Insight Software\Macro Express 6\EmailLog.dat | | |
Default Macro Log folder
|C:'\Users'\James'\OneDrive\Documents'\Insight Software\Macro Express 6\Macro Logs\ | | |
Crash Report folder
|C:'\Users'\Puinc'\Documents\[nsight Software\Macro Express 6\Crashes\ | | |
Temporary Capture file
|C:'\Users'\James'\OneDrive\Documents'\Insight Software\Macro Express 6\Quick Capture.txt | | |
External Scripts Temporary folder
|C:'\Users'\James\AppData\Local\Temp\ | | |
Favorites file
|C:'\Users'\James'\OneDrive\Documents'\Insight Software\Macro Express 6\Favorites.txt | E =)
Snippets file
|C:'\Users'\James'\OneDrive\Documents'\Insight Software\Macro Express 6\CodeSnippets.txt | | |
Reset Page OK Apply Cancel

Macro Express Explorer > Options > Preferences > File System > File Paths

Email Address Book

This specifies the path and name of the file that holds any email addresses to be
stored. This option is provided so that network users can each have their own
individual list of email addresses. If email addresses are common to all users,
simply point each user to the same file.




Sent Email Log

The Sent Email Log field displays the path and name of the file that logs the mails
sent via Macro Express. The email information will only be saved to this file if the
Email Logging option has been set. Start a new log file at any time by changing the
file name.

Default Macro Log folder

This specifies the path and name of the file that holds the error logs created when
using the Log Errors command. Start a new log file anytime by changing the file
name. This option is provided so that network users can each have their own
individual list of error messages. If error messages are common to all users, simply
point each user to the same file.

Crash Report folder

This specifies the path and folder where crash reports are saved. Crash reports are
generated by an unexpected closing of the program. The details of the problem are
saved to a file that begins with 'error' and ends with ".TX" in the folder specified
here. The default path is the folder where the Macro Express program is installed.

Temporary Capture File
Use the System Macro - Ctrl + Alt + Shift + B to capture a temporary macro. The
temporary macro is stored in the file located in the path defined in this field.

External Scripts Temporary folder

Macro Express allows for the creation of External Scripts in JScript, VBScript or
HTA/HTML. When the macro plays back the contents of an External Script, the
script is copied from the macro and temporarily saved to a file in the folder location
selected. The macro reads the contents of the file and plays them back. When the
macro is finished the temporary file is deleted.

Favorites File

Instead of displaying all of the commands available in the Script Editor, Macro
Express includes an option to create a favorites list, making it easier to find the
most frequently used commands. From the Script Editor menu click on Options >
Customize Favorites to assign the favorites. The information is stored in the file
listed in this file path.



Snippets File

Use the Code Snippets function to create snippets of a macro script, such as
routines for use in multiple macros. Save the code snippet to later insert into a
macro at any time. Select Code Snippets from the drop down list as shown below
to view, create or insert snippets. The code snippet information is stored in this file
path.

Click on the Open button to open the folder and view the contents associated with
the file path selected.



Network

Preferences X
Activations File Paths Network Macro File
Appearance R R
Email Macro File Networking
File System Lock the macro(s) currently being edited
General Synchronize the macro file
Playback Sync every minutes
Startup
Reset Page Apply Cancel

Macro File Networking
Macro Express can be set to run over a network using the options described below.

Lock the Macro(s) Currently Being Edited

This option prevents two or more users from editing a macro at the same time by
locking the macro as it is being edited. If this option is disabled the lock is neither
set nor checked when a macro is edited. If the Lock the Macro(s) Currently Being
Edited option is disabled and two or more users edit a macro at the same time, the
macro may become corrupted. We recommend leaving this option enabled.

Synchronize the Macro File
This option is available to allow automatic synchronization of data files between



users on a network. This updating can be set to occur every minute, every two
minutes on up to every 999 minutes.

For example, if the interval is set to 5 minutes and another user makes a change
to the same macro file currently open, then within 5 minutes the macro data will
automatically be synchronized between the networked computers.

When running Macro Express over a network there are options to prevent certain
users from changing any of the Macro Express data. This may be accomplished via
the Command Line Parameters.

Sync Every ____ Minutes
Enter the time interval in minutes of the synchronization schedule.

v Note: Multi-user networking of this product requires the purchase of a multi-user license.



Read Only Prompt

This preference setting refers to Macro Express (.mex) files that have been set to a
Read Only status. It may refer to opening a file through the File > Open File menu,
loading a macro file during playback of a macro, or other times the .mex file is
being accessed.

v Note: If using the command and the file to be loaded is a Read Only file, then
the Default Action selected in this Preference panel will be used.

Preferences b4
Activations File Paths Network Macro File
Appearance )
Email Read Only
File System Prompt about read-only status on macro files
General Default Action:
Playback (O Leave the file as is
Startup (® Turn off the read-only flag

(O Abort the operation

Reset Page Apply Cancel

Prompt about read-only status on macro files

Select this option to have the program prompt for action when a read only .mex
macro file is encountered. The following dialog opens allowing the user to select a
course of action.



M File is Marked as Read-Only — ] X
The following file is currently marked as read-only.

D:\Macros\Adjusted macro.mex
What would you like to do?

() Leave the file as is

(® Turn off the read-only flag

O Select a new file

() Abort the operation

[ ] Don't show me this again

cace

Default Action
If the Prompt option is not selected, then choose from one of the three default
options discussed below. The action selected will occur each time a read only .mex

macro file is encountered.

Leave the file as is
The read only status will be left as is. Macro Express will attempt to perform the

requested action with the read only file.

Turn off the read-only flag
The read only status of the macro file is turned off, which will allow for editing of

the macro file, etc.

Abort the operation
The function that Macro Express is attempting to do with the file will be aborted.



General

Backup

Use this option to create automatic backups of the macro data file currently in use.
This option allows for selecting the frequency of the backups, the number of
backups to store and where to save the backup files.

Preferences X
Activations Backup Capture Dialogs Notification Area Misc
Appearance
) Schedule
Email
File System [ ]Backup when program starts
[ ]Backup when program closes
Playback Backup when an editor closes
Startup [ IBackup every 1 Program start 12:00:00 PM =
Options

Display message while backing up

Keep backups

Backup Location

Backup to a specific path w

Backup path: |C:\Users\George\Documents\Insight Software\Macros\Backups | |

Reset Page Apply Cancel

v Note: Automatic backups will only occur after the macro (.mex) file has been modified. In the
example from the image above, if the file has not been modified, then starting the program or
closing the editor will not trigger a backup. Only if the file as been modified, does the automatic
backup occur. The date/time stamp of the backup file will match the date/time when the original
(.mex) macro file was last modified.

v' Disabling, enabling and deleting macros, as well as creating new or editing existing macros, are
considered modifications to the file and will initiate a backup.



Schedule

Determine the frequency of backups.

Backup when program starts
A backup of the data is created when the Macro Express Player is started.

Backup when program closes
This creates a backup of the data every time that the Macro Express Player is
closed.

Backup when an editor closes

A data backup file is created each time one of the Macro Express editor windows
closes. This includes the Script Editor, the Menu Builder, the Quick Wizard and
the Macro Express - Explorer window.

Backup Every _ Day at
This options provides flexibility for creating a backup schedule. Select the
number of days between backups. If the number 2 is entered, then a backup
will run every two days. Choose to have the backups run when the program
starts, closes or select a specific time of the day.

No Backup

To not schedule any backups, leave the four options unchecked. Manually back
up the macro file by opening the Macro Express - Explorer window and clicking
on File > Backup. See the Backing Up Macros topic for more information on this.

Options
Choose to display a message notifying of a backup and decide how many backup
files to keep.

Display message while backing up

Choose this option to display a message on screen when the backup occurs. If
the file is small, this may happen almost instantaneously, so that the display
message may not be visible. If the backups are scheduled intermittently, then
this may serve as a reminder that a backup is in progress.

Keep __ Backups



Specify the number of backup copies to store on the computer. The default
number of backup files is 10.

Backup Location
Specify the location of the backup files from the drop down list. Select the number
of backup copies to keep.

Backup to the Same Folder as the Macro File
The backup file is created and saved into the same folder where the original
macro file is currently located.

Backup to a Specific Path
Use this option to store the backups in a folder other than the one where the
original file is located.

Backup Path

If using the Backup to a Specific Path option, click on the Browse button to
select the location where the backup file will be stored. Or type in the full file
path in the edit field.

Click on the Folder button to open the folder containing the backup files.

v Note: To manually back up the macro file at any time, open the Macro Express Explorer window
and click on File > Backup.
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Macro Express records macros by capturing mouse and keystrokes and saving this
information for later playback as a macro.

Before starting the first recording, click on Options > Preferences > General -
Capture tab from the Macro Express Pro - Explorer window to define the capture
settings as explained below.

Start the capture

There are two methods for starting a macro recording.

1. Click on the Capture icon or Macro > Capture Macro from the menu



-- This method prompts to assign the macro activation before the recording.

2. Press the System Hot Key of Ctrl + Alt + Shift + X
-- This method prompts to assign the macro activation after the recording.

Stop the capture
There are three ways to stop the recording, depending on which method chosen to
start the capture.

1. Press the System Hot Key of Ctrl + Alt + Shift + X
2. If using the Capture icon press the hot key assigned to the macro
3. Right click on the Camera icon in the Notification Area that displays

while recording

Default Scope

The Global scope allows for the playback of the macro into any Windows program.
The Program/Window scope indicates that the recorded macro will only start in the
program or window selected. Or allow the macro to play back in all programs
except the ones defined.

Capture Keystrokes
Select this option to record all keystrokes made during the capture process.

Capture Alt Up and Down for Menus
Some window menus do not always respond to a single press of the Alt key in a
macro. This option records the Alt key twice to help ensure proper activation of

the menu.

For example, to open the File menu in an application, press Alt + f during the
capture. The macro script displays <ALT><ALT>f, even though the Alt key was

only pressed once during the capture.

Capture Mouse Relative To
A check placed in this option records all mouse clicks and movements made during
the capture process. There are several mouse options to choose from.



Relative to Screen - This option captures all mouse clicks and movements in
relation to the cursor's position on the monitor.

Relative to Window - This option captures all mouse clicks and movements
in relation to the application window that is open and has focus.

Capture Window Size is only available if the Relative to Window option is
selected.

This option remembers the size of the window in which the capture occurs.
When the macro plays back, the window is resized, if necessary, to the
original size when the recording was made. This helps ensure that the mouse
clicks and movements are accurate.

Relative to Last Position - This option captures the mouse clicks or
movements based on the last position of the mouse cursor.

Capture Only the Mouse Clicks

Select this option to only capture the mouse clicks, including the position of the
mouse click. This option captures the position where the mouse is to click and also
the mouse click itself. No other movements of the mouse are recorded.

Unless drawing or recording the mouse dragging an item, it is best to turn on this
option. It reduces the size of the macro considerably and makes it much easier to
edit if necessary. It also helps improve the playback speed of the macro, since all
of the interim mouse move commands and associated delays are eliminated from
the macro.

Capture Speed
This option refers to how fast the macro plays back in relation to the recording
speed.

Speed Description
Plays the macro back at the same speed as the
Actual Speed macro was recorded. Any hesitations, etc. play

back at the same speed as recorded.

Slows down the macro playback to half of the
recording speed.

Half Speed




Speeds up the macro playback to twice the actual
recording speed.

Double Speed

Speeds up the macro playback to four times the
actual recording speed.

Quadruple Speed

Plays back the macro with no hesitations, delays,
etc. Remove the check next to the Capture at a
Fastest Speed Specific Speed box to eliminate delays from the

(no delays) macro.

Caution: Selecting this option may cause the macro to play back
too fast and throw off the timing of the macro.

After the capture is complete, optionally modify the playback speed of the macro in
the Script Editor or Direct Editor. Use the Macro Playback Speed command to do
this.

Other

Display a Prompt before Capturing

With this option selected, a message is displayed indicating that the capture is
starting.
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Macro Express Explorer > Options > Preferences > General > Dialogs

Display message while packing macro file(s)

Select this option to display the progress of the file packing. From the Macro
Express Pro - Explorer window click on Tools > Pack and choose to pack the

current file or all open .mex files.

Display periodic messages during 30-day trial
This option displays 5 reminder messages during the 30 day evaluation period.

Display program is running notification



For first time users of the program a message appears above the Macro Express
icon in the notification area. The message notifies users that the program is
running and to click on the icon to open the Macro Express Explorer window.
Clicking on the message causes it to not appear anymore.

Choose this option to have the message appear in the future.

Display the advanced file prompt

Select this option to open a dialog similar to the one below when opening an
existing macro file or creating a new one. Since Macro Express allows more than
one file to be open at a time, this dialog provides an option to decide whether to
leave existing files open or close all open files before loading in the new one.

|

Filename:
‘D:\Macros\Adjusted macro.mex | |Z|

What would you like to do
(®) Add this file to the list of open files

O Close all open files before opening this file

‘ [ ] Don't ask me this again

|
OK Cancel

Display the shortkey conflict warning

When using the Prefix key activation method for shortkey activated macros, certain
shortkey combinations may conflict with each other. For example, if a shortkey
activation is set to 'be' and a second activation is set to 'bet', 'bet' will never play
back because 'be' will always play back before typing the last "t" in "bet". The
suffix key option does not run into this potential conflict.

The warning message is just a warning of potential conflict. It will not prevent
creation of the macro or use of the shortkey.

Select the Don't show this again option to not have the warning display in the
future. The warning may be turned back on from the Dialogs preference panel as
shown above.



Warning! X

If using the "Prefix" activation method, this shortkey activation may conflict with one or more

€. macros.
You may have multiple macros launched when using this activation.

[ | Don't show this again

Display the Syntax Error dialog

If you save your macro with a syntax error, such as a Repeat without an End
Repeat or an If command without an End If, an error message will display warning
you of the error.

Syntax Error 8
|€_:, | The macro, "0pen nOteDad“' IS Gt
—

errors.
Do you want to save the macro anyway?

[ | Don't show this again

The warning is also displayed in the Messages tab of the Script Editor.

Display the Use suffix Solitary usage warning

If the Suffix Key option is selected for use with shortkey macros, this message is a
reminder that you may want to turn on the Solitary usage option, if it is not
already enabled.

Display warning when the Display icon in Notification Area

option is disabled

If you elect to not have the Macro Express icon display in the notification area by
going to the Options > Preferences > General - Notification Area tab, you will be
shown the message below providing instructions for opening the Macro Express Pro
Explorer window.



Warning! X

'0' You have turned off the display of the program icon in the Notification
¥ Area.

To return to Macro Express Pro Explorer or to shut down Macro

Express you will need to press the HotKey for the Run Macro Express
Editor system macro. By default this is <Ctrl>+<Alt>+<Shift>+W.

[ 1 Don't show this again

Inform the user when a macro has been cancelled
Select this option to have a dialog box display when a running macro is cancelled.

Prompt the user to create a variable that is not defined

This option prompts a user to define a variable to be used in the macro, but no
value has been assigned.

Prompt to enable the clipboard hook

The clipboard hook option found in the Activations > General tab of the preferences
is required if using clipboard activated macros. This message alerts the user that
the macro file contains macros that use the clipboard activation and the clipboard
hook option is not enabled.

Warn about file format when importing a text file

Receive a prompt when importing a text file (File > Import > Import Text File) to
be notified that the file must be in a specific format or the import process may not
be successful.

Warn if a macro file backup fails
Displays a message to let the user know that the .mex file backup has failed.
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This topic discusses items placed in the notification area and notification area icon
functionality. The notification area refers to the small icons in the lower right hand
corner of a conventionally configured screen (next to the clock).

Display icon in notification area

This option, when selected, places a Macro Express icon into the Windows
notification area when the Macro Express Player is active. The icon in the
notification area serves two primary purposes.

1. It readily identifies that Macro Express is running in the background.

2. It provides quick access to Macro Express.



--Left click on the icon to open the Editor.

--Right click on the icon to open a menu with options to open the editor,
access the help file or tools, suspend the program, shut down the
program, etc.

When not selected, Macro Express runs in hidden mode. This mode completely
hides the macro editor. In the absence of a notification area icon, use the system
macros that are defined for activating the editor and terminating the player. Ctrl
Alt Shift W is the default hot key to open the editor.

Show macro running status

This option displays the "Running Man" icon in the notification area during the
execution of a macro. It sighals that a macro playback is in progress.

Show recording icon

This option displays the camera icon in the notification area during the recording
(capturing) of a macro. It signals that a macro recording is in progress.

v Note: Windows 7 and later hides many of the notification area icons by default. Click on the Show
Hidden Icons icon to dispﬁ those hidden by Windows. The icon looks like a small triangle ﬂ in

Windows 7 and like this in Windows 10. Other operating systems should be similar.

Main Icon Action

Use this option to change what happens when left clicking on the Macro Express
icon in the notification area. Select from three options.

1. The default setting opens the Macro Express Explorer window.
2. Let the program do nothing when left clicking on this icon.

3. Run a macro. Specify the macro file and which macro to run. The macro runs
each time the Macro Express icon in the notification area is clicked. If the
specified macro file is no longer loaded when the icon is clicked, the macro
file will be loaded. If the "Close open macro files before loading another
macro file" option is enabled, then all other macro files will be closed.
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Miscellaneous

Remember the last tab open when restarting the editor

Select this option to have the Script Editor window remember which tab was last
opened when the editor is closed. When reopening the editor, that tab will still be
open. This function refers to the Script, Activations, Variables, Miscellaneous,
Scope, Security or Notes tabs.

Close open macro files before loading another macro file

This setting instructs the program to close any macro (.mex) files currently open in
the program when another macro file is loaded. The setting chosen will be the
default when using the File > Open File menu from the Macro Express Explorer
window. This setting also affects double clicking on a .mex macro file to load it into



the program, loading a file from a command line, or the File > Reopen menu option.

Delete temporary external script file

When the External Script command runs, a unique file containing the script is
created in the Temp folder. By default this file is deleted after the External Script
command runs. In order to debug issues with the External Script command you
may want see what was sent to the script processor. To do this, turn off this option
to save the temporary files created by the External Script command.

» Warning: Selecting this option will leave a file in the Temp folder each time the External Script
command runs.

Enhanced Wildcard Window Search

This option enhances the use of wildcards in window names when using the partial
match option. It provides some additional functionality when the command is
looking for wildcards.

Make Direct Editor the default editor

When creating or editing a macro, the Direct Editor will open by default rather than
the Script Editor.

Show All Commands option after Snippet insert

After inserting a code Snippet into the macro script, the All Commands view is
displayed in the Script Editor. With the option turned off, the Snippets view will
remain displayed.

Show deprecated commands

Some macro commands have been designated as deprecated. These commands
may be infrequently used, use out of date terminology, or are no longer supported
by newer versions of Windows. In some cases deprecated macro commands have
been replaced by new ones.

Deprecated commands are still supported in existing macros for backward
compatibility. However, they may be removed from Macro Express in the future.
Where possible we recommend that you avoid the use of deprecated macro
commands.

By default deprecated commands are not displayed or accessible from the list of
commands in the Macro Express Editor. To allow adding deprecated commands to
a macro enable the Show deprecated commands option.

Below are the commands that have been deprecated.

Play CD-ROM Stop CD-ROM Pause CD-ROM



CD-ROM Next Track CD-ROM Previous Track |CD-ROM Goto Track

CD-ROM Step CD-ROM Back Eject CD-ROM

Close CD-ROM Tray Cascade Desktop Tile Desktop Windows
Windows Horizontally

Tile Desktop Windows Windows Sizing Border Dial-Up Networking

Vertically

If Dial-Up Successful Hangup Suspend Computer

Repeat Counter

Updates
Check for Updates

Use this option to have the program check to see if any applicable updates are
available to download and install.

Automatically

Each time Macro Express is loaded the program will check to see if an update is
available. If so, a notification will be displayed in the bottom panel of the Macro
Express Pro Explorer window. Click on the notification to see a list of the changes
and a link to start the upgrade process.

Manually

Open the Macro Express About box and it will check to see if any updates are
available. If so, click on the update link to see a list of the changes and a link to
start the upgrade process.

Disabled
The progress of the update is stored in a log file, easily accessible from the
Macro Express Explorer window by clicking on Tools, Macro Logs.

Log Update Progress

Save the progress details of the update to a log file. From the Macro Express Pro
Explorer window click on Tools and then Macro Logs to view the folder containing
the log file.

Advanced Options

Save settings as defaults for all users

The preferences for Macro Express Pro are stored in each user's profile. An option
set for one user will not be available for other users. When a new user begins to
use Macro Express Pro the program's default preference settings are assigned to
that user.



The "Save settings as defaults for all users" can be used to assign preference
settings for other users of that computer. To do this, adjust the preference settings
as desired. Then select the "Save settings as defaults for all users" check box and
click the OK or Apply button. From that point on, other users of the computer will
use the same default preference settings.

Unlike all other settings in the preferences, the “Save settings as defaults for all
users” option is meant for a one time use. If this option is selected, when either
the OK or Apply button is clicked, Macro Express Pro copies all of the settings from
the HKCU area of the registry to the HKLM area. This is useful when preparing to
Export Program Configuration to use later to import the preferences or to set the
preferences when installing the program. The “Save settings as defaults for all
users” option is always unselected when the Preferences dialog is opened.

Each user may change the preferences to suit their needs. Once changed, the
default values will not apply when they are using Macro Express.

**The "Save settings as defaults for all users" option is not available in the portable version.
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Delays

When typing text on the keyboard each key is pressed and then released. Macro
Express simulates this action for each keystroke played back in a macro. A delay
between keystrokes may be required for longer strings of text, so that the text
does not play back too fast and cause a Keyboard Buffer overflow. This may result
in some of the text missing or scrambled.

These two delay options are global settings for all macros that play keystrokes. If
you do find the text playing back too fast, increase the microsecond (millionth of a
second) delay and test. Adjust as necessary.



Delay after keystroke down
A delay in the number of microseconds selected is applied after each keystroke is
pressed down.

Delay after keystroke up (previously named Delay after

keystrokes)
A delay in the number of microseconds selected is applied after each keystroke is
released.

You may choose to use no delays, one of the delays or both. The default setting is
300 microseconds with both options turned on, which should be optimal for most
systems.

Delay After Keystrokes in the Text Type Command

It is possible when typing back long strings of text that the Keyboard Buffer may
overflow. When this happens some of the text may be missing or scrambled. Or
the computer may emit an odd high pitched sound. In this situation, the text is
trying to play back too fast. This Delay option is a global setting for all macros that
use the Text Type command. The default setting is zero.

If the scrambled text or high pitched sound occurs when playing back this type
macro, then adding a delay will help. The delay is in micro seconds, or thousandths
of a millisecond. Start at 1000 microseconds, test the results and so on until finding
the ultimate setting.

Use the Hardware High Speed Timer when Possible

Some computers make use of a high speed timer. Macro Express makes use of this
timer in calculating delays. If the system does not use this timer, then leave this
option unchecked.

On other systems the timer does not work properly. Do not select this option in
this circumstance either.

Wait __ Milliseconds between Clipboard Commands

This option inserts a default 250 millisecond delay for each clipboard command in a
macro. Windows requires a little bit of time to process a clipboard command. A 250
millisecond delay is adequate for most systems.

If the clipboard commands don't seem to be responding correctly, experiment with
the timing and adjust the setting. This option also reduces the need to insert Delay
commands after each clipboard command.



Wait __ Milliseconds after Executing the Window Activate

Command

This option instructs the macro to wait a minimum of 250 seconds after activating
a window before continuing with the next macro command. The default setting is
250 milliseconds. This setting may also be adjusted as needed.
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HotKey to abort macros: |Win + End w
HotKey to pause macros: |Win + Alt + End w
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Warn if a macro log exceeds [5120 KB

Notification

[_]Play a sound when a macro runs

HotKeys

HotKey to abort macros
Choose from among three hot key combinations to stop a macro that is currently
running. For example, if the Win + ~ combination is selected, press this

combination to stop a running macro.

If displaying the Running Status icon when a macro runs, alternatively right mouse
click on the icon to terminate the macro.

v Note: The Timed Delay in Seconds command and the Wait for Time to Elapse command suspend
Macro Express for the amount of time specified. During this delay time the macro cannot be

terminated.



Please note that macros that consist of numerous keystrokes can send the
keystrokes rather quickly and Windows buffers up the keystrokes. Once such
commands have been buffered in Windows, aborting a macro does not cancel
them. In these cases, it may appear that the abort command did not work when in
reality the macro has already finished issuing its commands and Windows is now
processing them.

HotKey to pause macros

Select from among four hot key combinations to pause a macro that is currently
running. When ready to resume the macro, press the original hot key or click on
the Resume button of the Pause window that displays.

Errors

Log all errors (regardless of individual macro settings)

This is a quick way to log errors for all macros. There is ho need to individually set
the error logging for each macro through the macro properties. It automatically
logs all information as long as the error logging commands are included in the
macros. Each individual macro generates its own separate log file.

Clear error messages after seconds

If an error message generated by the Macro Express Player occurs during the
playback of a macro, this option closes the error message after the number of
seconds designated. When not selected, manually click on the OK button of the
error message to close the dialog.

The default setting to is leave this option unchecked, so that error messages are
displayed until manually closed.

v Note: Setting the time to (0) zero seconds causes the error message to be displayed indefinitely.

The Clear Error Messages option may be preferable when several macros are
scheduled to run unattended. If for some reason the first macro fails and displays
an error message, the message closes automatically after the number of seconds
specified. When the message window closes, the macro terminates and allows the
next scheduled macro to run. Otherwise the first macro would not close,
preventing subsequent macros from running as scheduled.

Typical error messages coming from the Player would be Time Out messages while
waiting for windows, a file or folder wasn't found or a networking error.

Take this action



Set a default course of action to take when the error message occurs.

« Halt the Macro - When the error occurs the macro stops and terminates.

« Ignore the Error - The error is ignored and the macro continues. Most likely
the command that generated the error is skipped.

« Handle the Error - Most of the macro commands have an error handling
option. If using Error Handling commands in the macro script immediately
following the command that generated the error, the macro will take the
actions specified.

Macro Logs

Log timestamp format

This option formats the time stamp saved in the log file to any pattern preferred.
The guide in the Date/Time help topic can be used for determining the
abbreviations and setting the time stamp.

Log unusual events
Any unusual events that occur when playing back a macro will be logged. The
information will be stored in the same file where all macro log information is stored.

Notify when unusual event logged
This option, enabled by default, displays a notification when an unusual event is
logged.

Check size of macro logs

The macro log files can become quite large over time and potentially cause
performance issues. This function will warn you if one of the log files is getting too
large. A message appears on startup of Macro Express stating that one or more log
files may be getting too large.

Warning: Macro Log too large
One or more macro log files is
getting large and may cause your

macros to slow down.

Macro Express Pro®, a Windows macro

Warn if a macro log exceeds KB



Enter the size in KB of the macro log file. When the file exceeds this size, the
warning will appear the next time Macro Express is started. The default size is
5120 KB.

The options are to ignore the error, delete the log to let it start over, rename the
existing log to retain the log information or edit the log file and delete the older
entries.

Play a sound when a macro runs

Use this function to help debug macros. When testing a macro, this will alert that
the macro has successfully started. When finished testing, you may want to turn
off this option so that the sound doesn't play every time a macro starts.

To select a sound file click the Browse button to locate a .wav file on the computer
or type the full path and file name of the .wav file.

Or select one of the system sounds available on the computer by choosing from
the drop down list. A system sound is a sound assigned to specific Program Events
within Windows such as Asterisk, Device Connect or Windows Logoff. The sounds
assigned to these events are selected in the Windows Control Panel either
individually or as part of a theme. Not all system sounds listed in the Control Panel
are available in this command.

The Default Beep sound, defined in the Control Panel, plays if a system sound is
not defined or no sound is assigned to the specified system sound in the Control
Panel.

Click on the Play button to listen to the sound. This is a handy way to quickly test if
the correct sound was selected. (The sound is played immediately upon clicking the
button.)
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Macro Express Explorer > Options > Preferences > Startup > Startup

Program Startup

Show the splash screen

Displays the Macro Express Splash screen for a few seconds while the program is
loading.

Show Macro Explorer on startup

Instructs the Macro Express Pro - Explorer to load and display when Macro Express
starts up.



Windows Startup

Run when Windows Starts Up
This option instructs Macro Express to load when Windows starts.

Wait for ___ Seconds before Initializing the Program

On some computers Windows is not completely ready for Macro Express when it
tries to load the program. This may be caused by other programs that are
loaded when Windows starts.

This option instructs Macro Express to wait the number of seconds specified to
ensure that Windows is fully loaded. Most computers do not need this delay. If
necessary, experiment with the amount of time to wait.

Command Line Parameters

Macro Express provides a number of command line parameters that are
available for use at program startup. Enter the parameters in this edit field so
that they will be in effect when the program starts on Windows startup.

For example, to have the program run in Browse Mode and in Network mode,
insert the following into the edit field: /B /N

**The Windows Startup options are not available in the portable version.




Tools

Pack

Saving macros and deleting macros from a macro file creates holes in the macro
file structure or causes it to become fragmented. The Pack command compresses
the file and fills in the holes created by the changes to the file. This is similar to
performing a defrag on a hard drive, only it will take less time.

Pack Current File
Select this option to only pack the macro file that is currently in use.

Pack All Files
Select this option to pack all macro files that are currently loaded into Macro
Express.

You may see the warning below as you begin the Pack process. Since Macro
Express uses index numbers to track each macro in the file, packing may reorder
the index numbers. This may cause the macros in the popup or floating menus to
be reordered.

Packing your macro file may decrease its size. However, after
! packing you may need to recreate any popup or floating menu
macros in this macro file.

Do you want to continue?

Yes No




Restore Keyboard & Mouse Hooks

It is possible for other programs which are run after Macro Express to improperly
install themselves into the system wide Windows keyboard hooks. This causes
Macro Express to no longer be able to monitor keystrokes and/or mouse events.
When this occurs, Macro Express will not recognize a hot key, shortkey or mouse
activated macros.

This tool reinstalls the Windows keyboard and mouse hooks used by Macro
Express. It provides Macro Express with the first look at keystrokes and mouse
movements/clicks in order to respond to hot keys, shortkeys or mouse activated
macros.



Launch Mouse Locator

The Mouse Locator tool displays the X and Y coordinates of the mouse pointer
relative to the entire screen or to the window that is active. This is useful when
wanting to include mouse clicks in macro scripts.

The locator displays the exact position of the mouse in order to plot those
coordinates into a macro. Just plug in the coordinates when using the Mouse
Commands found in the Scripting Editor or Direct Editor. (This function is not
necessary if using the Capture option.)

Also activate this window by clicking on the Launch Mouse Locator button provided
in the Mouse Move command or the Get Pixel Color command.

Mouse Locator n

Screen Position
1564, 685

Active Window
45, 64

Pixel Color
9427967 | 0x8FDBFF
R:255 G:219 B:143

RGB: #FFDB8F

If the Mouse Locator window pops up in an area of the screen that covers
important data, click on the window, hold the left mouse button down on the title
bar at the top of the window and drag to another area of your screen.

Screen Position

The set of numbers directly under Screen Position lists the position of the mouse
relative to the computer screen. When the mouse is moved, the numbers change
in relation to the mouse cursor position. The humber to the left is the X coordinate,
or how many pixels from the left edge of the screen. The number on the right is
the Y coordinate, or how many pixels the mouse is positioned from the top of the
screen.

Active Window
The set of numbers directly under Active Window lists the position of the mouse



relative to the active window or the window that has focus. When the Mouse
Locator window is first launched, it receives focus. Clicking on a window outside of
the Mouse Locator gives focus to that window. The Mouse Locator window remains
on top in order to easily read the coordinates for the window with focus.

When the mouse is moved, the numbers change in relation to the mouse position.
The number to the left is the X coordinate, or how many pixels the mouse is
positioned from the left edge of the active window. The number on the right is the
Y coordinate, or how many pixels the mouse is positioned from the top of the
active window.

Pixel Color

The color of the pixel to which the mouse is pointing is displayed in a thin bar
above the Pixel Color header.

Windows assigns a numeric value to each color, normally from 6 to 8 digits in
length. The left side is the decimal value. This is the value returned by the Get
Pixel Color command. Use the decimal value in macros that compare color values.
The right side displays the hexadecimal value in BGR format.

The middle row displays the pixel color in separate values for Red, Green and Blue.
These values are used when entering colors in programs, such as word, that accept
separate values for Red, Green and Blue.

The bottom row displays the hexadecimal pixel color value in RGB format.

Which Pixel Color formats are displayed can be adjusted using the Pixel Color
options found in Options, Preferences, Appearance, Mouse Locator.

How colors are displayed

To display colors, computers use the RGB Additive Color System. The letters R, G
and B represent Red, Green and Blue respectively. Separate values are used for
the amount of Red, Green and Blue. On a Windows computer, each color ranges
from 0, all the way off, up to 255 (or FF hexadecimal) all the way on. Combining
different values for each basic color allows millions of different colors to be
displayed. For example, White has a value of 000000, Green has a value of
OO0FFO0 and black has a value of FFFFFF.

The hexadecimal number that represents a color can also be represented as an
integer value. For example, one orange color has a hexadecimal value of
2D42D4. When displayed as an integer this value is 2966228. The Get Pixel Color
command returns the integer value of the color for a given pixel. This allows the
integer variable commands to test for specific colors in your macros.

The Mouse Locator displays colors in a variety of formats to make it convenient to



enter colors into other programs. For example, when entering a color for a web
page the color value is in hexadecimal RGB format. To enter a color in Word
requires separate integer values for Red, Green and Blue. And some
programming languages require a hexadecimal BGR (Blue, Green, Red) format.

Copy to Clipboard

You can use the Mouse Locator to get the value of a color on your computer
monitor. Make sure the Mouse Locator is the active window, then move your
mouse over the color you want and press Ctrl-c. The color will be copied to the
clipboard so you can paste it into another program.

By default, several values are copied to the clipboard including the Screen
Position of the mouse and the Pixel Color in a variety of formats. Here is an
example:

990,385,2966228,2D42D4,212,66,45,#D4422D

What is copied to the clipboard can be adjusted using the Copy To Clipboard
options found in Options, Preferences, Appearance, Mouse Locator.




Restore Program Defaults

Clicking on Tools > Restore Program Defaults from the Macro Express Pro -
Explorer menu restores the program settings back to their default values. This
primarily affects any settings made in the Options > Preference area. Other things
that may be reset include the default macro file that opens, macro sort order and

categories.



Import Program Configuration

This option imports all of the program configuration settings into Macro Express, if
the configuration settings were previously exported to a file. The file replaces the
current configuration settings in Macro Express. This would include any Preference
settings selected, macro file in use, etc.

Click on Tools > Import Program Configuration to open a browse window to
navigate to the file previously exported. Highlight the file and import.

This is a handy way to save program settings if planning to migrate to another
computer. Easily import the settings back into the program after installing Macro
Express on the other computer. If more than one user shares a computer, each
user could save their own configuration settings and load them in while they are at
work on the computer.

Another option allows the individual settings to be loaded at startup for each user
by setting a Command Line Parameter. Each individual user would need to create
their own startup shortcut in order for this to work correctly.

v Note: Importing the program configuration from a newer version of Macro Express into an older
version of the program may cause problems. The newer configuration file may contain additional

data that is not supported in the older version of Macro Express.

**This import option is not available in the portable version.




Export Program Configuration

This option saves all of the program configuration settings to a file. This includes
any Preference settings selected, macro file in use, etc. Click on Tools > Export
Program Configuration to do this. A Save File box appears prompting to name the
configuration file and select the file location. Use the Tools > Import Program
Configuration to retrieve the file and reload the settings.

This is a handy way to save program settings if planning to migrate to another
computer. Easily import the settings back into the program after installing Macro
Express on the other computer. If more than one user shares a computer, each
user could save their own configuration settings and load them in while they are at
work on the computer.

Another option allows the individual settings to be loaded at startup for each user
by setting a Command Line Parameter. Each individual user would need to create
their own startup shortcut in order for this to work correctly.

**This export option is not available in the portable version.




Sent Email Log

If keeping a log of each email sent through Macro Express, click on Tools > Sent
Email Log to view the emails sent. A window opens showing the subject,
recipient(s) and date of the email. Highlight an email and click on the View button

to display its contents.



Macro Logs

The Macro Logs menu item opens the folder where the macro logs are stored. Click
on any of the files located in the folder to review the log details.

From the Macro Express Explorer window click on Options > Preferences > File
System, File Paths tab to edit or change the location of the log files.



Building Macros with the Editors
Script Editor

Use the Script Editor to build a macro or to edit a macro already created. The
Script Editor is divided into three main sections, the Commands, the Macro Script
and the Debugging tabs. Select the commands to insert into the Macro Script. The
Macro Script is written so that the top line in the script is the first command that
plays back in the macro.

v" Note: More than one macro may be open in the editor at the same time. Tabs at the bottom of the
window allow for navigation between open macro scripts. Either click on the tab to open or press
Ctrl Alt Left Arrow or Ctrl Alt Right Arrow to move between the tabs.

M Macro Express Pro - Script Editor [Generate Random Numbers] — O X
Script Edit Debug Options View Tools Help

(151 = ¢= |
HEEH> N ===
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7 System v
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The Script tab contains the list of commands and the macro script. Additional



information about the macro can be viewed or edited in the Activations, Variables,
Miscellaneous, Scope, Security and Notes tabs.

Macro Icon and Nickname
Located near the top of the editor window is the Macro Nickname field and a macro
icon. In the example below, the icon is a red number two.

2 Macro Nickname: ‘k}enerate Random Numbers ‘

Macro Icon

The icon (in the example above, a blue number one) is displayed to the left of
the macro nickname. Click on the icon to open the Select an Icon window. Click
on the browse button to open a folder with a number of icon options. Or
navigate to another location on the hard drive to find other icons on the
computer. If an icon was not selected at the time the macro was created, the
default Macro Express icon is displayed.

Macro Nickname

The nickname is used to help remember the function of the macro. If a
nickname was entered when assigning the macro activation, the nickname is
displayed as shown in the image above. The nickname may be changed in this
field if desired.

Command View
Select from the drop down menu which command view to display.

All Commands

This option displays all of the commands that may be used in Macro Express. To
insert a command into the script, scroll until finding the command category
wanted. Click on the category to expand the list and display all of the
commands available for that category.

Double click on the command to display a window to define what the command
should do. Then click OK on the new window to insert this command into the
Macro Script.



Double clicking on some of the commands that do not require any definition
inserts the command directly into the Macro Script, without an intermediary
window.

Favorite Commands

This option displays just the commands that are assighed as favorites, making it
easier to find the most frequently used commands. From the Script Editor menu
click on Options > Customize Favorites to assign the favorites.

Code Snippets

Use the Code Snippets function to create snippets of a macro script, such as
routines for use in multiple macros. Save the code snippet to later insert into a
macro at any time. Select Code Snippets from the drop down list as shown
below to view, create or insert snippets.

Script | Activations | Variables

Code Snippets v

Add Date to File Name
Company Info

File Count EH

Open notepad

Two Random Numbers IE:)

Wait Routine IED
=

Creating a Snippet

Select (highlight) one or more lines of a macro script in the Script Editor. Right
mouse click on the highlighted lines and left click on Add to Snippets from the
menu that opens. (Or click on Edit > Add to Snippets from the menu.)

Inserting a Snippet into the Script

Highlight the Code Snippet to use and click on one of the green insert buttons to
insert the snippet into the script. The Macro Script Navigation topic below
defines where in the script the snippet will be placed.

Search for command

Use this function to quickly locate a specific command within the Commands list.
Type the first few letters of the command to find it. To look for the Password
Protection command, enter "pa" without the quotes. This highlights the Password
Protection command within the list of commands. Typing "pau" without the quotes



moves the highlight to the Pause command.

Macro Script

This area lists each of the commands that the macro will perform. The macro plays
back sequentially through the list beginning with the top item. Edit any of the
commands in the list by double clicking on the line of the script to be edited.

There is also a right mouse click context menu available for the items in the Macro
Script. Highlight the line or lines of the script needed and then right mouse click. A
context menu appears with a variety of options, also available through the
Scripting Editor menus.

One item unique to the context menu is the Edit Macro option. Right mouse click
on a Macro Run command in the script and select the Edit Macro option. The
contents of the macro from the Macro Run command are displayed in a separate
tab in the Script Editor.

Debugging Tabs

The Debugging Tabs located near the bottom of the Editor window provide
information when attempting to debug a macro. Also click on Debug > View
Variable Values or press the F5 key to see a display of all variables used in the
macro and the values saved to those variables. These are displayed when running
the macro in Test Mode.

Messages

Any syntax errors or other problems with the macro are displayed in the
Messages tab when saving a macro. This tab will alert you to potential problems
with the macro script, such as having a Repeat Start command without a
matching Repeat End, or an If command without a matching End If.

Line 2: Missing "End Repeat”

WMessages | Breakpoints |

Breakpoints
This tab displays any breakpoints that were defined in the macro for debugging



purposes. The line in the script and the command with the breakpoint are
displayed.

|Line |Command
42 Macro Run
30 Repeat Prompt Start

35 Text Type

iMessages LBreakpoints /

Macro Script Navigation
This section describes the functionality of the buttons available to help build and
modify the macro script.

Button Function Description

Inserts the macro command selected
from the Commands list above or
before the command that is highlighted
Insert Command in the Macro Script edit box. If a script
Before Selected item is not highlighted in the edit box,
the macro command is placed as the
first or uppermost item in the script.

|

Inserts the macro command selected
from the Commands list below or after
the script item that is highlighted in the
I Insert Command |Macro Script edit box. If a script item is
After Selected not highlighted in the edit box, the
macro command is placed below or
after the first or uppermost item in the
script.

- Add Command to Inserts the macro command selecteld
: from the Commands list as the last item
End of Script in the script, below all other items.




Disable
Command

Highlight a line in the Macro Script and
then click on this button. It disables the
highlighted line in the script, so that it
does run during macro playback. A red
line is drawn through the disabled
script, for a quick visual
acknowledgment.

Enable Command

Highlighting a line in the Macro Script
that is disabled displays this symbol.
Click on the button to enable the line in
the script to allow the command to run
during macro playback.

Direct Editor

Switch from the Script Editor view to
the Direct Editor.

I

Move Command
Up

Moves the highlighted command up one
spot in the Macro Script, ahead of other
script items already in place. Each click
moves the command up one space in
the script. Also highlight several
consecutive lines in the script and move
them all at the same time.

4@l

Move Command
Down

Moves the highlighted command down
one spot in the edit box, beneath the
other script items already in place.
Each click moves the command down
one space in the script. Also highlight
several consecutive lines in the script
and move them all at the same time.

Duplicate Macro
Command

Highlight one or more lines of the
macro script and click on the Duplicate
button. This adds another copy of the
command line or lines to the script. This
is essentially a one step method for
copy and paste. Or press CTRL D to
duplicate the highlighted command or
commands.

Insert Comments

Highlight a line in the macro script and
click on the Insert Comments button or
press Ctrl Alt C to open a Comments
edit box. Type any comments about the
line in the script into this box and click
OK. The comments are inserted next to
the command listed in the script.




Keyboard Shortcuts
These are the Keyboard Shortcuts available in the Script Editor.

Keystroke Action

Alt+Right Arrow Move focus to the macro script area

Alt+Left Arrow Move focus to the All Commands/Favorite Commands/Co
Alt+Down Arrow Move the text cursor to the Search for command box
Ctrl+Alt+Left Arrow |Move to the previous macro tab

Ctrl+Alt+Right Move to the next macro tab

Arrow




Activations

Typically the activation of a macro is assigned when the macro is first created.
However, this screen may be used to change the macro activation or assign more
than one activation method to a macro. Activations and details about the
activations are listed in this tab.

2 Macro Nickname: ‘benerate Random Numbers

Script | Activations | Variables | Miscellaneous | Scope | Security | Notes

e HotKey: Ctrl+Shift+R
Activate when the keys are released

Properties Add Remove
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Properties

To view the Properties, highlight an activation listed and click on the Properties
button. This opens an edit field where changes may be made to the activation
selected. For example if the activation is a hot key of Ctrl+Shift+R, assign the
activation to another combination.

Add

Click on the Add button to open the Add Activation window, as shown below. Use
this window to add a second or third activation type to your macro.



M Add Activation
Activation

HotKey
@ Shortkey
() Schedule
() Window Title
O Mouse Event
() Control Event
() Directory Modification
O System Event
() Process Event
() TCP/IP
() Clipboard Text

Shortkey
Original Shortkey: ‘rndm ‘

(® Use Global Settings (Customizable from Options | Preferences | Activations | Shortkeys)
(O Customize Settings (for this macro only)

Case Sensitivity
Match First Character's Case between Shortkey and Replacement Text
If the first letter in the text is uppercase, don't change it to lowercase
Require Exact Uppercase/Lowercase Match on Shortkey
No Case Sensitivity

Other
Do not Remove Keystrokes Typed

Cance

Remove

Highlight a macro activation and click on the Remove button to remove this
activation from the macro.




Variables

This tab lists all variables available for use in the macro. Use this option to create,
edit or delete variables.

2 Macro Nickname: |EEiECICIEN NI ‘

Script ‘ Activations | Variables | Miscellaneous ‘ Scope ‘ Security ‘ Notes ‘

Variable Name Elements Global
# Type : Control Variables
# Type : Decimal Variables
= Type : Integer Variables
N 99
Random 3
Type : Text Variables

NI

Add Properties Delete

—‘EI Generate Random Numbers

Script Editor > Variables Tab

Type

The variable type is listed in this column.

Variable Name
A list of the variable names is displayed in this column.

Elements
This column displays the number of array elements associated with the variables.

Global

If the Global check box is selected for a variable, the variable values are available
to other macros. The values may be passed using the Macro Run command or the
Variable Save and Variable Restore commands.




Add, Properties, Delete Buttons
These three buttons provide options to create a new variable, edit an existing
variable or delete it.

Variable Properties X

Variable Name: |Sales |

Variable Type: |Integer Variables v

Create as an array

-

Elements: ‘30 =

Make this variable available to macros

called by this macro

e

Add
Click on the Add button to create a new variable for use in the macro. The
Variable Properties window, as shown above, opens for generating new

variables. This option does not allow for assigning values to a variable. Use this
function to create the variable name and type. Use the Variable commands to

assign values to variables.

Variable Name
Assigh a name to the variable, preferably something that is easy to

remember or that identifies the variable. In the example above the variable

is named "sales". Variable names may not exceed 31 characters.

v Note: If assighing original names to variables, instead of using T[1], D[1], etc., then the following

characters are not allowed in the variable name: []<>,.-+=\|/*%

Variable Type

Select from the eight different types of variables. The example above
displays the Text Variable option.

Create as an Array

Select this option to set the variable as an array and then choose the nhumber

of elements to make available in the array.

Elements



Select the number of elements to place in the array. In the example
above, 30 elements have been selected, allowing for the use of up to 30
variables in the array. Array elements start with [1] and not [0]. The
variable format looks like the following:

sales[1]
sales[2]
sales[ 3]

sales[30]

Make this Variable Available to Macros Called by this Macro

The variable value may be passed between macros when using the Macro
Run command or when using the Variable Save and Variable Restore
commands.

When this option is selected the variables are also referred to as Global
variables, because they are available to other macros. When not selected,
the variable values are local and may only be seen in the current macro.

Properties
Highlight a variable that has already been created. Click on the Properties
button in order to edit the variable using the Variable Properties window.

Delete
Highlight a variable that has already been created. Click on the Delete button in
order to remove the variable selected.



Miscellaneous

£ Macro Nickname: ‘Generate Random Numbers

Script | Activations | Variables | Miscellaneous | Scope | Security | Notes

Miscellaneous
Macro is Enabled

Logging Other
[ ]Log all Errors [ ] Turn off the CAPS Lock prior to running the macro
Log all Commands D Restore the CAPS Lock state after finishing the macro

[ ] Email Macro Log when the macro completes or aborts

info@mywebsite.com

(®) Save to Default Macro Log folder
() Save to File

Browse
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Macro is Enabled

This check box shows whether the macro has been disabled or is still an active
macro. A check in the box signifies that the macro is enabled (active).

Logging

The logging option captures any error message or command logging in the macro.
Decide what to log and where to store the information. The information may also
be viewed by right clicking on the macro in the Macro Explorer window. Left click
on Macro Properties from the menu that opens. Then click on the Logging tag to
see the results.

Log All Errors
This option logs any error messages generated during playback of the macro.

Log All Commands
This option logs each command that runs successfully and date/time stamps the



command.

What to do with the Log File

After determining what to log, select what to do with the file.

Email Log File when the Macro Completes or Aborts
Use this option if the file is to be sent via email. Enter a recipient email address
and optional carbon copy and blind carbon copy addresses.

Save to Default Error Log

The log details are saved to the default error log. This log location is defined in
Options > Preferences > File Systems > File Paths. A separate log file is created
for each macro that includes logging details.

Save to File
Save the log file to the desired file hame and location. Enter the file name and
path or click on the Browse button to locate the file.

Turn Off the CAPS Lock Prior to Running a Macro

With this option selected, the macro turns off the CAPS Lock key before starting
the macro playback.

Restore the CAPS Lock State after Finishing a Macro

With this option checked, the CAPS Lock key is returned to the state it was in
before the macro ran. For example, assume that the Caps Lock key is initially
turned off and a macro runs that turns the Caps Lock key on during the playback.
After the macro has finished playing, the Caps Lock key is turned back off again. In
the previous scenario, leaving this option unchecked would keep the Caps Lock key
on after the macro finished playing.

v Note: These two CAPS Lock options previously were global options set through the Preferences in
version 3 and prior. Due to the fact that version 4 allows more than one macro to run at a time,
these settings needed to be moved to the individual macro level to avoid conflicts.



Scope

Scope essentially refers to which program or programs allow the macro to activate.
The default setting is Global for each new macro created. Choose to have the
macro run in all applications, limit it to specific programs or windows, or have it
play back in all windows and programs except for the ones specified.

£ Macro Nickname: |Generate Random Numbers ‘

Script | Activations | Variables | Miscellaneous | Scope | Security | Notes

Current Scope: Window/Program Specific >
Runs in a specific window/program

Window Title: Notepad
The window must be on top
The title is a partial match
Include hidden windows
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Global

The global option allows a macro to play back in any Windows application.

Window/Program Specific

Use this option to select a specific window or program in which the macro starts. If
the window or program selected is not active, the macro does not start. Click on
the Add Window or Add Program button to select the window or program wanted.

v" Note: A Window or Program Specific Scope does not prevent a macro from playing back in an
application not assigned in the scope. It prevents a macro from starting unless the specified window
or program is active.

For example, assume a hot key macro of F12, with a scope is set to program
specific and Notepad is the selected program. Press F12 in Wordpad and the macro
does not run. Press F12 in Notepad and the macro runs. The F12 macro may insert
text into Notepad and then later open Wordpad during the same macro. The macro
scope does not prevent this.



Global Except

The Global Except option allows the macro to play back in all Windows applications,
except in the programs or windows selected. Click on the Add Window or Add
Program button to select the window or program required.

v" Note: A hot key may only be assigned to one macro if the scope is set to General. The same hot
key may be used multiple times if the scope is assigned to Window or Program Specific.

Buttons
These four buttons are only available when using the Window/Program Specific or
Global Except scopes.

Modify
Highlight an entry made in the scope window and click on the Modify button to
change the window or program selected previously.

Add Window

Click on the Add Window button to view all windows that are currently running
on the computer. One tab lists all visible windows currently running and a
second tab lists all windows running that are hidden. Hidden windows are not
displayed when an application is running, but are active.

If the window is currently running, scroll through the list and click on the title.
The window selected is placed in the Window Title edit field. If the window is not
currently running, type the window name in the Window Title edit field.

Exact Match/Partial Match

The exact match option requires that the Window title match exactly before
the macro plays back. A partial match only requires a portion of the window
title in order to work. For example, "notep" would be sufficient to find the
"notepad" window.

The title contains wildcards

Select this option if a wildcard is included in the window title name. A
wildcard uses the " * " or " ? " characters in the title to expand the
possibilities of a match. These are similar to the wildcards used in Windows

for searches.

A Window with this Title Must Be on Top



This option plays the macro back only if the window is the current top-most
window (the one that is showing on top of all other windows). If this option is
not selected, the macro will start if the window is running in the background
and play back in whatever window has focus.

Include Hidden Windows in the Scope
By default the macro will only look for windows that are visible, not those
that run hidden and are not seen by the user. Select this option to have the

scope apply to the windows listed in the Hidden tab, as well as those that are
visible.

After making a selection, click OK and the window is listed in the Scope tab.
Repeat the process to add additional windows if necessary.

Add Program

Click on the Add Program button to view all programs that are currently running
on the computer. One tab displays the tree view of the programs in the Start
Menu. The other tab displays a list of processes currently running. Scroll
through the list or tree view and highlight the program wanted. The program
name displays in the Executable Path edit box. If the program is not found in
either tab, manually type the file name and path or click on the Browse button
to find the file on the computer.

This Program Must Have a Window on Top

This option only runs the macro if the program is the current top-most
program (the one that is showing on top of all other windows). If this option
is not selected, the macro will start if the program is running in the
background and play back in whatever program has focus.

After making a selection, click OK and the program is listed in the Scope tab.
Repeat the process to add additional programs if necessary.

Delete

Highlight an entry made in the scope window and click on the Delete button.
The scope entry previously made is removed.



Security

Use this option to password protect a macro before it can be edited, played back or
both. From the Macro Explorer, click on the Edit Macro icon to open the Script
Editor. Or double click on a defined macro in the list of macros to open the Script
Editor. Then click on the Security tab to edit the security settings. Three security
options are available.

- R R Generate Random Numbers | |
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Use separate passwords for editing and running this macro

Edit Password i
Password set __jJ

Run Password
Password not set
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Do Not Password Protect this Macro
This is the default setting. No password is required to view, edit or run the macro.

Use a Single Password to Protect this Macro

Select this option and click on the Change button to create a password. With the
password information defined, the password must be entered before viewing or
editing the contents of the macro in the Script Editor. This same password is also
required before running the macro.

Use Separate Passwords for Editing and Running This Macro

Select this option to create one password to edit the macro and another password
to run the macro. Or use a password for either the Edit or Run functions and not
use a password for the other.

Edit Password
Highlight Edit Password and click on the Change button to set up a password.



With the password information defined, the password must be entered before
viewing the contents of the macro in the Script Editor. This is one way to
prevent others from viewing the macros or being able to alter them.

Run Password

Highlight Run Password and click on the Change button to set up a password.
With this password information defined, the password must be entered before
the macro runs.

v Note: Password protect the entire macro file from viewing or editing. Also prevent Macro Express
from playing back any macros until a proper password has been entered.



Notes

This tab opens the Notes field. This is a free form text editor for keeping notes
about the macro. Make notes about what the macro does, how it is to be used or

how frequently. Essentially this field can be used to input any information about
the macro.
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Insert any comments you want to make about the macro in this field. You can bold, /faficize, underline, strike-threugh or color the text.
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The Notes field supports Rich Text editing. Optionally use colored fonts, bold,
italics, underlines and strikeouts.



Editor Menu

Editor Menu - Script

Import from Text File - (Direct Editor Only)
Use this option to import the entire text contents of a text file into the script field in
the Direct Editor.

Save Macro
Save the macro data to the macro file.

Save and Close
Save the macro data to the macro file and close the Editor.

Save All

Save all macros that are currently open in the Editor.

Print Script

Print the macro script. The script prints as displayed in the Editor.

Close Current Tab

If more than one macro is loaded in the editor, this option closes the tab (macro
script) that is currently being viewed.

Close
This option closes the Editor.



Editor Menu - Edit

Modify Command - (Script Editor Only)
To modify a command already inserted into the script, highlight that command and
do one of the following:

« Click on Edit > Modify Command from the menu

o Press Ctrl + M

« Right click on the command and select Modify Command from the context
menu

« Double click on the command

Duplicate Command - (Script Editor Only)
Use this option to make a copy of a command or string of commands in the script.
This is essentially a one step method for copy and paste. Highlight one or more
lines of the macro script and then do one of the following:

« Click on the Duplicate button

« Click on Edit > Duplicate Command from the menu

e Press CTRL + D

Comment - (Script Editor Only)
Insert a comment next to a line of script in the Editor. Highlight a line in the macro
script and do one of the following to open the Comments edit box:

« Click on the Insert Comments button =

« Click on Edit > Comment

e Press Ctrl Alt C

Type any comments about the line in the script into the Comments box and click
OK. The comments are inserted to the right of the command listed in the script.

Delete Command - (Script Editor Only)
To remove a command or commands from the script, highlight one or more lines
and do one of the following:



« Click on Edit > Delete Command from the menu
« Right mouse click on the highlighted lines and left click on Delete Command
from the context menu.

« Press the Delete key on the keyboard

Enable/Disable - (Script Editor Only)

Rather than deleting a command from the script, sometimes it may be advisable to
disable the command. A disabled line of the script does not run during macro
playback. It is displayed with a red line through the text.

Disable a command

To disable a command or commands highlight one or more lines of the macro script
and do one of the following:

« Click on the Disable button
o Click on Edit > Disable from the menu
e Press CTRL+ N

Enable a command

To enable a disabled command or commands, highlight the disabled line or lines in
the macro script and do one of the following.

« Click on the Enable button
« Click on Edit > Enable from the menu
e Press CTRL+ N

Cut

Standard Windows cut command. Removes the highlighted command from the
script and saves it to the Windows clipboard.

Copy
Standard copy to Windows clipboard command. This copies a highlighted command
in the script and saves to the clipboard.



Paste

Standard Paste from Windows clipboard. This pastes a command that was copied
to the clipboard into the script.

Undo

This option removes the last change made to the script and restores the script to
the way it was before the change was made.

Copy Command Text - (Script Editor Only)

Highlight one or more lines of the macro script. Then click on Edit > Copy
Command Text. This option copies the lines of script to the Windows clipboard.
Paste the script into another application and the contents are displayed shown in
the Script Editor.

Typically the contents display in a macro format similar to the Direct Editor script
when copying the script to the clipboard and pasting. Use the Copy Command Text
function to display the contents exactly as they are shown in the Script Editor.

Add to Snippets

Highlight one or more lines of the macro script. Click on Edit > Add to Snippets
open a prompt to assign a name to the lines of code to save. Enter a name and
click OK to save. The script lines are saved as a snippet which can easily be
inserted into other macros.

Set Text Color - (Script Editor Only)

Highlight one or more lines of the macro script and click on Edit > Set Text Color.
Select a text color and save. The text of the line or lines in the script are displayed
in the selected color.

Set Background Color - (Script Editor Only)
Highlight one or more lines of the macro script and click on Edit > Set Background



Color. Select a text color and save. The background of the line or lines in the script
are displayed in the selected color.

Clear Colors - (Script Editor Only)
Select this option to remove any text colors or background colors of the highlighted
lines.

Find

Use the Find command to locate a key word in the text of the macro being
modified. Click on Edit > Find or Ctrl F to activate the Find window as shown below.
Type in the word or phrase to find and click the Find Next button or press Enter.
The search scans the macro for a potential match. If one is found, the first item
located is highlighted. If no match is found, a message displays indicating that no
match was found.

The Find process starts from the location of the text cursor through the end of the
text.

M Find %
Find what: <ARROW LEFT> - ‘ | Find Next |
Close

Match case
Search script text

The drop down list contains the previous ten search items.

Find Again

Click on Edit > Find Again or press the F3 key to look for the next item that
matches the search criteria as discussed above. Continue using the Find Again
feature until a message displays advising that the entire replacement text has
been searched and no more matches have been found.

Replace



Use this feature to quickly replace a word found in the macro with another. Click on
Edit > Replace or Ctrl R to activate the Replace window as shown below.

. Type in the word or phrase to replace in the box next to Find What.

« Then input the replacement word or phrase in the box next to Replace With.

« Click the Find Next button to begin a search. If a match is found, the word or
phrase in the script is highlighted.

« Click on Replace to just replace that one instance of a match. Or click Replace

All to replace all matches found in the macro script.

The Replace process starts from the location of the text cursor through the end of
the text. The drop down list contains the previous ten find or replace items.

M Replace X
Find what: old v || FindNext |
Replace with: ‘M v ‘ Replace
Replace All
Match case
Close

< Be advised that in addition to replacing editable text in the macro, the command structure text may
also be replaced, which could possibly render the macro inoperable.

Goto Line - (Script Editor Only)

This option prompts to input the number of the line in the script to be viewed or
edited. This is handy for larger macros and is quicker than scrolling through the
script.

Goto Line X

Enter Line Number:
s




Select All

Select All highlights the entire macro contents of either the macro script in the
Script Editor or macro text in the Direct Editor.



Editor Menu - Debug

Test Run Macro

Press the Test Run button on the tool bar, press F9 or click through the menu
option to test run the macro open in the Editor. This is a quick way to determine if
any fine tuning is necessary. Before the macro starts, a dialog similar to the one
shown below is displayed. Choose whether to test run the macro in a specific
window or leave focus as is.

M Start Debugger in a Different Window - O X

Macro Express Pro - Explorer A
Macro Express Pro - Script Editor (Generate Random Numbers)

Macro Express Pro - Script Editor [Generate Random Numbers]

Macro Express Pro 6.hsm - HelpSmith

Macro Express Pro Explorer

Microsoft Store

Microsoft Text Input Application

Month View ?- Calendar

Program Manager

Settings

Snipping Tool

Untitled - Notepad v

OK

Which window to use will depend on the first line or two of the macro.

For example if the first line of the macro types text, then select a window from the
list where the text can be inserted. The macro needs to know where to type the
text during the debug testing. With the (Don't Switch Focus) option the macro will
attempt to insert the text into Macro Express, since this is the window that
currently has focus.

If the macro does not use mouse clicks or type text before opening a program or
window, then choose the (Don't Switch Focus) option. Or if the first line of the
macro is to open a program or window and then insert text, use the (Don't Switch
Focus) option as the macro will determine the focus.

Turning off the Switch Focus menu option, discussed below, will run the macro
without opening the Start Debugger in a Different Window dialog.

Pause (Script Editor Only)

While the macro is running in test run mode click on Debug > Pause or the Pause
button on the tool bar. This pauses the test run of the macro. Click on the Test Run



button to resume.

Stop (Script Editor Only)
While the macro is running in test run mode, click on Debug > Stop or the Stop
button on the tool bar. This stops the test run of the macro.

Toggle Breakpoint (Script Editor Only)

Highlight a line in the script to set as a breakpoint and then select the Toggle
Breakpoint menu option or press CTRL B. When test running a macro, the macro
stops at the set breakpoint. During the break, it's possible to view the Variables
window (Debug > Show Variable Values from the menu) and verify that the
variables are being populated correctly.

Press the Test Run Macro button to resume until finished or until the next
breakpoint. To remove a Breakpoint, highlight the command in the script and press
CTRL B or click on the menu item Debug > Toggle Breakpoint.

v"  Note: The breakpoints are saved when the macro is saved and are available for use the next time
the macro is run through the debugger. The breakpoints are ignored when running the macro
outside of the debug mode.

Step Options (Script Editor Only)

Select the Step Over or Step Into option to test run the macro and have the macro
pause after each line in the script. Pressing the F8 or F7 button causes the macro
to run the next command and so on, until the macro has finished. This simplifies
the process for debugging a macro.

Step Into - F7/

If the script contains a Macro Run command, pressing the F7 key or clicking on
the Step Into button loads the script of the called macro into the editor and
steps through each line of the called macro script.

Step Over - F8

If the script contains a Macro Run command, pressing the F8 key or clicking on
the Step Over button plays the called macro at the appropriate point in the
script, but does not step through the called macro.



Switch Focus (Script Editor Only)

When using the F7 or F8 key to step through a macro, it is necessary to click the
mouse to return focus to the Editor between each step. In order to avoid this,
select the Switch Focus option. The focus returns to the prior window when
stepping through a macro.

Save Before Test Run
This option saves the macro script first and then performs a test run of the macro.

Show Variable Values

The values of the variables are displayed in a separate window when debugging a
macro. Use this window to determine that the correct values are being saved to
the variables. The window displays the variable type, variable name and the
corresponding value.

Click on Debug > Show Variable Values or press the F5 key to open a window
similar to the one displayed below. Give focus back to the Script Editor, press F7,
F8, F9 or click on the Test Run button to run the macro in a test mode and watch
the window populate with the variable values. Running in test mode again clears
the values and repopulates the window with new data as the macro runs.

Generate Random Numbers - Variables n
|Name |Va|ue
-I Type : Integer Variables
Random[1] 3
Random[2] 75
Random[3] 54

Helps for Debugging Macros

1. Did the macro run or not?
Depending on the macro, it may be difficult to determine whether the macro



started and just played back incorrectly or never started at all. One method to help
determine this would be to place a Sound File command at the beginning of the
macro. The sound alerts when the macro starts.

Or log the commands and check the log file later to see if the macro at least
started. This would be beneficial for debugging Scheduled macros, where you may
not be around when the macro is set to run.

2. Variables

If you are seeing odd values being used in the macros, you may need to check
what values are being saved to variables. One method to do this would be to use
the Text Box Display command to show what values are saved to each variable.

If a variable value is not correct, you can look to see if the wrong field is being
copied and saved to a variable, not enough time was allowed to copy the value or
any number of other causes.

3. Timing

Timing may cause a macro to fail or to do unexpected things. Macro Express has
quite a few options to help. Below are several of the more common timing
commands.

a) Wait for Window Title instructs the macro to wait for the window to be ready
to accept mouse or keyboard input before continuing.

b) Delay adds a delay of a specified duration to allow Windows or the application
to be ready before accepting additional macro commands.

c) Wait for Text Playback instructs the macro to not continue until all of the text
from a Text Type command has been typed. This is useful for longer strings
of text.

d) Keystroke Speed slows down the playback of text in situations where the
receiving application has difficulty high speed input.

e) When capturing (recording) a macro, the Macro Speed command is inserted
in the first line of the macro script. Adjust the speed value to slow down or
speed up the macro playback.




Editor Menu Options

The three insert commands are the equivalents of the buttons found in the Script
Editor. These options determine where the command is positioned in the macro
script. Choose from one of the three options to be the program default.

Insert Command Before Selected - (Script Editor Only)

With this option selected, any commands added to the script are inserted above
the highlighted line in the script.

Insert Command After Selected - (Script Editor Only)

With this option selected, any commands added to the script are inserted to the
line below the highlighted line in the script.

Add Command to End of Script - (Script Editor Only)

With this option selected, any commands added to the script are inserted as the
last line of the macro script.

Example

Assume the macro script contains 10 lines and Insert
Command Before Selected is assigned as the default. A new
Text Type command needs to be inserted between lines 5
and 6. To do this, first highlight line number 6 in the script.
Then expand the Keyboard category and double click on the
Text Type command. Insert the text and click OK to save.
The Text Type command is inserted before line 6 in the
macro script.

Now, suppose the command needs to be inserted at the end
of the script. The alternate method would be to expand the
Keyboard category and highlight the Text Type command.
Click on the Add Command to End of Script button to open
the Text Type command. Insert the text and save. The
button overrides the default and places the Text Type
command at the end of the script.

Customize Favorites
The Script Editor allows for the display of all commands, code snippets or a list of



the most frequently used macro commands for quicker macro creation.

Use this Customize Favorites option to create a favorites list. Select the command
and click on the insert button to move it to the Favorites column. Click on the
Folder icon to insert a folder in the Favorites field. The directional buttons on the
right of the window allow for positioning the command in the Favorites list. When

finished, click on the OK button to save.

Click on the drop down menu in the Script Editor to display the Favorite Commands.

Customize Favorites

Macro Commands:

“ End Catch Error
“ End Error

HEnd Repeat

<€ End Switch

& Extended Math

* External Script

@ Frp Change Directory
& FTP ChMod

@ FTP Create Directory
@ F7p Delete Directory
& FTP Delete File

@ FTP Get Current Directory
& FTP Get File

& FTP Get Filesize

@ rrp Keep Alive

@ FTP List Directory

& FTP Rename File

& FTP Send File

@ 7P Site Command

& FTP Site Connect

& FTP Site Disconnect

Favorites:

w2 Editing

-E Text Box Display
----- & Text Type

----- [F] Clipboard Copy
----- 7] Clipboard Paste

----- & Wait for Key Press

----- @ Wait for Window Title

----- & Wait for Time to Elapse
v Variables and Logic

-4 AND

"‘?d. OR

-« If Variable

-« If Window

-« End If

----- & Variable Set String

----- # Variable Modify String

----- & Variable Set Integer

----- & Variable Modify Integer
----- & Variable Set Decimal

----- # Variable Modify Decimal
----- & Variahle Modifv Date/Time

s>

<@l

@l

Cancel




Editor Menu - View

Direct Editor
From the Script Editor click on View > Direct Editor to open the Direct Editor. Or

click on the Toggle Direct Editor button to change Editors.

Toolbar
Choose whether to display or hide the Toolbar containing the icons shown below.

HELE » 11 n (==

&

Line Numbers
Select this option to display line numbers next to each command in the script. The
line numbers make it easier to find specific lines in longer scripts.

Word Wrap

The word wrap selection displays several lines of macro information in the Script
Editor (if more than one line is required).



Editor Menu - Tools

Launch Mouse Locator

The Mouse Locator tool displays the X and Y coordinates of the mouse pointer
relative to the entire screen or to the window that is active. This is useful when
wanting to include mouse clicks in macro scripts.

The locator displays the exact position of the mouse in order to plot those
coordinates into a macro. Just plug in the coordinates when using the Mouse
Commands found in the Scripting Editor or Direct Editor. (This function is not
necessary if using the Capture option.)

Also activate this window by clicking on the Launch Mouse Locator button provided
in the Mouse Move command or the Get Pixel Color command.

Mouse Locator =

Screen Position
1564, 685

Active Window

45, 64

Pixel Color
9427967 |/ 0x8FDBFF
R:255 G:219 B:143
RGB: #FFDB8F

If the Mouse Locator window pops up in an area of the screen that covers
important data, click on the window, hold the left mouse button down on the title
bar at the top of the window and drag to another area of your screen.

Screen Position

The set of numbers directly under Screen Position lists the position of the mouse
relative to the computer screen. When the mouse is moved, the numbers change
in relation to the mouse cursor position. The nhumber to the left is the X coordinate,
or how many pixels from the left edge of the screen. The number on the right is
the Y coordinate, or how many pixels the mouse is positioned from the top of the
screen.

Active Window
The set of numbers directly under Active Window lists the position of the mouse



relative to the active window or the window that has focus. When the Mouse
Locator window is first launched, it receives focus. Clicking on a window outside of
the Mouse Locator gives focus to that window. The Mouse Locator window remains
on top in order to easily read the coordinates for the window with focus.

When the mouse is moved, the numbers change in relation to the mouse position.
The number to the left is the X coordinate, or how many pixels the mouse is
positioned from the left edge of the active window. The number on the right is the
Y coordinate, or how many pixels the mouse is positioned from the top of the
active window.

Pixel Color

This option displays the color of the pixel to which the mouse is pointing. Windows
assigns a numeric value to each color, normally from 6 to 8 digits in length. The
left side is the decimal value. This is the value returned by the Get Pixel Color
command. Use the decimal value in macros that compare color values. The right
side displays the hexadecimal value in BGR format.

The middle row displays the pixel color in separate values for Red, Green and Blue.
These values are used when entering colors in programs, such as word, that accept
separate values for Red, Green and Blue.

The bottom row displays the hexadecimal pixel color value in RGB format.

Which Pixel Color formats are displayed can be adjusted using the Pixel Color
options found in Options, Preferences, Appearance, Mouse Locator.

How colors are displayed

To display colors, computers use the RGB Additive Color System. The letters R, G
and B represent Red, Green and Blue respectively. Separate values are used for
the amount of Red, Green and Blue. On a Windows computer, each color ranges
from 0, all the way off, up to 255 (or FF hexadecimal) all the way on. Combining
different values for each basic color allows millions of different colors to be
displayed. For example, White has a value of 000000, Green has a value of
OO0FFO0 and black has a value of FFFFFF.

The hexadecimal number that represents a color can also be represented as an
integer value. For example, one orange color has a hexadecimal value of
2D42D4. When displayed as an integer this value is 2966228. The Get Pixel Color
command returns the integer value of the color for a given pixel. This allows the
integer variable commands to test for specific colors in your macros.

The Mouse Locator displays colors in a variety of formats to make it convenient to
enter colors into other programs. For example, when entering a color for a web
page the color value is in hexadecimal RGB format. To enter a color in Word
requires separate integer values for Red, Green and Blue. And some



programming languages require a hexadecimal BGR (Blue, Green, Red) format.

Copy to Clipboard

You can use the Mouse Locator to get the value of a color on your computer
monitor. Make sure the Mouse Locator is the active window, then move your
mouse over the color you want and press Ctrl-c. The color will be copied to the
clipboard so you can paste it into another program.

By default, several values are copied to the clipboard including the Screen
Position of the mouse and the Pixel Color in a variety of formats. Here is an
example:

990,385,2966228,2D42D4,212,66,45,#D4422D

What is copied to the clipboard can be adjusted using the Copy To Clipboard
options found in Options, Preferences, Appearance, Mouse Locator.




Direct Editor

In the Script Editor, macro commands are displayed in an easily recognized and
understood format. To achieve this simplicity, some of the details about each
command are only displayed in the edit dialog for the macro command. In the
Direct Editor, all details about each macro command are visible. When describing
these two ways of viewing macros, we refer to them as the Script and ASCII
representations.

To view the ASCII representation of a macro click View > Direct Editor from the
Script Editor menu. Note that when in the Direct Editor view, all open macros are
displayed in their ASCII form. You can use either the Script Editor or the Direct
Editor to build or edit a macro.

The Direct Editor is divided into three main components, the Commands, the Macro
Text and Edit Buttons/Debugging tabs. Select from the commands what to insert
into the Macro Text. The Macro Text reads from left to right so that the top line in
the text, starting at the left, is the first command that plays back in the macro.

The Script tab contains the list of commands and the macro script. Additional
information about the macro can be viewed or edited in the Activations, Variables,
Miscellaneous, Scope, Security and Notes tabs.

v Note: More than one macro may be open in the editor at the same time. Tabs at the bottom of the
window allow for navigation between open macro scripts.



M Macro Express Pro - Direct Editor [Generate Random Numbers] — O X
Script Edit Debug Options View Tools Help
HEEH> n |
2 Macro Nickname: |Generate Random Numbers |
Script | Activations | Variables | Miscellaneous | Scope  Security | Notes
All Commands ~ <TEXT BOX DISPLAY Content="{\\rtfl\\ansi\\ansicpgl252\\deffO\"
& Clipboard ~ <VARTIABLE SET INTEGER Option="\x05" Destination="%Random[1]%"
\ Debug <VARIABLE SET INTEGER Option="\x05" Destination="%Random[2]%"
v Deskt <VARIABLE SET INTEGER Option="\x05" Destination="%$Random[3]%"
thesi oP <TEXT BOX DISPLAY Title="Display random numbers" Content="{\\1
= Dialogs
= Explorer
i Files/Folders
@ Internet
& Keyboard =| | < >
< Logic Alt Arrow Up End Page Down Tab
* Macro Control Alt Down Backspace Enter Page Up Win
¥ Macro Express Alt Up Control ESC Shift Win Down
* Mouse Arrow Down Control Down Home Shift Down Win Up
- : Arrow Left Control Up Insert Shift Up
¢ Multimedia Arrow Right Delete Num Enter Space
> @ Network
& Registry
¥ Repeat . .
u System v FL F2 F3 F4 F5 F6 F7 F8 F9 F10 Fi11 F12 | Misc Keys Symbols Variables
Search for command ‘ |Messages |Breakpoints |Keys/
—‘x Generate Random Numbers ‘
*2/28/2020 10:17:00 AM Variables workfile.mex

Macro Icon and Nickname

The Macro Nickname field and a macro icon are displayed near the top of the Direct
Editor window. In the example below the icon is a blue number one.

1 Macro Mickname: |Generate Random Mumbers

Macro Icon

The icon (in the example above, a compass) is displayed to the left of the macro
nickname. Click on the icon to open the Select an Icon window. Click on the
browse button to open a folder with a number of icon options. Or navigate to
another location on the hard drive to find other icons on the computer. If an icon
was not selected at the time the macro was created, the default Macro Express
icon is displayed.

Macro Nickname



The nickname is used to help remember the function of the macro. If a
nickname was assigned when creating the macro, the nickname is displayed as
shown in the image above. The nickname may be changed in this field if desired.

Command View
Select from the drop down menu which command view to display.

All Commands

This option displays all of the commands that may be used in Macro Express. To
insert a command into the script, scroll until finding the command category
wanted. Click on the category to expand the list and display all of the
commands available for that category.

Double click on the command to display a window to define what the command
should do. Then click OK on the new window to insert this command into the
Macro Script.

Double clicking on some of the commands that do not require any definition
inserts the command directly into the Macro Script without an intermediary
window.

Favorite Commands

This option displays only the commands that are assigned as favorites, making
it easier to find the most frequently used commands. From the Script Editor
menu click on Options > Customize Favorites to assign the favorites.

Code Snippets

Code snippets are pieces of macro script that may be reusable in other macros.
Rather than rewriting the section of macro each time, save the lines of the
macro as a code snippet and retrieve at any time as needed.

v Note: Code Snippets may only be created and saved in the Script Editor view.

Inserting a Snippet into the Script
Highlight the Code Snippet to use and drag it onto the Direct Editor script.

Search For Command

Use this function to help locate a specific command within the Commands list. To
look for the Password Protection command, enter "pass" without the quotes. This



highlights the Password Protection command within the list of commands. Notice
that entering the "p" and the "a" first displays the Pause command. Adding the
"ss" moves the highlight to the Password Protection command.

Macro Text

This area lists each of the commands that the macro performs. The macro plays
back sequentially from top to bottom. Each command in the macro is typically
displayed on a separate line. But it is possible to insert more than one command on
a line. To insert a command into the text, place the mouse cursor where the
command should be positioned. Then select the command and it is inserted to the

right of the mouse cursor in the Macro Text field.

v Note: It is not necessary to use the Text Type command in the Direct Editor. Just type the text to
be played back directly into the edit field. Macro Express converts the text to a Text Type command
when the macro is saved and the Editor is reopened.

Debugging Tabs

These tabs provide information when trying to debug a macro. Also click on Debug
> View Variable Values or press the F5 key to see a display of all variables used in
the macro and the values saved to those variables. These are displayed when

running the macro in Test Mode.

Messages
When saving a macro, any syntax errors or other problems with the macro are

displayed in the Messages tab.

Breakpoints
This tab displays any breakpoints defined in the macro for debugging purposes.
The line number of the Break and the command are displayed.

Keys Tab

Use the Keys tab to insert symbols or other keystrokes directly into the script.

Special Keys and the F1 - F12 Keys

Click on any of the entries (keys) in the yellow box area. For example, clicking
on the Alt key places the Alt command into the Macro Text field. The Alt key
plays back in the macro at that point in the script. Or Tab to the entry and press



Enter. Click on the F1 - F12 keys to input these keystrokes in the Macro Text
field and have them play back in the macro.

Symbols

To insert a symbol into the Macro Text click on the Symbols button to display a
window with a humber of symbols. Double click on the symbol wanted and it is
inserted into the Macro Text. Or highlight the symbol and click on the OK
button. Also use this function to insert Alt Key Sequences. See the Text Type
topic for more information.

Misc Keys

Miscellaneous keystrokes such as the Print Screen, Right Window Key, etc. may
be inserted into the script. Click on the "Misc Keys" button to open the dialog as
shown below. Select the key to insert and click on the OK button. The
Miscellaneous Key is placed into the Macro Text at the location where the text

cursor is positioned.

Miscellaneous Keys X
W Keypad 3 Browser Search F18
Right Window Keypad 4 Browser Favorites F19
Print Screen Keypad 5 Browser Home F20
Scroll Lock Keypad 6 Launch Media Playe F21
Pause Keypad 7 Next Track F22
CAPS Lock Keypad 8 Previous Track F23
Num Lock Keypad 9 Stop F24
Right Control Keypad . Play/Pause Attn
Left Control Keypad / Volume Mute CrSel
Application Keypad * Volume Down ExSel
Email Keypad - Volume Up ErEOF
Launch APP 1 Keypad + F13 Play
Launch APP 2 Browser Back Fi14 Zoom
Keypad 0 Browser Forward F15 PAl
Keypad 1 Browser Refresh F16 Select
Keypad 2 Browser Stop F17 Execute
cocs




Variables

Click on the Variables button to open the Insert Variables window and choose a
variable to play back in a macro. Select the variable from the variable types
available and click on the OK button. This places the variable into the Macro
Text at the location where the cursor is positioned. Or click on the Add button to
name a new variable to use in the macro.

M Insert Variable %

Variable Name: ‘Random[3]

Available Variables:

Variable Name Elements Global
Type : Control Variables

Type : Decimal Variables

Type : Environment Variables

= Type : Integer Variables

N 99
Random 3
Type : Text Variables
Add ‘ | 0K | ‘ Cancel ‘

Direct Editor > Variables Button



Code Snippets

Use the Code Snippet function to create reusable macro code. Create common
routines or functions that may be easily inserted into other macro scripts. Save the
code snippet to later insert into a macro at any time. Select Code Snippets from
the drop down list as shown below to view, create or insert snippets.

Script | Activations | Variables

Code Snippets v

Add Date to File Name
Company Info

File Count E:P'

Open notepad

Two Random Numbers IE:\)

Wait Routine IED,
=

Creating a Snippet

Select (highlight) one or more lines of a macro script in the Script Editor. Right
mouse click on the highlighted lines and left click on Add to Snippets from the
context menu. (Or click on Edit > Add to Snippets from the Script Editor menu.)

Enter Snippet Name X

Name:

‘k:opy Routine

cace

A small dialog box opens prompting to name the snippet. The name helps to later

identify what the snippet does. Click OK to save the name and add it to the list of
existing snippets.

Inserting a Snippet into the Script

Highlight the code snippet needed and click on one of the insert buttons to insert
the snippet into the script in the location required.



Deleting a Snippet

If a code snippet is no longer needed, highlight the snippet and press the Delete
button on the keyboard. A prompt appears to verify that the snippet should be
deleted. Press Yes to delete or No to cancel.

Editing a Snippet
There is not a direct method for editing an existing code snippet. The current
method consists of the following four steps.

Insert the snippet into a macro script.

Edit the changes directly in the macro script.

Delete the snippet from the list.

Save the script changes as a new snippet with the same name as the one
deleted.

N



Capture (Record) Macros

Capture Settings

Macro Express can capture keyboard and mouse activity for later playback as a
macro. Options are available to determine what to capture and how much.
Optionally capture keystrokes, mouse movements and clicks and actual time
between actions.

There are two methods for starting a macro recording. One is to select the
activation (hot key, shortkey, etc.) before recording. The other is to define the
macro activation after recording.

Press System Hot Key to Start Capture

One of the System Macros is defined as CTRL+ALT+SHIFT+X by default. This is
the Start/Stop Capture system hot key. Pressing CTRL+ALT+SHIFT+X starts the
recording of a macro and pressing it a second time stops the recording. The default

key may be changed to another combination available in Macro Express, such as
ALT+F1.

While recording, a Camera icon displays in the Windows notification area to indicate
that a capture is taking place. Besides pressing the system hot key to stop the
recording, right click on the Camera icon to stop the capture. Open Options >
Preferences > General > Notification Area and turn off the Show Recording Status
option to not display the Camera icon.

When the recording stops, a Capture Complete window appears. Assign the
captured macro to a Hot Key, Shortkey or other activation.

Before recording a macro using the System Hot Key method, make sure that the
default settings have been defined. Select Options > Preferences > General >
Capture from the Macro Explorer to define the capture settings. These are the
settings used when utilizing the System Start/Stop Capture macro.

Click on Capture Icon to Start Capture

This option requires defining the macro activation and other information before
recording the keystrokes and mouse moves. Upon clicking on the capture icon in
the Macro Explorer window, the Create New Macro Window opens. Select an
activation and optionally assign a nickname to the macro. Click OK to open the
capture settings window to determine what to capture, etc. The options are listed
below.



Scope

The Global scope allows for the playback of the macro into any Windows program.
The Program scope indicates that the recorded macro will only play back in the
program it is recorded in. Only use the "program" option if recording all of the
macro in the same program. The macro playback will have unpredictable results, if
recording in several programs and the Program scope is selected..

Capture the Keystrokes

Select this option to record all keystrokes made during the capture process. If this
option is not selected, then only mouse moves and clicks are recorded.

When the Alt Key is Pressed, Capture It Twice

Use of the <ALT> key does not always work properly for activating menu
commands. (Example: "<ALT>f" for activating the file menu command). To
ensure that a menu command will always work, a double <ALT> is used.
(Example: "<ALT><ALT>f") Selecting this option captures a double <ALT>
whenever the ALT key is pressed. Use this option if planning to capture
keystroke commands that activate window menus.

Capture the Mouse

Choose this option to record all mouse clicks and movements made during the
capture process. If not selected, only keystrokes are recorded. There are several
mouse options to choose from.

Relative to Screen
This option captures all mouse clicks and movements in relation to the cursor's
position on the monitor.

Relative to Window
This option captures all mouse clicks and movements in relation to the
application window being used.

Capture and Restore the Window Size

This option is only available if the Relative to Window option is selected. It
remembers the size of the window when the capture occurred. When the
macro plays back, the window is resized, if necessary, to the original size
when the recording was made. This helps ensure that the mouse clicks and



movements are accurate.

Relative to Position
This option captures the mouse clicks or movements based on the last position
of the mouse cursor.

Only Capture the Mouse Clicks

Use this option to only capture the mouse clicks and the position of the mouse
click. This option captures the position where the mouse is to click and also the
mouse click itself. No other movements of the mouse are recorded.

Unless drawing or needing to record the dragging of an item, select the Only
Capture the Mouse Clicks option. This option reduces the size of the macro
considerably and makes it much easier to edit, if needed. It also increases the
playback speed of the macro, since all of the interim mouse move commands
and associated delays from the macro are eliminated.

Capture the Macro Speed At
This option actually refers to how fast the macro plays back in relation to the
recording speed.

Speed Description
Plays the macro back at the same speed as the
Actual Speed macro was recorded. Any hesitations, etc. play

back at the same speed as recorded.

Slows down the macro playback to half of the
recording speed.

Half Speed

Speeds up the macro playback to twice the actual
recording speed.

Double Speed

Speeds up the macro playback to four times the
actual recording speed.

Quadruple Speed

Plays back the macro with no hesitations, delays,
etc. Remove the check next to the Capture at a
Fastest Speed Specific Speed box to eliminate delays from the

(no delays) macro.

Caution: Selecting this option may cause the macro to play back
too fast and throw off the timing of the macro.




v Note: After the capture is complete, it is possible to modify the playback speed of the macro in the
Script Editor. Use the Macro Playback Speed command to do this.

Display a Prompt before Capturing (Capture preference option)

After pressing the system macro to start a capture, this option displays a message
indicating that the capture is about to start.

Begin Capture in Window (available when clicking on the Capture icon)
Select the program from the drop down menu in which the macro recording will
start. The drop down menu lists the windows currently open on the computer. Or
select the last active window option. This refers to the window that was open prior
to opening Macro Express Explorer to start the capture.

Press the Capture button and the program selected is brought to the foreground so
capturing may begin.



Capture a Temporary Macro

There is a quick way to capture a temporary macro for testing purposes. No
assigning of hotkeys or checking settings is required. The macro is saved
temporarily for playback. Open the application in which to record the macro and
press the system macro hot key combination of Ctrl+Alt+Shift+T to start the
capture. Next enter the keystrokes, mouse clicks and movements. When finished,
press the system macro Ctrl+Alt+Shift+X to stop the capture.

The macro is not saved as a viewable macro in the Macro Express Pro - Explorer
and cannot be edited in the Editor windows. The macro is stored in a file. Once
another macro is captured using Ctrl+Alt+Shift+T, the previously captured macro
is overwritten. The location of the file is displayed in Options > Preferences > File
System - File Paths tab. Use the File Paths preference option to change the location
of this file.

The capture of a temporary macro uses the capture settings defined in Options >
Preferences > General - Capture tab.

Run the Captured Temporary Macro

Press the system macro hot key combination of Ctrl+Alt+Shift+S to start the play
back of the temporary macro.



Quick Wizards

Multimedia Wizards

Below is a listing of each of the Multimedia wizards available.

Play Audio CD-ROM
Play an Audio CD.

« Play favorite music CDs

« Pause the CD to answer the phone

. Repeat a favorite song (go to previous, next or specific track)
« Open and close CD Tray

Play a Video Clip
Play a Video Clip.

. Display and watch a favorite video clip

Sounds and Volume
Play a sound or set audio volume, treble and bass controls.

Play an audio clip to alert of an event

Adjust volume down or up depending on music being played
Mute the volume when on the phone

Adjust treble and bass volume depending on music being played



Networking Wizards

Below is a listing of each of the Networking wizards available.

Send an Email
Send Email and attachments to one or more recipients.

« Send a set of instructions to a user. Prompt for user.

« Send a message to a specific set of friends or associates. Prompt for message.
« Send favorite pictures or other attachments

« Send data captured in the clipboard

Go to a Web Page

Go to a web site or initiate an ftp download.

« Go to a favorite web site
. Download the latest version of a software program

Work with a Network Drive
Connect, Disconnect or Toggle Network drives.

« Access the network server or another computer
« Make network connections temporary
« Bypass Network Neighborhood

Dial-Up Networking
Connect and Disconnect to the Internet and other computers using Dial-Up
Networking.

« Quick one keystroke access to dialing up the Internet and hanging up the
phone



System and Files Wizard

Below is a listing of each of the System and File wizards available.

Launch or Activate a Program
Launch a program or a document. Or switch to a program that is already running.

« Switch to an E-Mail program if it is running; otherwise, launch and run it.
« Open a Word Document

« Open a spreadsheet document

« Launch a database program

Reboot or Shut Down
Logoff, Reboot or Shut Down the computer.

« Bypass explorer, task manager, etc.
« Shut down and power off with a single command

Copy, Delete or Rename a file(s)
Copy, Delete, Rename Files. Change current folder.

« Backup files
« Delete temporary files
« Change folder prior to using an open dialog box

Change the display resolution.
Change or set the system's display resolution.

« Maintain screen resolution preferences among multiple users

« Develop presentations or .html that is optimized for all screen resolutions
« View graphics in high color resolutions

« Maintain multiple settings for laptop and desktop

Change the Default Printer

Choose a Default Printer.



« Switch between color and non color printers
« Maintain printer preferences among multiple users
o Quickly fax documents

Change Desktop Wallpaper
Change the desktop wallpaper.

« Place favorite images on the desktop

« Place a family picture on the desktop

. Tile the image (multiple copies spread over the desktop)
« Stretch, Center or Position the image on the desktop

Move or Resize a Window
Resize or Position a Window.

« Automatically position windows anywhere on the screen.

« Resize windows to allow perfect alignment of Windows

« Position the top most window in the center, top corner or anywhere on the
screen.

Maximize/Minimize a Window
Maximize, Minimize, Restore, Hide, Close Windows.

« Maximize or Minimize the Top Most Window with a keystroke
« Temporarily hide windows and then restore (unhide) them when needed
« Shut down the Top Most program with a keystroke.

Open an Explorer Folder
Open up an Explorer Folder.

« Go directly to a specified folder in Explorer
« Clean up a cookie folder

« Clean up the temp folder

« Rearrange the start menu folders

Desktop Goodies

Cascade, Tile, Minimize or Restore All Windows. Undock and suspend computer.



o Quickly unclutter the desktop
« Align all windows on the desktop with a keystroke
« Undock the computer from a docking station by pressing a key

Run Control Panel
Open up the Control Panel or run a Control Panel applet.

« Go directly to Internet Settings to make changes

. Go directly to Display properties to make changes

« Go directly to Network Options to make changes

« Go directly to System Properties to make changes

« Go directly to Accessibility Options to make changes



Text Based Wizards

Below is a listing of each of the Text Based wizards available.

Create a Reminder
Create a reminder to be displayed at a specific time.

« Create a reminder for an appointment or meeting.
« Create reminders for birthdays or anniversaries

« Create reminders for a chore

o Create reminders of an upcoming event

Paste Text or Graphics
Paste Text or Graphic images into programs automatically.

« Insert commonly used phrases, paragraphs or boilerplate into a Word
Processor, Email and other programs such as:
Answers to frequently asked questions
Sales quotes
Legal, Medical, Real Estate, etc documents
« Insert graphic images into documents.

Type the Date or Time

Type the current, future or past date or time into programs.

« Time stamp documents with today's date and time
« Date and time stamp an email
« Place yesterday's or tomorrow's date into a document

Type a Symbol

Place an international character or a symbol in programs.

. Insert Western European Language characters includingd € 6iu O E £ B i
and more

« Insert Western European Language punctuation such as i ¢

« Insert Math Symbols such as + X %o £ Va V2 34

« Insert Currency Symbols suchas ¢ £¥ $

o Insert Legal Symbols suchas® © ™



Type Some Text

Have Text, Keystrokes and Symbols typed into programs automatically.

« Insert into a Word Processor, Email and other programs commonly used
phrases such as:
Name, Address, Phone
Headers & Footers
Email Taglines
« Insert comm